Music Artwork Have/Missing List?
#1
CD Art Manager had a tool to output a have/missing list for all the art in your library.  Does anyone know of a way to create something similar in 18.1?

As a somewhat-regular contributor at fanart.tv, I find these lists very valuable.
Reply
#2
Well if you have the skill level to use SQL then you could use that via a SQL browser to create such a list. Otherwise you are talking about writing an addon that uses the JSON API to makes requests to the music libaray and generates a list
Reply
#3
I thought about that but my SQL skills are few and weak.  I may be able to hammer out something if I beat on it enough.  I was hoping someone already had something and I assume it would be more in demand for us artwork types.
Reply
#4
I can help you with the SQL if you are up for it. It is your db, I have no problem helping you look at the data. Since the end result is you contributing to fanart.tv and community benefit that is a good thing to facilitate. But you will need to take responsiblity, do backups etc., I have no idea where on a scale of nubie to tech wizard you sit.

Tell me what you want to list and I'll tell you how to do it Smile
Reply
#5
I will consider that.  You can call me noob.  I haven't used any database for years and I was rusty even back them.  I came across a guy who did something similar for video, so I may try to emulate what he did.
https://www.johannesbader.ch/2014/03/xbm...g-artwork/

As far as running on my own db, I don't think I can do that right now.  I've been hitting massive problems with music since 18.0 (can't scan properly, can't play), not to mention the new "Artist Info" folder that created a lot of dupes.  It's really a mess right now.
Reply
#6
The music db is completely different to the video, I doubt that will help you with any of the SQL. If you can find a tool that lets you browse and sumbit SQL then I can tell you what to query.

(2019-03-20, 21:11)dkoh Wrote: As far as running on my own db, I don't think I can do that right now.  I've been hitting massive problems with music since 18.0 (can't scan properly, can't play), not to mention the new "Artist Info" folder that created a lot of dupes.  It's really a mess right now.
Back up a bit there.

The new Artist Infomation Folder can not create music library entries, only add additional artist info and art. Duplicate entries will be about how your music files are tagged, and issues in scanning those tags. Which version of Kodi were you using previously? Did you migrate a previous installation or start fresh? If you can neither scan not play that suggests a network/drive access issue not something music library specific.

If you want help then come back with a debug log of these things going wrong.
Reply
#7
Fresh install, last was 17.4 (I think), clean W7 format.  The duplicates are from all the logos and artist fanarts from previous versions/add-ons that are now both in the artist folders and in the new Artist Info folder.  I'm still not certain on where everything should be, but the Wiki hints that everything artist related should now be in the 'Artist Info' folder and nothing but discart/albumart in the respective album folders.  I haven't seen what the official filenames should be either, logo.png vs. clearlogo.png, or does it matter?

I file in the normal fashion of:
E:\
- AC-DC
- - Back in Black
- Britney Spears
- - whateverthefuckshemakes
 with my Artist Info at E:\#Artist Info

I am running Win7 32 (not 64 because of remote control issues), clean installs (repeatedly), with SMBs with full credentials.  I have a pretty large library, ~3gb, ~50k albums IIRC.  I've been playing with 18 since maybe RC6 or so, but have been ignoring the artwork and the details 'til about a week or so ago.  I can scan if I leave it alone, otherwise it crashes with a C++ Windows error or a blank Windows error and a log that ends in "OUT OF MEMORY".  When playing, I can play a track or two, but if I hit < or >, the same crashes occur, or it just hangs with the spinner forever.  I've looked for broken images and have recently removed all music files, adding them back in one letter at a time.  It's now crashing only on #-H.  I mention the dupe artwork because I'm trying to minimize variables.  I feel like I'm fighting of the inevitable, and I know 7 x86's limitations, but it ran perfectly on 17.4(?) and I really don't know what to do about the remote in 64.  It's failed (the remote) on 3 different 64 machines and it's a showstopper on a dedicated HTPC.  Using http://xbmccustomregis.sourceforge.net BTW, problems getting focus on shelled Kodi.  A friend has the same problem, went to BT keyboard.

Anyways, I wasn't looking for this to be a support thread.  I won't turn down any help, but I was just looking for a way to list some more fanart to make, even on a partial library, in between me being frustrated at Kodi.  I may post a log, depending on how stuck I get, but I have some ideas first.
Reply
#8
https://forum.kodi.tv/showthread.php?tid=341179
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#9
@DaveBlake
Here's a log https://pastebin.com/S7nDhdEs

I definitely have a caching issue. Play a song, hit back and scroll through artists, and it hangs up. If it doesn't crash, the textures system wide will be missing.
Reply
#10
@dkoh

Debug mode is not enabled. Could you try again but this time enable Debug in Settings>System Settings>Logging
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#11
https://pastebin.com/p4Nckgma

I should mention...
Started a song
Hit Back to the artist list
Textures gone on everything
Hit Back again
Screen goes black, completely unresponsive, music still plays, then does the white fade-out, Windows not-responding thing
Had to kill kodi.exe manually
Reply
#12
I just installed a 2nd machine (Intel NUC) from scratch with the same W7 Pro x86 ISO and loaded the same Music library from the same SMB path and everything works fine.  Something is definitely wrong with the install on the 1st machine.
Reply



Logout Mark Read Team Forum Stats Members Help
Music Artwork Have/Missing List?0
This forum uses Lukasz Tkacz MyBB addons.