Solved Crash on startup, 32-bit fresh install with SIGILL - illegal instruction
#1
kodi.log debug log not available, never generated. I had to create ~/.kodi manually just to add advancedsettings.xml to enable logging and also created ~/.kodi/temp with no log result.

Fresh install on Lubuntu 18.04.2: Linux 4.15.0-47-generic #50-Ubuntu SMP i686 athlon i686
GPU: NV44A [GeForce 6200] driver=nouveau

Kodi won't start. (clicking icon in menu) Near immediate crash generating a crash log.

Also tried to launch via cli and with sudo with same result.

When run from terminal I get:
Illegal instruction (core dumped)
Traceback (most recent call last):
File "/user/bin/apport-unpack", line 74, in <module>
pr.extract_keys(f, bin_keys, dir)
File "/usr/lib/python3/dist-packages/problem_report.py", line 270, in extract_keys
[item for item, element in b64_block.items() if element is False])
ValueError: ['UserGroups'] has no binary content

Since I don't have kodi.log I can't see the official Git Revision, but dpkg reports this:
kodi 2:18.1+git20190217.1232-final-0bionic all

kodi_crashlog.log: paste.ubuntu.com/p/35FRyWfC4V/

Thanks in advance for any help or pointers.
Reply
#2
Sorry, first post, forgot to mention this was installed via team-xbmc/ppa.
Reply
#3
What's you cpu?
cat /proc/cpuinfo
Reply
#4
(2019-03-22, 06:40)adrienm Wrote: GPU: NV44A [GeForce 6200] driver=nouveau

GeForce 6200 is the minimum supported GPU for Kodi without hardware decoding. Just to let you know. And AFAIK we do not support nouveau. Check your distro packages for a matching driver. One driver which could work is the NVidia driver version 304.137.

You could add the graphics driver ppa and install it from there if it's not available from the Ubuntu repos: https://launchpad.net/~graphics-drivers/...ubuntu/ppa
Reply
#5
And he has a 32-bit install on a machine labeled "athlon". That GPU is 15 years old. If the CPU is a similarly old 32-bit Athlon, it doesn't support SSE2. That's would be why he's getting illegal instruction.
Reply
#6
(2019-03-23, 02:58)yasij Wrote: And he has a 32-bit install on a machine labeled "athlon". That GPU is 15 years old. If the CPU is a similarly old 32-bit Athlon, it doesn't support SSE2. That's would be why he's getting illegal instruction.
 exactly. we need sse2
Reply
#7
Thanks, I suspected as much as I continued fiddling with it. Unfortunately, 304.137 won't install on this machine. (at least not with 18.04, and I don't want to fall back to an older release if at all possible)
Reply
#8
Bummer. Yes, this is an Athlon processor and it doesn't have sse2. I was hoping to give this box a new life with kodi, but I guess a file server is all its good for now. Thanks for the help!
Reply
#9
Thread marked solved.
Got a Kodi problem? Provide us with a full Debug log (wiki)  || Useful pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || forum rules (wiki) || VPN policy (wiki)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Crash on startup, 32-bit fresh install with SIGILL - illegal instruction00
This forum uses Lukasz Tkacz MyBB addons.