[Windows] IAGL / Retro launches in the background, never foreground
#1
Kodi 18.1 and just installed IAGL and Retro. Followed all the tutorials set up for external. Though, it doesn seem to run external, it is only showing me the cores in RetroPlayer?

So... Launch IAGL, select a game, choose 'Launch' from the game selected (also tried downloading it first, no difference)... screen stays on Kodi, closes selected game menu, and goes back to IAGL screen w/ list of games... the screen never switches to Retro.  I find the retro window (small, not full screen) in the background.

how to fix?

thx
I'm not an expert but I play one at work.
Reply
#2
@zachmorris  can you help? I dont see any info on setup to ensure it launches proper in the foreground. Is this supported on Windows? thx
I'm not an expert but I play one at work.
Reply
#3
(2019-04-05, 05:13)Livin Wrote: @zachmorris  can you help? I dont see any info on setup to ensure it launches proper in the foreground. Is this supported on Windows? thx

I dont have this problem on my Windows 10 machine, and I don't think this is an issue specific to IAGL (you'd likely have the same issue with other launcher programs). I'd suggest the following:
In Kodi, my System Video settings are 'Fullscreen' and 'Use FullScreen Window'
In Retroarch, I have it set to be fullscreen (not windowed) when Retroarch is launched (open Retroarch externally and set it up to do this, then save your configuration), and my video driver is Vulkan
Reply
#4
(2019-04-07, 19:23)zachmorris Wrote:
(2019-04-05, 05:13)Livin Wrote: @zachmorris  can you help? I dont see any info on setup to ensure it launches proper in the foreground. Is this supported on Windows? thx

I dont have this problem on my Windows 10 machine, and I don't think this is an issue specific to IAGL (you'd likely have the same issue with other launcher programs). I'd suggest the following:
In Kodi, my System Video settings are 'Fullscreen' and 'Use FullScreen Window'
In Retroarch, I have it set to be fullscreen (not windowed) when Retroarch is launched (open Retroarch externally and set it up to do this, then save your configuration), and my video driver is Vulkan 

OK, thanks, I'll check it out.
I'm not an expert but I play one at work.
Reply
#5
@Livin Does the problem happen with other launchers as well (AEL, RCB)? Are you using Kodi as a shell in Windows 10?
Reply
#6
(2019-04-11, 17:27)Wintermute0110 Wrote: @Livin Does the problem happen with other launchers as well (AEL, RCB)? Are you using Kodi as a shell in Windows 10?

Dont have other launchers. Kodi is not shell.  

When using External it launches properly, using RetroPlayer (internal) it does not.

Also, seems like there is no 'watcher' to re-launch Kodi when Retro is closed?
I'm not an expert but I play one at work.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[Windows] IAGL / Retro launches in the background, never foreground00