Problem with channel change when audio changes from dd5.1 to aac
#1
Hi,

I'm struggling with this problem that i think is related to this PVR plugin.

normally tv works good, but each time i change channel from a dd5.1 to aac2.0 or the other way around, i get crazy buffering and lost audio, a channel change to another channel that have the same audio format as the last fixes the problem until again i fall on another audio format change.

as you can see in the log i tryed both using normal streaming and RTSP

log part1 ilogebetuc.kodi (paste)
log part2 okokakedov.kodi (paste)


I'm on libreelec raspberry pi 3 b+ 9.0.1

mediaportal tv server plugin is 1.20.0.140 and Tv server is 1.20.100 (using windows mediaportal clients all works perfectly, from android tv i have the same behavior of  libreelec on a latest leia)

thank you for any suggestion or  help
Reply
#2
(2019-04-04, 19:58)mrmojo666 Wrote: mediaportal tv server plugin is 1.20.0.140 and Tv server is 1.20.100 (using windows mediaportal clients all works perfectly, from android tv i have the same behavior of  libreelec on a latest leia)

thank you for any suggestion or  help

i want to add that I've tried also the same windows clients that works with native MP client, they show the same issue.

thank you
Reply
#3
another workround to temporary fix  is to toggle on/off passtrough after a channel change between different audio formats. i think it reset the audio .
Reply
#4
@margro sorry for poking directly, could you please take a look to my log to help me in find the source of my problem? thank you
Reply
#5
(2019-04-06, 14:22)mrmojo666 Wrote: @margro sorry for poking directly, could you please take a look to my log to help me in find the source of my problem? thank you

Last online 8th Feb, but he always comes back!
Reply
#6
This is something that should be fixed in the Kodi player itself. The addon does not do anything with video or audio streams. I'm afraid that I cannot help here. Posting this in the video player section might result in more useful suggestions.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#7
Thank you, i will go there to submit this
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Problem with channel change when audio changes from dd5.1 to aac00