•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   
Channels not loading
#61
(2020-07-16, 21:49)phunkyfish Wrote:
(2020-07-16, 12:35)Marcguyver Wrote: Hi everybody,

I have the same problem with my User agent but i don't know how i have to change my M3U file. My M3U works on VLC but not on KODI.

My M3U is like that :
http://provider.com:2086/login/password/1

I try to put "|http-user-agent=VLC" or "User-Agent=VLC" behind but it doesn't work.

Someone can help me?

Thanks.

Under general settings for the addon you can set a user agent.
I try to write VLC, but it doesn't work.

Thanks
Reply
#62
And if you check your debug log do you see the user-agent logged?
Maintainer of Enigma2 PVR addon: repo, docschangelog
How to create a full debug: here
Reply
#63
(2020-07-20, 22:24)phunkyfish Wrote: And if you check your debug log do you see the user-agent logged?

that's my log:

2020-07-30 17:51:10.492 T:7136   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 501
2020-07-30 17:51:10.492 T:7136   ERROR: CCurlFile::Open failed with code 501 for http://163.111.39.181:25461/LOGIN/PASSWO...AlVFVmQQSA==:
2020-07-30 17:51:10.493 T:7136   ERROR: XFILE::CFileCache::Open - failed to open source <http://163.111.39.181:25461/LOGIN/PASSWORD/728?token=SxdVXFBBDxEqY3R9ci0oPl1QBlYFXwEJU1FVAQoEBFFWVFYGAQJWBQBRUgsFUgNTRVQHAlVFVmQQSA==>
2020-07-30 17:51:10.493 T:7136   ERROR: CVideoPlayer::OpenInputStream - error opening [pvr://channels/tv/Toutes les chaînes/pvr.iptvsimple_1103552867.pvr]

Peraps the probleme is somewhere else and not with the USER-Agent... Some channel works but not all, specifically the 4K one. Maybe is a codec problem?

Have you an idea?

Thanks
Reply
#64
A 501 error usually means the server is not able to fulfill the request. So the url may invalid.

But very hard to help without a full debug log. A log snippet is not enough.
Maintainer of Enigma2 PVR addon: repo, docschangelog
How to create a full debug: here
Reply
#65
when I see an IP address in a URL, I think to myself "Pirate IPTV Service"  Angel
Reply
#66
(2020-07-08, 08:45)pacobar Wrote:
(2020-05-17, 16:32)jaum20 Wrote:
(2019-06-02, 05:31)skleist29s Wrote: For me the problem was solved, when I unchecked
"Cache m3u at local storage"
in
"Settings - PVR IPTV Simple Client"

Thank you! That worked for me

Can you elaborate this? I don´t find this settings on the addon

It only shows when "Remote path" is selected under "location"
Reply
#67
(2020-07-20, 17:28)Marcguyver Wrote:
(2020-07-16, 21:49)phunkyfish Wrote:
(2020-07-16, 12:35)Marcguyver Wrote: Hi everybody,

I have the same problem with my User agent but i don't know how i have to change my M3U file. My M3U works on VLC but not on KODI.

My M3U is like that :
http://provider.com:2086/login/password/1

I try to put "|http-user-agent=VLC" or "User-Agent=VLC" behind but it doesn't work.

Someone can help me?

Thanks.

Under general settings for the addon you can set a user agent.
I try to write VLC, but it doesn't work.

Thanks
Same here.
Guys, is there any ideas why it stopped working?
Reply
#68
(2020-09-16, 19:06)underketzer Wrote:
(2020-07-20, 17:28)Marcguyver Wrote:
(2020-07-16, 21:49)phunkyfish Wrote: Under general settings for the addon you can set a user agent.
I try to write VLC, but it doesn't work.

Thanks
Same here.
Guys, is there any ideas why it stopped working?

Hello.

I just fixed it using "Windows" as user agent under Simple Client configuration.

Hope you can fix it so easily.
Reply
#69
(2019-08-02, 16:22)pavipollo Wrote:
(2019-08-02, 14:31)DarrenHill Wrote: We haven't changed anything, so it will be your provider blocking us.

So please cast all the bile that you seem to be dumping on our doorstep (which is not the way to get things supported, in fact quite the reverse) on theirs.

A bit touchy, aren't you? If you read my post carefully you'll see that in connection to the User Agent I wrote "in which case", so if you did nothing, I do not see why you should feel offended. It remains that NOBODY, neither the developer nor Kodi's Big Shots in 4 months (this thread has been open since April) even tried to help, maybe asking some more information or giving a hint where to look for an answer, so I do not see which better help I would have had by not (rather innocently) pulling Kodi's Big Shots legs... I can assure you that if you think that an ironical "thanks guys" is bile, then it says more about you than me... Cheers!
You conveniently forgot the facts. You said: "Well, since neither the developer of IPTV Simple Client nor Kodi's Big Shots gave a sh** about this problem (thanks guys!) which rendered IPTV Simple Client unusable to me, I had to dive into the deep (for me) and find a solution myself, which I did." - and you were wrong. SO now's a great timne to apologise.
Reply
#70
Hi,

So I also just started today to experience this issue. My channels list does not even load. The strange thing is that I see this on the log:

```
2020-10-14 21:56:35.433 T:140118467798784   ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)
2020-10-14 21:56:35.433 T:140118467798784   ERROR: CCurlFile::Open failed with code 0 for "my m3u link":
2020-10-14 21:56:35.433 T:140118467798784   ERROR: Open - failed to open source <"my m3u link">
2020-10-14 21:56:35.433 T:140118467798784   ERROR: AddOnLog: PVR IPTV Simple Client: Unable to load playlist file 'my m3u link':  file is missing or empty.
```

However, If I past the link on chrome, it automatically downloads my m3u file which means the link is fine. Any idea about this @phunkyfish ?
Reply
#71
Did you try setting a user agent?
Maintainer of Enigma2 PVR addon: repo, docschangelog
How to create a full debug: here
Reply
#72
(2020-10-14, 22:05)nunojsa Wrote: Hi,

So I also just started today to experience this issue. My channels list does not even load. The strange thing is that I see this on the log:

```
2020-10-14 21:56:35.433 T:140118467798784   ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)
2020-10-14 21:56:35.433 T:140118467798784   ERROR: CCurlFile::Open failed with code 0 for "my m3u link":
2020-10-14 21:56:35.433 T:140118467798784   ERROR: Open - failed to open source <"my m3u link">
2020-10-14 21:56:35.433 T:140118467798784   ERROR: AddOnLog: PVR IPTV Simple Client: Unable to load playlist file 'my m3u link':  file is missing or empty.
```

However, If I past the link on chrome, it automatically downloads my m3u file which means the link is fine. Any idea about this @phunkyfish ?
I think it may be a cloudflare issue. Kodi for windows works, Kodi for IOS does not work. Kodi for Android does not work, CoreElec/LibreElec all have same problems.
I think but don't hold me to it, that cloudflare is redirecting the clients to a captcha. Strange how windows is not affected.
Reply
#73
(2020-10-14, 22:21)phunkyfish Wrote: Did you try setting a user agent?

Yes, I did try to change it even though I don't really know which value should I set. I tried VLC and it did not work. Does the user agent has any effect on loading the channel list? Anyways I downloaded my m3u file and changed the settings to point to local file and the channels loaded but then I cannot play any channel. I see the same error "ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)".

@SpaceBallz is right, my m3u link works perfectly fine on windows but I can confirm it fails in 2 different linux machines (an arm one and a x64) and on Firestick...
Reply
#74
(2020-10-14, 22:58)nunojsa Wrote:
(2020-10-14, 22:21)phunkyfish Wrote: Did you try setting a user agent?

Yes, I did try to change it even though I don't really know which value should I set. I tried VLC and it did not work. Does the user agent has any effect on loading the channel list? Anyways I downloaded my m3u file and changed the settings to point to local file and the channels loaded but then I cannot play any channel. I see the same error "ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)".

@SpaceBallz is right, my m3u link works perfectly fine on windows but I can confirm it fails in 2 different linux machines (an arm one and a x64) and on Firestick...

Just to add one more thing. I don't really believe my problem is related with Cloudflare since I can access trakt.tv for instance without having to enter any captcha...
Reply
#75
(2020-10-14, 23:07)nunojsa Wrote:
(2020-10-14, 22:58)nunojsa Wrote:
(2020-10-14, 22:21)phunkyfish Wrote: Did you try setting a user agent?

Yes, I did try to change it even though I don't really know which value should I set. I tried VLC and it did not work. Does the user agent has any effect on loading the channel list? Anyways I downloaded my m3u file and changed the settings to point to local file and the channels loaded but then I cannot play any channel. I see the same error "ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)".

@SpaceBallz is right, my m3u link works perfectly fine on windows but I can confirm it fails in 2 different linux machines (an arm one and a x64) and on Firestick...

Just to add one more thing. I don't really believe my problem is related with Cloudflare since I can access trakt.tv for instance without having to enter any captcha...
I am pretty sure you will find your iptv provider use cloudflare. I can open any link I want in a browser, its purely just kodi on the afore mentioned operating systems. I have even tried curl on the same OS that kodi is failing (Coreelec) via ssh, and curl downloads the m3u fine
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   



Logout Mark Read Team Forum Stats Members Help
Channels not loading0
This forum uses Lukasz Tkacz MyBB addons.