•   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 72
  •   
v19 LibreELEC Testbuilds for RaspberryPi (Kodi 19.0)
(2019-06-05, 00:17)Milhouse Wrote:
(2019-06-04, 17:00)Milhouse Wrote:
(2019-06-03, 21:31)ezar Wrote: Using #0507 works bluetooth & usb mount + wifi issues
Using #0509 works bluetooth & usb mount (wifi works fine)
Using #0513 works bluetooth & usb mount (wifi works fine)
Using #0514 bluetooth not works, usb mount works 
Using #0521 bluetooth not works, usb mount works 
Using #0528 bluetooth not works, usb mount not works

For the bluetooth in #0514, I'll take a look at the 5.1.1 kernel.  

@ezar can you test build #0604b: RPi2 - it has this BT kernel commit reverted.  
Using #0604b, BT works fine Smile thanks!

Same problem using USB automount -> http://ix.io/1KXJ 
Quote:Apr 11 18:28:41 LibreELEC udevil[442]: fuse: mountpoint is not empty
Apr 11 18:28:41 LibreELEC udevil[442]: fuse: if you are sure this is safe, use the 'nonempty' mount option
Apr 11 18:28:41 LibreELEC udevil[442]: FUSE exfat 1.3.0
Apr 11 18:28:41 LibreELEC udevil[442]: mount: mounting /dev/sda1 on /media/RETROARCH failed: No such device
Reply
(2019-06-05, 05:54)ezar Wrote:
(2019-06-05, 00:17)Milhouse Wrote:
(2019-06-04, 17:00)Milhouse Wrote: For the bluetooth in #0514, I'll take a look at the 5.1.1 kernel.  

@ezar can you test build #0604b: RPi2 - it has this BT kernel commit reverted.  
Using #0604b, BT works fine Smile thanks!

Same problem using USB automount -> http://ix.io/1KXJ 
Quote:Apr 11 18:28:41 LibreELEC udevil[442]: fuse: mountpoint is not empty
Apr 11 18:28:41 LibreELEC udevil[442]: fuse: if you are sure this is safe, use the 'nonempty' mount option
Apr 11 18:28:41 LibreELEC udevil[442]: FUSE exfat 1.3.0
Apr 11 18:28:41 LibreELEC udevil[442]: mount: mounting /dev/sda1 on /media/RETROARCH failed: No such device

Thanks, I'll continue reverting the BT commit until there is an upstream fix.

I'm now looking at the exfat issue.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2019-06-04, 21:24)Milhouse Wrote:
(2019-06-04, 18:32)KrX3D Wrote: hi,

since #0524 i cant play any videos. kodi is just "thinking" and i can see the title on the right top but nothing happens. when i update back to #0523 it works. also updating it to the newest version doesnt help

Can you test these two builds and confirm if either of them is working for you:

build #0604d: RPi2
build #0604e: RPi2 (reverts PR16070
#0604d did not work

#0604e did work Wink
Reply
(2019-06-05, 17:59)KrX3D Wrote: #0604d did not work

#0604e did work Wink

OK thanks, I've added a comment on PR16070.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I'll be downgrading fuse-exfat from 1.3.0 to 1.2.8 (there wasn't a 1.2.9) as fuse-exfat-1.3.0 seems to have compatibility issues with libfuse-2.9.9 - fuse-exfat-1.3.0 includes changes in preparation for libfuse-3.x which don't appear to be backwardly compatible with libfuse-2.x.

And no, we can't yet upgrade to libfuse-3.x as fuse-exfat-1.3.0 doesn't actually build with libfuse-3.x! So, best to avoid fuse-exfat-1.3.0 for now until it fully aligns with libfuse-3.x.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Matrix build #0605: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 35f7dcbf9c46cc1af3c1f18c596de672e250b23544a0b04b8afc7e4a541be185 (RPi)
SHA256 Checksum: 9d6f31838e3f79fe5a95d1719248863ae4ebe5ffea69fa8eaf1a35239e6a605a (RPi2)

# uname -a
Linux rpi512 5.1.7 #1 Wed Jun 5 21:22:08 BST 2019 armv6l GNU/Linux

# vcgencmd version
May 28 2019 16:24:29
Copyright © 2012 Broadcom
version f37252430f9659d04032b6e0123d7950e3f9d92c (clean) (release) (start_x)

# lsb_release
LibreELEC (Milhouse): devel-20190605212134-#0605-g17cda55 [Build #0605]

# Kodi version
Kodi (19.0-ALPHA1 Git:75c1d6b). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (17cda55, changelog) and tip of XBMC master (75c1d6b, changelog) with the following modifications: Build Highlights:
  1. Downgrade fuse-exfat to 1.2.8 due to mounting issues (thanks @KrX3D, @Fourweddings)
  2. Revert kernel Bluetooth commit to fix PS3 pairing issues (thanks @asavah, @SirMacke)
Build Details:
  1. LibreELEC.tv:
    • buildsystem: cleanup (addons) and fix (linux) (PR:3531, 14 commits, 19 files changed)
    • linux: drop ati_remote.conf modprobe file (PR:3528, 1 commit, 1 file changed)
    • cleanup initramfs build, drop support for kernel modules in initramfs (PR:3523, 10 commits, 13 files changed)
  2. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:3537 (perma): packages: mega bump
    • Updated: [env] PR:3540 (perma): linux (RPi/Generic/Allwinner): update to linux-5.1.7
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2019-06-05, 17:59)KrX3D Wrote: #0604d did not work

#0604e did work Wink

@KrX3D feedback from #16070 is that your system has a number of Python related issues which may be contributing to the issue. Can you test #0605 with a "clean" .kodi folder (without any additional addons, and minimal setting changes) and see if you can reproduce? If you are unable to reproduce, then try adding Emby, and again see if you can reproduce with #0605.

It may be that there is something else (other than Emby) installed in your system which is causing this problem, but what that is we can't tell because of the Python related "noise".

There's also something wrong with lirc on your system which is spamming errors for some reason - it looks like your installation might be an old OpenELEC system that has been upgraded to LibreELEC? A completely clean (image) installation might be a good idea at some point!
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2019-06-06, 19:06)Milhouse Wrote:
(2019-06-05, 17:59)KrX3D Wrote: #0604d did not work

#0604e did work Wink

@KrX3D feedback from #16070 is that your system has a number of Python related issues which may be contributing to the issue. Can you test #0605 with a "clean" .kodi folder (without any additional addons, and minimal setting changes) and see if you can reproduce? If you are unable to reproduce, then try adding Emby, and again see if you can reproduce with #0605.

It may be that there is something else (other than Emby) installed in your system which is causing this problem, but what that is we can't tell because of the Python related "noise".

There's also something wrong with lirc on your system which is spamming errors for some reason - it looks like your installation might be an old OpenELEC system that has been upgraded to LibreELEC? A completely clean (image) installation might be a good idea at some point!  

thanks for the info i will test that

EDIT: i just tested on my "damaged" kodi if i could play those movies/series through smb and that work fine.
so it seems to be emby related. so i will still try an clean kodi enviourment, since if it is really emby i will need to stay on 604e because emby wont make changes to solve bugs for kodi19 until the end of 2019 or even 2020....

and while im writing this, the episode was trying to start since 5 minutes and it worked on 605. so it seems that after starting an episode it takes like 5 minutes to start, but when i hit any button during that start process my raspberry freezes
Reply
(2019-06-05, 22:54)Milhouse Wrote: New LibreELEC.tv Matrix build #0605: RPi / RPi2(Supercedes previous build)

SHA256 Checksum: 35f7dcbf9c46cc1af3c1f18c596de672e250b23544a0b04b8afc7e4a541be185 (RPi)
SHA256 Checksum: 9d6f31838e3f79fe5a95d1719248863ae4ebe5ffea69fa8eaf1a35239e6a605a (RPi2)

# uname -a
Linux rpi512 5.1.7 #1 Wed Jun 5 21:22:08 BST 2019 armv6l GNU/Linux

# vcgencmd version
May 28 2019 16:24:29
Copyright © 2012 Broadcom
version f37252430f9659d04032b6e0123d7950e3f9d92c (clean) (release) (start_x)

# lsb_release
LibreELEC (Milhouse): devel-20190605212134-#0605-g17cda55 [Build #0605]

# Kodi version
Kodi (19.0-ALPHA1 Git:75c1d6b). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (17cda55, changelog) and tip of XBMC master (75c1d6b, changelog) with the following modifications: Build Highlights:
  1. Downgrade fuse-exfat to 1.2.8 due to mounting issues (thanks @KrX3D, @Fourweddings)
  2. Revert kernel Bluetooth commit to fix PS3 pairing issues (thanks @asavah, @SirMacke)
Build Details:
  1. LibreELEC.tv:
    • buildsystem: cleanup (addons) and fix (linux) (PR:3531, 14 commits, 19 files changed)
    • linux: drop ati_remote.conf modprobe file (PR:3528, 1 commit, 1 file changed)
    • cleanup initramfs build, drop support for kernel modules in initramfs (PR:3523, 10 commits, 13 files changed)
  2. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:3537 (perma): packages: mega bump
    • Updated: [env] PR:3540 (perma): linux (RPi/Generic/Allwinner): update to linux-5.1.7
 
Thanks for solve my two issues Smile
Reply
so i tried it with an fresh libreelec installation. after  installing it on an SD card i updated to #0605 and just changed the theme for touch support since i used an RP3 with touch screen for this test.
after that i tried the playback via smb which worked. so i installed emby and updated the Database, and restarted kodi. than i started an episode and after like 3 minuted i hit several buttons and kodi froze. here is the crash log

http://ix.io/1L5T
Reply
(2019-06-06, 21:01)KrX3D Wrote: so i tried it with an fresh libreelec installation. after  installing it on an SD card i updated to #0605 and just changed the theme for touch support since i used an RP3 with touch screen for this test.
after that i tried the playback via smb which worked. so i installed emby and updated the Database, and restarted kodi. than i started an episode and after like 3 minuted i hit several buttons and kodi froze. here is the crash log

http://ix.io/1L5T

That isn't a crash log, or at least it doesn't _include_ a crash log - did Kodi actually crash after your fresh install (if not this would explain the absence of any crash log). I'm guessing Kodi froze but didn't crash - if you enable debug logging and reproduce this would include more information, but it would also be interesting if #0604e behaves differently in this situation. This could also be a completely unrelated Emby bug of course...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Matrix build #0606: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: c35cdf2a9920072ff0be2950be9514731774384fd30da8cba7824f64be4695d3 (RPi)
SHA256 Checksum: ffb9522dde71791cd4c70d28831c27e02ba39a8fdb9d2a86f895455e182a1e6e (RPi2)

# uname -a
Linux rpi512 5.1.7 #1 Thu Jun 6 21:04:32 BST 2019 armv6l GNU/Linux

# vcgencmd version
May 28 2019 16:24:29
Copyright © 2012 Broadcom
version f37252430f9659d04032b6e0123d7950e3f9d92c (clean) (release) (start_x)

# lsb_release
LibreELEC (Milhouse): devel-20190606210358-#0606-g17cda55 [Build #0606]

# Kodi version
Kodi (19.0-ALPHA1 Git:e18c43c). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (17cda55, changelog) and tip of XBMC master (e18c43c, changelog) with the following modifications: Build Highlights:
  1. Amlogic: Remove Platform
Build Details:
  1. XBMC:
    • Amlogic: Remove Platform (PR:16043, 3 commits, 60 files changed)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Just discovered from #0528, 28-May-2019 onwards, for some reason OpenVPN does not open from the add ons menu, whereas any previous version it works as expected. 
It's the only add on I seem to be having and it works fine on any earlier version than 0528.
Reply
(2019-06-07, 07:43)tez1 Wrote: Just discovered from #0528, 28-May-2019 onwards, for some reason OpenVPN does not open from the add ons menu, whereas any previous version it works as expected. 
It's the only add on I seem to be having and it works fine on any earlier version than 0528.

Please enable debug logging, reboot, then try to open the OpenVPN add-on, and then upload your kodi.log and journalctl -a logs (note: if you upload the Kodi log from the LE settings addon these two logs are combined into one).

I don't think OpenVPN is provided as an add-on - the binary is included as standard with LibreELEC. Where did you install this add-on from (what repository)?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Sorry that should read VPN Manager not Open VPN
Reply
  •   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 72
  •   
 
Thread Rating:
  • 8 Vote(s) - 4.75 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 19.0)4.758
This forum uses Lukasz Tkacz MyBB addons.