The TVDB scraper is currently broken due to upgrade works at TheTVDB site. We hope this issue will be resolved quickly.

XBOX Kodi ignores TV Shows with "proper?" tvshow.nfo
#1
Bug 
my setup is XBOX ONE X, connected via NFS to a local NAS, and using FileBot on every new episode that get added.

now if I don't use FileBot to get all the metadata, Kodi will find the new episode, because my naming scheme is proper, here's an example:

Code:

.../TV Shows/Game of Thrones $ tree
.
└── Season\ 08
└── Game\ of\ Thrones\ -\ S08E01\ -\ Winterfell.mkv

with FileBot it would look something like this
Code:

.../TV Shows/Blindspot $ tree
.
├── Season\ 04
│   ├── Blindspot\ -\ S04E18\ -\ Ohana.mkv
│   ├── folder.jpg
│   └── poster.jpg
├── banner.jpg
├── clearart.png
├── fanart.jpg
├── folder.jpg
├── landscape.jpg
├── logo.png
├── poster.jpg
└── tvshow.nfo

if I try to update my library, game of thrones would get scanned but Blindspot is ignored, if I delete `tvshow.nfo` from Blindspot directory and update the library it would STILL get ignored, but If I downloaded a new TV Show and deleted the `tvshow.nfo` before updating the library it will show it the next update.

the log can be found here and the tvshow.nfo for Blindspot can be found here.
PS: I believe my issue is related to this one 340621 (thread)
Reply
#2
This sounds vaguely familiar. I helped another member recently and he quoted these same two shows, can't be you though as this is your first post.

You are missing the <episodeguide> URL from your NFO File.

See NFO_files/TV_shows (wiki)
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2019-04-18, 01:14)Karellen Wrote: This sounds vaguely familiar. I helped another member recently and he quoted these same two shows, can't be you though as this is your first post.

You are missing the <episodeguide> URL from your NFO File.

See NFO_files/TV_shows (wiki)

It’s a coencidence for sure, As I’m new to the Kodi world, and this GOT episode was released a couple of days ago Tongue
Thanks for the help and above all thanks for making Kodi and maintaining it, I will look into FileBot and how to make it add the episode guide URL or add NFO file in every new episode directory.
Reply
#4
Just for anyone who’s having the same issue, here’s a topic over at FileBot forums talking about this issue, and how it’s connected to TheTVDB API, the only work around is to turn off artwork download which will also stop FileBot from creating .NFO all together which makes FileBot sort of useless.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi ignores TV Shows with "proper?" tvshow.nfo00