Installation on Kodi 18.1 and Ubuntu 19.04
#1
Can't install on Kodi v18.1 & Ubuntu 19.04

Attempted via ubuntu official repository v4.12.12. Got the following:

"The following packages have unmet dependencies:
 kodi-pvr-mythtv : Depends: kodi-api-pvr (= 5.2.1)
E: Unable to correct problems, you have held broken packages."

Tried via Kodi "Install from zip file" github release v5.10.7. Got a failed to install from zip file notification from Kodi.

Any remedies, ideas?
Reply
#2
(2019-04-19, 21:32)jsnj Wrote: Can't install on Kodi v18.1 & Ubuntu 19.04

Attempted via ubuntu official repository v4.12.12. Got the following:

"The following packages have unmet dependencies:
 kodi-pvr-mythtv : Depends: kodi-api-pvr (= 5.2.1)
E: Unable to correct problems, you have held broken packages."

Tried via Kodi "Install from zip file" github release v5.10.7. Got a failed to install from zip file notification from Kodi.

Any remedies, ideas?
Did you add the team-xbmc repo?
there is a cosmic version in there.
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update

should install version 5.10.6 which is stable.
Reply
#3
(2019-04-19, 23:13)disaacso Wrote:
(2019-04-19, 21:32)jsnj Wrote: Can't install on Kodi v18.1 & Ubuntu 19.04

Attempted via ubuntu official repository v4.12.12. Got the following:

"The following packages have unmet dependencies:
 kodi-pvr-mythtv : Depends: kodi-api-pvr (= 5.2.1)
E: Unable to correct problems, you have held broken packages."

Tried via Kodi "Install from zip file" github release v5.10.7. Got a failed to install from zip file notification from Kodi.

Any remedies, ideas?
Did you add the team-xbmc repo?
there is a cosmic version in there.
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update

should install version 5.10.6 which is stable.   

I did add that initially as I always do when installing Kodi. But only v4.12.12 is available for Disco Dingo at the moment which isn't compatible vKodi v18.1. Not sure why zip install of the 5.10.x versions doesn't work either.
Reply
#4
(2019-04-21, 19:47)jsnj Wrote:
(2019-04-19, 23:13)disaacso Wrote:
(2019-04-19, 21:32)jsnj Wrote: Can't install on Kodi v18.1 & Ubuntu 19.04

Attempted via ubuntu official repository v4.12.12. Got the following:

"The following packages have unmet dependencies:
 kodi-pvr-mythtv : Depends: kodi-api-pvr (= 5.2.1)
E: Unable to correct problems, you have held broken packages."

Tried via Kodi "Install from zip file" github release v5.10.7. Got a failed to install from zip file notification from Kodi.

Any remedies, ideas?
Did you add the team-xbmc repo?
there is a cosmic version in there.
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update

should install version 5.10.6 which is stable.    

I did add that initially as I always do when installing Kodi. But only v4.12.12 is available for Disco Dingo at the moment which isn't compatible vKodi v18.1. Not sure why zip install of the 5.10.x versions doesn't work either. 
ah, for some reason I thought you were running cosmic.  I don't believe there is a ppa for dingo, you'll have to use the instructions on janbars github to build it yourself.
Reply
#5
you can use the unstable ppa or wait a day till 18.2 is released. Then the add-on will also be in the stable ppa
Reply
#6
(2019-04-22, 09:26)wsnipex Wrote: you can use the unstable ppa or wait a day till 18.2 is released. Then the add-on will also be in the stable ppa

I updated to latest (Leia 18.2), installed kodi-mythtv-pvr from the team-xbmc PPA, the log says it installed fine, but I still see no PVR Clients in Add-Ons. I tried installing the kodi-pvr-demo client -- still no PVR clients. 

This is on Bionic (18.04), all packages latest version. team-xbmc is the only non-Ubuntu repo on the machine.
Reply
#7
did you enable the addon in kodi?
Addons -> My Addons -> PVR Clients
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Installation on Kodi 18.1 and Ubuntu 19.0400