Default "black" Background
#1
Hi once again ,  I have redone all the panels in light shades to try and mimic apple tv's latest GUI, but am stuck on one black background that i can't locate to replace with a lighter image. In the 3rd pic below i have scrolled down to the third row of icons, thats when the black BG becomes visible behind the white panel that i have set. Have tried all the black png's in the media folder but none of them seem to be this image? am wondering if its a line of text somewhere with "diffuse black" or similar ? 
pic 1. top row highlighted, pic2 second row highlighted , pic3 third row highlighted.
Image
ImageImage
Reply
#2
it may be the background tag in the xml file
<!-- <texture background="true" colordiffuse="88FFFFFF">$INFO[Player.Art(fanart)]</texture> -->
use notepad ++ search files
Reply
#3
@the_other_guy tx , found it .
Reply
#4
@ontap,

Sorry only just saw this as have been camping with family. Can I ask why you don't just use the "lite" theme I include with the skin? If there is something that is not right with the theme (included it to try to match current AppleTV interface) please let me know so I can improve it. Changing skin code means every time I release a new version you need to go back and reapply all of your changes. Even if you make yourself a new theme, it should save you a lot of messing about applying code changes as a theme just involves changing graphic files and a theme.xml file for any colour changes.

Wyrm
Reply
#5
(2019-04-23, 17:14)wyrm Wrote: @ontap,

Sorry only just saw this as have been camping with family. Can I ask why you don't just use the "lite" theme I include with the skin? If there is something that is not right with the theme (included it to try to match current AppleTV interface) please let me know so I can improve it. Changing skin code means every time I release a new version you need to go back and reapply all of your changes. Even if you make yourself a new theme, it should save you a lot of messing about applying code changes as a theme just involves changing graphic files and a theme.xml file for any colour changes.

Wyrm
Can't remember seeing a "lite" theme , my bad , will have a look.
Reply
#6
ImageImageLite or flat lite doesn't seem to work for me , it just dims the screen so I can barely read any text , the actual colours are the same as default ? Both Pics are with colour set to "lite".
Reply
#7
(2019-04-23, 22:47)ontap Wrote: ImageImageLite or flat lite doesn't seem to work for me , it just dims the screen so I can barely read any text , the actual colours are the same as default ? Both Pics are with colour set to "lite".

@ontap,

Nope that was definitely not how it was looking last time I played with it. Will take a look when I can get near the computer. Kids home for school holidays so might be a little while before that happens.

Wyrm
Reply
#8
@ontap,

Managed to elbow son off of computer long enough to check this out. Works as expected (with a minor bug with the first line hilited). I would say your messing with the code has mucked up the images being used by the theme. Suggest you make a backup of your skin as it currently is and reinstall skin from my repo. Next change to Icon home view and then change to lite theme in settings menu.

Should be fairly close to latest AppleTV interface once you do that. Added bonus to using skin straight from my repo is that all of the images used in my media and themes directories are available uncompressed, so you can modify any that are not quite right. Let me know if you come up with something better as I only have a gen 2 AppleTV (not functioning any more) so have had to come up with theme from pictures only. Also be aware I have had to make a number of compromises to design to allow for three different generations of home screen in the one skin. One example of this is the shelf area on skin is not as tall as proper AppleTV interface as shelf code is shared with horizontal home screen view.

Let me know how you get on, and if need be I can explain how to turn you graphics mods into a new theme.

Wyrm
Reply
#9
Will do thanks , although the pics i posted yesterday are from a fresh kodi with a clean install of your skin. although I downloaded the "skin.apptv-master.zip , from GitHub , so I will try it from your repo , cheers.
Reply
#10
(2019-04-24, 23:05)ontap Wrote: Will do thanks , although the pics i posted yesterday are from a fresh kodi with a clean install of your skin. although I downloaded the "skin.apptv-master.zip , from GitHub , so I will try it from your repo , cheers.

@ontap,

By repo I meant from Github. It sounds like in that case the files you changed were not updated with the contents of the zip file. I have had this happen to me in the past, usually because I tried to update the skin while it was still in use. Change to another skin before trying to update again with your current zip file should work. Also make sure none of the skin files are open in an editor as I'm pretty sure any open files are skipped if you try to update them.

Wyrm
Reply
#11
Exactly the same as in the two pics above, I opened up a brand new clean version leia,  downloaded the shin again from GitHub , installed it , went to interface, colours changed to "LITE" , just dims the screen and still dark theme.
This is on a clean version , no edits of mine just the default skin.
Reply
#12
(2019-04-25, 10:23)ontap Wrote: Exactly the same as in the two pics above, I opened up a brand new clean version leia,  downloaded the shin again from GitHub , installed it , went to interface, colours changed to "LITE" , just dims the screen and still dark theme.
This is on a clean version , no edits of mine just the default skin.

@ontap,

Really testing my diagnostic skills here sport. Try updating from the main Kodi repo (don't use a zip). So you will be using version 1.6.0. If that does not work, I will need to see a FULL debug log so I can see what is happening as the skin starts up. Will be hitting son with a big stick later tonight to get near the computer. Will fix minor bug with hilited then, but trust me on my system changing to Lite theme changes the background to grey and the list items to grey or white if item is focused item.

Wyrm
Reply
#13
OK will try shortly , version i had from GH was 1.6.1 , although to be fair I wasn't expecting to see any grey in the "LITE" theme, BTW I have the new 4K apple tv and the gui is all pastel shades aka my edited images above.
Reply
#14
(2019-04-25, 13:15)ontap Wrote: OK will try shortly , version i had from GH was 1.6.1 , although to be fair I wasn't expecting to see any grey in the "LITE" theme, BTW I have the new 4K apple tv and the gui is all pastel shades aka my edited images above.

Please report how you get on.  I fixed the focus problem with the home screen, but lets fix whatever the issue with theme not working correctly and then we can move you back to bleeding edge. As to pastels, that's great (and does look flash) but does tend to make for BIG image files. Skin has always been designed to run on low speced hardware, so that might not be a goer, we will see. Please post images from AppleTV were I diverge greatly from the correct look and I will see what I can manage (allowing for the various constraints I am operating under). Just understand there will always be some differences as Kodi does some things different to AppleTV.

Wyrm
Reply
#15
OK ,  installed from kodi itself and lite theme works fine.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Default "black" Background00