20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

OS X Upscalers make my old iMac stutters on streaming only
#1
Hello,

I had stuttering problems hard to understand those times and I finally have a kind of explanation :

I notice that it stutters when Kodi upscales a streaming source, but not with local files (in that case everything works perfectly).

I'm able to get the video fluid by selecting the "bilinear" setting... but the quality is really degraded, compared to the default upscaler.

My config :
ooold iMac from 2009 (but still working well !)
Kodi 18.2
my streaming addons : Netflix, Catchup TV and More
setup : mirroring of screen with a videoprojector, in 1080p

I have stutters problem with the SD videos (1024x576 or so)

And the behavior of the stutters are different regarding the sources :
- in Netflix, a SD movie always stutters
- in Catchup TV and More, it's fluid in fullscreen but stutters when I zoom out the image
- I did test with the Youtube add-on, just to test, same behavior that Catchup TV and More

My question is :

I understand that maybe my setup is too old...
And maybe the computer doesn't have the time to use a good upscale, and it provokes stutters...
But in that case why does it work perfectly with local files ?
Would it be possible to increase a cache somewhere, so that Kodi would handle streaming video as well as local videos ?

If not possible, would it be able to setup a workaround, using advancedsetting.xml, to configure Kodi this way :
- with local files use default upscaler
- with streaming files use bilinear upscaler

Thanks !
And thanks to the Kodi team for that great great software Smile
Reply
#2
I just tried playing with the buffers, in advancedsetting.xml :

<cache>
            <buffermode>0</buffermode>
            <memorysize>4289999999</memorysize>
            <readfactor>1000</readfactor>
</cache>

But it changes nothing.
Reply
#3
Or could it be able, using a python script, to do something like that ? :

Know if the media is a streaming with :
TestStream = xbmc.getInfoLabel('Player.IsInternetStream')

Then
    if TestStream == 'True':

 >> Set the scaling method to bilinear

Else leave it to auto.

The question is how to set the scaling Method ?
I found this : (here)

VS_SCALINGMETHOD_NEAREST 
VS_SCALINGMETHOD_LINEAR 
VS_SCALINGMETHOD_CUBIC 
VS_SCALINGMETHOD_LANCZOS2 
VS_SCALINGMETHOD_LANCZOS3_FAST 
VS_SCALINGMETHOD_LANCZOS3 
VS_SCALINGMETHOD_SINC8 
VS_SCALINGMETHOD_BICUBIC_SOFTWARE 
VS_SCALINGMETHOD_LANCZOS_SOFTWARE 
VS_SCALINGMETHOD_SINC_SOFTWARE 
VS_SCALINGMETHOD_VDPAU_HARDWARE 
VS_SCALINGMETHOD_DXVA_HARDWARE 
VS_SCALINGMETHOD_AUTO 
VS_SCALINGMETHOD_SPLINE36_FAST 
VS_SCALINGMETHOD_SPLINE36 
VS_SCALINGMETHOD_MAX 

But I don't know how to use it...
Is it with the "xbmc.executebuiltin(function, block)" ?
Reply
#4
After exploring a bit the xbmc code (I'm not informaticien but I like trying understand...), I think the workaround I want is not possible.

Because to use a Kodi function in a python script, it as to be define in the "builtin functions", right ?
So to get "deeper" in the functions of Kodi I have to create my own builtin in C++, right ?

Well if it's the case it's too complicated for me...

Still could please just someone explain to me why the scaling method makes my computer stutter only with streaming ?

Thanks, have a good day !
Reply
#5
I would suggest you post debug logs from playing a working/not working content to help identify what may be causing the problem.  If you can save one of the streams and post the mediainfo it would be helpful as well

In the end with 10+ year old hardware, it may be time for an upgrade.
Reply
#6
Hello, thanks for your answer !

You’re right about my old iMac Smile
But on the other way, I found one or two bugs in the Leia version that made it stutters... and once corrected by the Kodi team (thanks !), it really work like a charm !
So it’s really about improving the soft, if I saw the cpu at 99,9% or something like that I wouldn’t post. But it’s not he case, Kodi is reading a 480p video in streaming and stutters when I use other upscale as bilinear. I just wander if there would be a little bug somewhere ?

Anyway, thanks again for your answer, I’ll post log as soon as possible.
Reply
#7
Hello,

Here's my log.
SORRY WRONG LOG

Here's the good one.

I start a french TV on Catchup TV and More.
Upscale method : automatic.
It opens in zoom 1.0 > It's all fluid, nothing stutters
FPS : 25

I decrease the value of the zoom, when it reaches about 0.64, it begins stutters.
FPS : about 37
It looks like Kodi tries to reach 50FPS, without success.

If I set "Bilinear" as upscale method, it doesn't stutters anymore.

> this bug is only with SD streaming sources (I can reproduce the bug with a SD stream of youtube, for example)
But it doesn't happen with 1080p sources, or with local files.
Reply
#8
Here's another log more complete, with the video components logging.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Upscalers make my old iMac stutters on streaming only00