ScummVM - Possibly bug ?
#1
I have a Pi2 whit a working OSMC Setup........ i have enabled ScummVM and i have add some games.
The games it's be stored on a PENDRIVE correctly connected to a usb port......... the games works perfectly (some choppy and issue on audio but it's playable) and all apparently it's ok.

Exit from ScummVM to back kodi skin..... when i relauch scummVm all games list it's not saved and all back to empty list............. it's normal ?
...only on your "little world" can you lay down the law...
Reply
#2
(2019-04-30, 20:16)DjDiabolik Wrote: I have a Pi2 whit a working OSMC Setup........ i have enabled ScummVM and i have add some games.
The games it's be stored on a PENDRIVE correctly connected to a usb port......... the games works perfectly (some choppy and issue on audio but it's playable) and all apparently it's ok.

Exit from ScummVM to back kodi skin..... when i relauch scummVm all games list it's not saved and all back to empty list............. it's normal ?

Hi

I had the same problem with ScummVM on my Vero 4K+, and while searching for a solution I found this thread.

After a bit of investigation, I found out that ScummVM saves its settings (including the game list) to an ini file called scummvm.ini.
In OSMC the full path to this file is supposed to be the following: /home/osmc/.kodi/userdata/addon_data/game.libretro.scummvm/resources/system

The problem is (on my system at least) that the system folder doesn't exist.

After creating the system folder (I used SSH) ScummVM automatically creates the scummvm.ini file and everything seems to be working perfectly form here on.
I didn't have to give any special permissions to any folder.
Reply
#3
(2020-04-09, 23:32)mtandrup Wrote:
(2019-04-30, 20:16)DjDiabolik Wrote: I have a Pi2 whit a working OSMC Setup........ i have enabled ScummVM and i have add some games.
The games it's be stored on a PENDRIVE correctly connected to a usb port......... the games works perfectly (some choppy and issue on audio but it's playable) and all apparently it's ok.

Exit from ScummVM to back kodi skin..... when i relauch scummVm all games list it's not saved and all back to empty list............. it's normal ?

Hi

I had the same problem with ScummVM on my Vero 4K+, and while searching for a solution I found this thread.

After a bit of investigation, I found out that ScummVM saves its settings (including the game list) to an ini file called scummvm.ini.
In OSMC the full path to this file is supposed to be the following: /home/osmc/.kodi/userdata/addon_data/game.libretro.scummvm/resources/system

The problem is (on my system at least) that the system folder doesn't exist.

After creating the system folder (I used SSH) ScummVM automatically creates the scummvm.ini file and everything seems to be working perfectly form here on.
I didn't have to give any special permissions to any folder. 

But you have create manually a empty file scummvm.ini or it's be created when you load scummvm ?
Otherwise I had heard that it was a problem related to the scummvm.ini file and i have tryed to create an empty files in some places whitout success..... how you have found the correct path to put this files ?

Otherwise i have check and i have this path on my setup:
Problably i have tryed the path but it's not works........
...only on your "little world" can you lay down the law...
Reply
#4
Hi
 
Quote:But you have create manually a empty file scummvm.ini or it's be created when you load scummvm ?

No, I did not create scummvm.ini. It was created automatically when I started ScummVM in OSMC.
 
Quote:how you have found the correct path to put this files ?

The short answer is Google. Smile
Reply
#5
Just to clarify, I'm not 100% certain that folder permissions may not contribute to the issue.

Before I solved my issue by creating the system folder, I also messed around a bit with folder permissions, but I believe that I restored all the permissions to default.

The permissions on my system folder is 755.
Reply
#6
(2020-04-10, 19:59)mtandrup Wrote: Just to clarify, I'm not 100% certain that folder permissions may not contribute to the issue.

Before I solved my issue by creating the system folder, I also messed around a bit with folder permissions, but I believe that I restored all the permissions to default.

The permissions on my system folder is 755.

Oh ok... i have already this folder on my setup. I have set the permission to 777 (anyone can access+write) but apparently it's not resolve...... need to investigate.

I have another question:
What it's your device you run scummvm ? What's the scummvm version ? You also tryed on currently osmc image ?
...only on your "little world" can you lay down the law...
Reply
#7
Hi
 
Quote:What it's your device you run scummvm ?

I have a Vero 4K+. A device made and sold by the OSMC team.
https://osmc.tv/vero/
 
Quote:What's the scummvm version ?

My version is 2.1.0.7.
 
Quote:You also tryed on currently osmc image ?

I'm not exactly sure what you mean by currently. I always let OSMC update itself automatically.
At the time of writing I'm on version 2020.03-1.
Reply
#8
(2020-04-11, 12:02)mtandrup Wrote: Hi
 
Quote:What it's your device you run scummvm ?

I have a Vero 4K+. A device made and sold by the OSMC team.
https://osmc.tv/vero/
 
Quote:What's the scummvm version ?

My version is 2.1.0.7.
 
Quote:You also tryed on currently osmc image ?

I'm not exactly sure what you mean by currently. I always let OSMC update itself automatically.
At the time of writing I'm on version 2020.03-1. 

Ops sorry... you said your device in the first message.
At this point i need to investigate..... i have tryed last night. I have created the path (777). Tryed to start scummvm and add a games (i don't thinks it's a problems if it's stored on a pendrive and not in the storage sd). Exit from scummvm. Relaunch and no works..... no scummvm.ini it's been created.
...only on your "little world" can you lay down the law...
Reply
#9
(2020-04-11, 16:17)DjDiabolik Wrote:
(2020-04-11, 12:02)mtandrup Wrote: Hi
 
Quote:What it's your device you run scummvm ?

I have a Vero 4K+. A device made and sold by the OSMC team.
https://osmc.tv/vero/
 
Quote:What's the scummvm version ?

My version is 2.1.0.7.
 
Quote:You also tryed on currently osmc image ?

I'm not exactly sure what you mean by currently. I always let OSMC update itself automatically.
At the time of writing I'm on version 2020.03-1. 

Ops sorry... you said your device in the first message.
At this point i need to investigate..... i have tryed last night. I have created the path (777). Tryed to start scummvm and add a games (i don't thinks it's a problems if it's stored on a pendrive and not in the storage sd). Exit from scummvm. Relaunch and no works..... no scummvm.ini it's been created.

Hi

Strange. I guess there’s some kind of difference, that influences the problem.

I have the games stored on the internal storage, but I agree in your assumption that it probably doesn’t matter where they are stored.
Reply



Logout Mark Read Team Forum Stats Members Help
ScummVM - Possibly bug ?0
This forum uses Lukasz Tkacz MyBB addons.