Solved Loud POP when track plays using Kodi 19.0
#1
I'm guessing this is a problem with a recent build, as I started noticing this in the past week or so.

There is a loud POP when certain tracks begin playing. The files are m4a audio, I've listened to them many times before, and I can play them now using VLC via an NFS share without the POP.

I'm running the latest 19.0+git20190502.0203-b0f9314-0bionic on a Ubuntu Linux 18.04 server.

The audio comes out of the HDMI port, which is attached by a cable to a stereo amp.

The selected audio output device is "HDA Intel PCH, BNQ benQ PJ on HDMI #0". "Allow Passthrough" is disabled. "Crossfade between songs on the same album" is enabled.

Any suggestions?
Reply
#2
A debug log of playing with "pop" may be useful. Even more would be if you could identify which v19 nighty this issue starts happening with.
Reply
#3
(2019-05-02, 11:50)DaveBlake Wrote: A debug log of playing with "pop" may be useful. Even more would be if you could identify which v19 nighty this issue starts happening with.
Here's the log: http://paste.ubuntu.com/p/HYT.../

I'm not sure how to identify which version this started with. I usually update to the latest build every day or two, and I first noticed this problem within the past week.
Reply
#4
Code:
2019-05-02 20:35:26.737 T:140613591435392 NOTICE: Disabled debug logging due to GUI setting. Level 0.

Please enable Debugging and restart Kodi for a clean log file, reproduce the error(s) and provide the new log file.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
(2019-05-02, 13:43)Klojum Wrote:
Code:
2019-05-02 20:35:26.737 T:140613591435392 NOTICE: Disabled debug logging due to GUI setting. Level 0.

Please enable Debugging and restart Kodi for a clean log file, reproduce the error(s) and provide the new log file.

Sorry, trying again: http://paste.ubuntu.com/p/S2v***/
Reply
#6
(2019-05-02, 13:54)mrob Wrote:
(2019-05-02, 13:43)Klojum Wrote:
Code:
2019-05-02 20:35:26.737 T:140613591435392 NOTICE: Disabled debug logging due to GUI setting. Level 0.

Please enable Debugging and restart Kodi for a clean log file, reproduce the error(s) and provide the new log file.

Sorry, trying again: http://paste.ubuntu.com/p/S2v***/  
Do I need to provide any other information...?
Reply
#7
Sorry for silence, nothing obvious to me in that log this needs a PAPlayer expert to dig deeper (and finding someone wth time takes time).

But it looks like it could have been caused by this 15980 (PR), and therfore is fixed by 16061 (PR)

Perhaps try the next v19 nightly.
Reply
#8
(2019-05-05, 08:16)DaveBlake Wrote: Sorry for silence, nothing obvious to me in that log this needs a PAPlayer expert to dig deeper (and finding someone wth time takes time).

But it looks like it could have been caused by this 15980 (PR), and therfore is fixed by 16061 (PR)

Perhaps try the next v19 nightly.
Thanks! I'll try the next v19 build, test it, and report back. Smile
Reply
#9
Okay, I've updated to the latest 19.0+git20190506.0203-2eef5af-0bionic build, and the loud popping sound is no longer happening.

Marking this thread solved !!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Loud POP when track plays using Kodi 19.000