Kodi zap works only one time when using live TV
#1
Hi,

I have a strange problem on 1 of my devices which i run kodi on.
I have multiple devices with kodi(18) such as running on windows 10, andriod, intel nuc and a raspberiPY

With the last one (raspberryPI) i have a problem, it runs on last librelec(so also does my intel nuc) and i use the LIVE TV option.

I installed simple IPTV pvr addon and ENIGMA2 pvr addon.
I configured both addons and i have on both perfect picture and sound, i have exactly the same running on my intel nuc and windows laptop.

The following problem only occurs on the PI, other systems do not have this issue:

When i watch TV, doesn't matter which channel or from which serivce and i zap to the next channel (channel UP or DOWN), which can be done by keyboard PageUP or Down of using remote etc, this also doesn't matter for the problem then the PI zap perfectly to the next TV channel.
It shows the INFO screen of the channel and then TV picture.

Now the problem starts, when i try to zapp again NOTHING happens..... It doesn't matter how i zap, up/down, with keyboard, remote etc it does NOT work anymore, which service i am watching (iptv or enigma2).
I have to open channel list and choose then a channel to watch...

On my other systems i can keep zapping until the battery dry out but on the RASP it only zap 1 time up or down and then it stops zapping.

When i leave the LIVE TV menu and start it again i again can zap 1 time up or down and the problem is back again...
I removed/reinstalled both pvr services, also tried only one, the problem keeps coming back. I also tried to remap the buttons, remapping works fine but the problem then popups with the new buttons also.

I really have no idea what could cause this, is this a bug, is it a setting or something else?

Anyone an idea how to fix this?

Again:
I have several devices with same setup and setting, only other hardware and none of the other devices have this problem.
Reply
#2
Same here on a Pi Zero. I tried LibreELEC, OpenELEC and OSMC. The behavior is the same as described above. It seems that after the first channel switch Kodi thinks it is in Videoplayer instead of Live TV. I have attached a debug log where you can see, that the first keystroke of pageup is mapped to action ChannelUp, while the further ones are mapped to SkipNext.

kodi.log
Reply
#3
(2019-05-09, 22:29)Doesi Wrote: Same here on a Pi Zero. I tried LibreELEC, OpenELEC and OSMC. The behavior is the same as described above. It seems that after the first channel switch Kodi thinks it is in Videoplayer instead of Live TV. I have attached a debug log where you can see, that the first keystroke of pageup is mapped to action ChannelUp, while the further ones are mapped to SkipNext.

kodi.log

Same here. RPi 3 with LibreElec 9.0.1 and 9.0.2 und TVHeadend 4.3-1789.
Reply
#4
@Doesi: Which PVR backend do you use?
Reply
#5
(2019-05-11, 22:17)_nico Wrote: @Doesi: Which PVR backend do you use?

Tvheadend

The same configuration on a Pi 3 B+ works as expected, the problem is only on the Pi Zero W.
Reply
#6
The hardware acceleration OMX is the problem, with MMAL no problems with live tv and channel switching.

Disable OMXPlayer and enable MMAL under Kodi > Settings > Player

Image
Reply
#7
Image
Reply
#8
Thumbs Up 
(2019-05-14, 09:33)_nico Wrote: The hardware acceleration OMX is the problem, with MMAL no problems with live tv and channel switching.

Disable OMXPlayer and enable MMAL under Kodi > Settings > Player

Indeed, that did the trick! Thanks for your help.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi zap works only one time when using live TV00