v18 MySQL Streamdetails strVideoCodec vc1 vs vc-1
#1
Summary: BD ISO with codec VC-1 is added to database table streamdetails column videocodec as 'vc1', which Confluence skin does not recognize as VC1.. (it seems to expect 'vc-1')

Hardware: Amazon FireTV 4k Stick, GigE Ethernet (per best practices 336151 (thread) )
Software:  kodi-18.2-Leia-armeabi-v7a.apk
Database: MySQL 5.1.73

MySQL -> MyVideos116.streamdetails Column: strVideoCodec 
If the value is: 'vc-1" the Confluence skin displays a nice VC1 
Image
If the value is: 'vc1" the Confluence skin has an absence of VC1

Image

Log: hoseboqabe.kodi (paste)

It's pretty clear from the above log that Kodi is writing the 'vc1' value into the strVideoCodec column.  And the log also shows the Confluence skin unable to find the resource:
[Warning] CGUITextureManager::GetTexturePath: could not find texture 'flagging/video/vc1.png'
.. so maybe there is something wrong with my install or advancedsettings.xml 


Comments: I do not like being the one to open a new ticket.  I did some searching on strVideoCodec and streamdetails to attempt to find this.  vc1 and vc-1 are too short as search terms.  Also, vc-1 ISO files make up a small portion of my library.  I really hope I have provided everything and this report is helpful.
Reply
#2
(2019-05-15, 10:42)thefrog Wrote: Comments: I do not like being the one to open a new ticket. 

Normally I'd call those people lazy, but here you are opening a forum thread with plenty of information into a Bug Tracker ticket all the same. Smile

A pro tip: when you enable debugging, restart Kodi so it debugs from the start, otherwise certain bugs/errors might not appear.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#3
(2019-05-15, 12:40)Klojum Wrote:
(2019-05-15, 10:42)thefrog Wrote: Comments: I do not like being the one to open a new ticket. 
Normally I'd call those people lazy, but here you are opening a forum thread with plenty of information into a Bug Tracker ticket all the same. Smile

A pro tip: when you enable debugging, restart Kodi so it debugs from the start, otherwise certain bugs/errors might not appear. 

Probably the fear of making a foolish mistake.  I am in the midst of BD-Rebuilding all my VC1s to h.x264 to overcome some hardware limitations of my device.  I had noticed this problem in the past (Kodi 17.6?  earlier?) but I figured I should probably report it now that I had caught up with the current production release.

I have acquired new screencaps and new logs from a restart of Kodi with the logging turned on.  Also, it's a different ISO/DB entry (the Film is '9').

Starts with a nice looking Movie Info:
Image
Immediately after the film ends, the Media Info box looks like this:
Image

Upon re-entry to the directory...  A prettier version of the missing VC1

Image

Logs: udifivovul.kodi (paste)

I also note some other behavior when it updates the codec (like a NULL in table files column playCount and a removal of settings).  I'm not sure about this behavior, but my pain/annoyance factor is low -- but it explains watch counts, subtitle settings, and other things having disappeared when playing blu rays.

PS: These photos are coming from google photos, So I do not trust them to be permanently available 

PPS: If there is anything else that I can do to assist, let me know.  I could probably test nightly builds if it would help and I am comfortable with adb Shell and such.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
MySQL Streamdetails strVideoCodec vc1 vs vc-100