Pi2 deinterlace "auto" function resulting in choppy playback
#1
I have a few files that have very choppy playback. I finally found a workaround to set deinterlace to off (from auto) and that fixes playback. 
Was hoping for Kodi 18.2 to solve the issue but it still exists. Not an expert but would be great if deinterlace "auto" does not select unplayable settings.

Full debug log, details and screenshots posted here in librelec forum:
https://forum.libreelec.tv/thread/14982-...post119484
Reply
#2
Choose Bob X2 deinterlace instead as it uses less resources and it works just as well as auto (adv X2)
Reply
#3
(2019-05-19, 14:36)the_bo Wrote: Choose Bob X2 deinterlace instead as it uses less resources and it works just as well as auto (adv X2)

Thanks but is that the best  default setting for all content? I assume "auto" should decide to turn deinterlace on only when needed, and then pick the right version. 

Not sure if adv X2 should work fine on a pi2 or if it just troublesome with some content, so hoping the auto function gets tweaked. Will try your setting in the mean time.
Reply
#4
(2019-05-19, 16:20)kees667 Wrote:
(2019-05-19, 14:36)the_bo Wrote: Choose Bob X2 deinterlace instead as it uses less resources and it works just as well as auto (adv X2)

Thanks but is that the best  default setting for all content? I assume "auto" should decide to turn deinterlace on only when needed, and then pick the right version. 

Not sure if adv X2 should work fine on a pi2 or if it just troublesome with some content, so hoping the auto function gets tweaked. Will try your setting in the mean time.

Does the choppy playback happen only on HD channels or all channels. I had problems with HD channels only. Setting bob X2 on HD channels and leaving the SD channels at adv x2 worked for me.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Pi2 deinterlace "auto" function resulting in choppy playback00