Solved Animated weather icons stop moving in Weather addon windows
#1
Rainbow 
Hi Ronie.

Slightly strange issue - all the animated gifs in the forecast screens only animate for around a little under a second before stopping. 

If I click around in menus etc I get another second of animation for every click... which leads me to believe it's might possibly be something in MyWeather.xml tripping up with user window/menu interactions ?
(Outside of the main Weather addon, back on the Home screen, the animations run continuously as expected.)

It been happening with Leia from beta up to current 18.2 & Transparency! v11.0.3-ish onwards (possibly way earlier, and I've just never noticed) & any weather addon that allows choice of icons (e.g. Weatherbit IO & OpenWeathermap Extended)
, and any animated weather icon set, including resource.images.weathericons.animated which seem to be the skin default.
Nothing relevant shows up in debug logs, other than the registering of key/button presses that give another few frames of animation Smile


I've been having a few other niggly issues with this elderly and crufty Kodi install that's been through many many upgrade cycles, so decided to bite the bullet and address as many of them as I could with a format & clean re-install from scratch with only the bare minimum addons.  Animation issue still occurs with fresh LibreELEC 9.02/Leia 18.2/Transparency 11.0.8 install.
Reply
#2
There is a possibility that your o/s is playing one full cycle of the anm gif as a setting and looping is turned off.

If you can get to the settings of your o/s, look for Video and under "Auto-Play Videos" set it to loop.
Reply
#3
(2019-05-20, 18:28)PatK Wrote: There is a possibility that your o/s is playing one full cycle of the anm gif as a setting and looping is turned off.

If you can get to the settings of your o/s, look for Video and under "Auto-Play Videos" set it to loop.

Nope.  As mentioned in the initial report... animated gifs work elsewhere in the skin just fine, even the very same weather icon gifs.
This problem *ONLY* happens in the Weather addon's main page.
Reply
#4
No sure what to say, there doesn't seem to be any issue on my end with T! and weather io; animated icons on home page or main weather page, both play well with windows. I did notice that libgif.dll in system is no longer present in Leia, just wondering if this is part of the cruft?
Reply
#5
(2019-05-21, 00:00)PatK Wrote: > I did notice that libgif.dll in system is no longer present in Leia, just wondering if this is part of the cruft?
Linux based LibreELEC setup here, so uses .so (shared object) libraries rather than .dll (dynamic-link library)
Either way ... it wouldn't explain gifs partially instead of fully animating, or that the animations work elsewhere in the skin.
Reply
#6
Ooookay ... some extra weirdness on top ...

Using Debug Level 2 (with the onscreen counters) the Weather screen animations all work properly  Oo
Using Debug Level 1 (no onscreen extras) the same halted gif animation occurs again.

While I had a Debug Level 1 session running, and was in the Weather window, a notification popup from PVR service occurred ... and the gif animations ran again for the 3 seconds the popup displayed, then stopped again when it cleared.

It seems that any item/window overlaid on the Weather window starts up the animations again, for as long as the overlay is displayed.

Here's the debug log (Level 1) - hopefully someone with a bigger brain than mine can get something useful from it.
yoqacinote.kodi (paste)
Reply
#7
Just a quick test if you can. Can you disable both the advancedsettings.xml files that are being loaded (you will see them at the start of the log). Restart Kodi and check the animations. Do they work? What Hz is set for your TV- 50, 60, other?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#8
(2019-05-21, 22:34)Karellen Wrote: Just a quick test if you can. Can you disable both the advancedsettings.xml files that are being loaded ...

Oh, I see what you are getting at ... the GUI settings section for lowering GPU load.

WELL DONE, sir!  Love

You absolutely nailed both my issues.  Seems the `experimental` Kodi v18 Leia setting for smartredraw (https://kodi.wiki/view/Advancedsettings.xml#smartredrawwas causing both the gif animation & progress-bar weirdnesses.
(The dirtyregions handling parts have no effect on this particular issue, and continue to keep GPU load sensible)



For informational purposes the function and it's drawbacks are referenced here: [Github xbmc:master] Improve GUI message handling / gui :: smartredraw #12213
Reply
#9
Great to hear!!

The second solve was an unexpected bonus Smile
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#10
Thread marked solved.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Animated weather icons stop moving in Weather addon windows0
This forum uses Lukasz Tkacz MyBB addons.