19 Nov 2019 - TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

Dolby Atmos buggy in Kodi on Nvidia Shield TV
#1
I've been using Kodi succesfully ever since it was XBMC. I never had to ask a question. Everything just worked.

However I recenlty upgraded my home theater system and added Dolby Atmos. Now I'm having a problem that I can't seem to solve on my own.

My hardware consists of:
TV: LG OLED 65B8PLA
Mediadevice: Nvidia Shield TV (2017)
Receiver: Onkyo TX-NR676

The problem I have is the following: Whenever I play a movie/clip with Atmos sound, the sound does work. My receiver recognizes it as being Atmos and sound is coming from my speakers. However 2 times out of 3 the channels aren't placed correctly. Sometimes the audio that is supposed to come out of the center channel comes out of the left surround speaker, the atmos info comes out of the right front speaker, surround comes out of one of the Atmos speakers,... It's all messed up. When I restart the movie/demo sometimes it fixes itself, sometimes it doesn't. There are times I have to restart a video 3 or 4 times to get the sound to play correctly.

One demo, Dolby Nature's Fury, downloaded from Demo-World.eu never seems to work in Kodi. The channels are always messed up I redownloaded it with the same result. I thought it was a corrupt file but then I played it with VLC and in VLC it works just fine.

I have set everything to passthru in Kodi and the Shield is set to Automatic surround (tried "Always" but results are the same).

Is there anyone who can point me in the right direction here?
Thanks in advance.
Reply
#2
I can't find any downloads on that site to test on my setup but a debug log would be useful.
Reply
#3
(2019-05-26, 15:59)Hitcher Wrote: I can't find any downloads on that site to test on my setup but a debug log would be useful.

The Nature's Fury demo file sits under Trailers -> 2D Demo Trailers (HD) -> Dolby

Nature's Fury is the one giving me the most trouble. All the others seem to work after a couple of tries. Nature's Fury never does.

I will go and try to create a Log file to post here.
Reply
#4
The Debug Log

This is starting Kodi, playing the Dolby Nature's Fury demo and exiting Kodi. Funny thing is, with debugging enabled I had to try 3 times to get the demo to play faulty. I never got it to play correct. I tried 20 times at least without succes and with debugging enabled it played correctly for the first 2 times. The 3th time however it did what it always did. Throwing channels all over the place. So the logfile is from this 3th attempt.
Reply
#5
I have an Onkyo TX-NR 787 and have  experienced this issue as well although way less frequently than you are reporting. The 2 or 3 times it has occured, I have simply stopped and resumed the file. It has been completely random so I wouldn't be able to reproduce it.
Reply
#6
Just got around to testing this myself and there is indeed a problem. First time I played that file the voice came out of the centre channel for the first piece of dialogue, then the second piece it came out of the left surround channel, and the next piece came out of the front right channel. The second playback had no audio at all. And the third time everything played perfectly.
I suggest you open an issue on GitHub and post your logs. I'll try and add more details myself later.
Reply
#7
Thanks guys. Good to now I'm not the only one having this problem and others are able to reproduce the symptoms. This makes for greater odds on getting it solved. I will open an issue on GitHub tomorrow.
Reply
#8
I have just opened an issue on GitHub: Here
Reply
#9
Thanks, commented.
Reply
#10
Try with the forceraw build please.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#11
Can confirm this issue has existed for a while now. I think it exists on MrMC as well. Going to upvote your comment on Github as well.
Reply
#12
@fritsch Tested with forceraw build and it worked correctly every time.
Reply
#13
Will the forceraw build install itself next to or on top of my existing Kodi? In case of the latter, will I keep my library, settings, add-ons,... or will everything be overwritten/deleted?

If I can keep my library and stuff I will try it later tonight. If I loose everything I'm gonna wait to try it until the weekend when I have some more time to fiddle around with it.
Reply
#14
It will overwrite your current install but keep all your data as long as it's newer than it. If it's older then you'll need to uninstall Kodi (keeping the data), restart your Shield, then install the forceraw build. I did this using adbLink.
Reply
#15
Now someone please test in windows / Linux please.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Dolby Atmos buggy in Kodi on Nvidia Shield TV00