v18 Audio Passthrough issue with AVR on Ubuntu 18.04
#1
While playing Audio test content which is downloaded from Kodi wiki ( Dolby ATMOS and others) in Kodi 18 lia (18.0, 18.1, 18.2, 18.3) on Ubuntu 18.04 minimal with Denon AVR X3200W, when audio passthrough enabled some times AVR does not receive Audio Codec stream and AVR stuck on the same codec then other video codecs like ATMOS, TrueHD and other does not work. This issue is resolved only after reboot/restart.

As I have tested the same setup and the same scenario with KODI 17.6, in this setup we did not get the above-mentioned issue.
 
Issue repo steps:
1. Start Kodi 18
2. Play ATMOS content.
3. Put the content playback in repeat mode(So that the test content does not stop permanently during power off)
4. change the source of AVR
5. Then put AVR into the standby mode or power off the AVR.
6. After some time start the AVR.
7. Repeat step 4,5,6 steps randomly till the audio disappeared.

Also, we did not receive any error in Kodi logs.
Reply
#2
Known - changes that this will be fixed are not that high. Just restart kodi or fixate your EDID information.

Kodi's X11 port is not maintained anymore. Try to switch to DRM / GBM or Wayland.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2019-06-29, 20:50)fritsch Wrote: Known - changes that this will be fixed are not that high. Just restart kodi or fixate your EDID information.

Kodi's X11 port is not maintained anymore. Try to switch to DRM / GBM or Wayland.
[align=start][font]Restarting Kodi does't fix the problem. [/font][/align]
[align=start][font]EDID information is already made static using the attached DENON edid[/font][/align]
[align=start][font]Rebooting the system is the only solution to fix the problem.[/font][/align]
[align=start] [/align]
[align=start][font]BTW how do I switch to GBM/DRM ? Please help. [/font][/align]
[align=start][font]Thank you[/font][/align]
Reply
#4
(2019-06-29, 20:50)fritsch Wrote: Kodi's X11 port is not maintained anymore. Try to switch to DRM / GBM or Wayland.

Really? I've seen posts from FernetMenta saying X11 is the reference platform and to not use GBM. Granted this was almost a year ago, but I've never seen a team member say "Switch to GBM" before now. Other than in the new build instructions, I can't find anything in the docs/wiki about installing for GBM. Even your Intel VAAPI guide uses X11.
Reply
#5
My intel guide is also not maintained anymore, just kept alive. FernetMenta has left team kodi some months ago. Happily he is still helping us out in the code he has majorly written: VideoPlayer, VDPAU, VAAPI, ActiveAE, X11 and many others.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
(2019-07-06, 08:28)fritsch Wrote: My intel guide is also not maintained anymore, just kept alive. FernetMenta has left team kodi some months ago. Happily he is still helping us out in the code he has majorly written: VideoPlayer, VDPAU, VAAPI, ActiveAE, X11 and many others.

We have tried the same test with Wayland, but still, we are facing the issues.
Also, we have tried LibreELEC (LibreELEC-Generic.x86_64-9.0.2.img) on the same machine and we did not get that issue on it as liber EEC is using Kodi 18.2 and X11 by default.
Reply
#7
Okay, then you have a driver issue with your stack.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#8
(2019-07-11, 11:14)fritsch Wrote: Okay, then you have a driver issue with your stack.
Ya but we have tried a lot of combination including padoka ppa and still the issue persists, could you help me to identify which part of the package is causing this issue as you know liber ELEC is working properly on the hardware.
Also, if possible can you list our the driver stack which I need to compare.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Audio Passthrough issue with AVR on Ubuntu 18.0400