Playing Facebook MPD live stream with livestream adaptive
#1
The URL below used to be working. ffplay the URL, the video could be played correctly.
I have Googled around, playing MPD stream should use the following syntax.


url = "https://video.fhkg4-1.fna.fbcdn.net/hvideo-atn5-ftw/v/reYIwC3XA8qGEUWlyxNuU/live-dash/dash-abr1/2281510105267930.mpd?_nc_rl=AfDahWCcNwOsNKOr&oh=53038e478c3a108e81b1f8980cb9f7d5&oe=5D1D799D"
play_item = xbmcgui.ListItem()
play_item.setProperty('inputstreamaddon', 'inputstream.adaptive')
play_item.setProperty('inputstream.adaptive.manifest_type', 'mpd')
xbmc.Player().play(item=url, listitem=play_item)

I have got the error below:
Code:
2019-07-02 17:06:15.933 T:140084556335232  NOTICE: VideoPlayer::OpenFile: https://video.fhkg4-1.fna.fbcdn.net/hvid...e=5D1D799D
2019-07-02 17:06:15.942 T:140084556335232   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.tvhk/?action=play&video=https%3A%2F%2Fvideo.fhkg4-1.fna.fbcdn.net%2Fhvideo-atn5-ftw%2Fv%2FreYIwC3XA8qGEUWlyxNuU%2Flive-dash%2Fdash-abr1%2F2281510105267930.mpd%3F_nc_rl%3DAfAtflSKwIWQ7Uzt%26oh%3D35541a088608b55924dc5516da7a21d6%26oe%3D5D1D799D]
2019-07-02 17:06:16.042 T:140081901827840  NOTICE: Creating InputStream
2019-07-02 17:06:16.098 T:140084556335232  NOTICE: GL: Selecting YUV 2 RGB shader
2019-07-02 17:06:16.099 T:140084556335232  NOTICE: GL: NPOT texture support detected
2019-07-02 17:06:16.099 T:140084556335232  NOTICE: GL: Using GL_ARB_pixel_buffer_object
2019-07-02 17:06:16.099 T:140084556335232  NOTICE: Using GL_TEXTURE_2D
2019-07-02 17:06:16.169 T:140081901827840  NOTICE: Creating Demuxer
2019-07-02 17:06:16.171 T:140081901827840   ERROR: Open - error probing input format, https://video.fhkg4-1.fna.fbcdn.net/hvid...e=5D1D799D
2019-07-02 17:06:16.171 T:140081901827840   ERROR: OpenDemuxStream - Error creating demuxer
2019-07-02 17:06:16.172 T:140081901827840  NOTICE: CVideoPlayer::OnExit()
2019-07-02 17:06:16.172 T:140081901827840  NOTICE: Closing stream player 1
2019-07-02 17:06:16.172 T:140081901827840  NOTICE: Waiting for audio thread to exit
2019-07-02 17:06:16.172 T:140081927005952  NOTICE: thread end: CVideoPlayerAudio::OnExit()
2019-07-02 17:06:16.172 T:140081901827840  NOTICE: Closing audio device
2019-07-02 17:06:16.173 T:140081901827840  NOTICE: Deleting audio codec
2019-07-02 17:06:16.173 T:140081901827840  NOTICE: Closing stream player 2
2019-07-02 17:06:16.173 T:140081901827840  NOTICE: waiting for video thread to exit
2019-07-02 17:06:16.173 T:140081062487808   ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
2019-07-02 17:06:16.173 T:140081062487808  NOTICE: thread end: video_thread
2019-07-02 17:06:16.173 T:140081901827840  NOTICE: deleting video codec
2019-07-02 17:06:16.173 T:140081901827840  NOTICE: VAAPI::Close
2019-07-02 17:06:16.173 T:140081935398656  NOTICE: COutput::OnExit: Output Thread terminated
2019-07-02 17:06:16.173 T:140081901827840  NOTICE: VAAPI::Close - closing decoder context
2019-07-02 17:06:16.193 T:140084556335232  NOTICE: CVideoPlayer::CloseFile()
2019-07-02 17:06:16.197 T:140084556335232  NOTICE: VideoPlayer: waiting for threads to exit
2019-07-02 17:06:16.197 T:140084556335232  NOTICE: VideoPlayer: finished waiting
2019-07-02 17:06:16.536 T:140084026181376  NOTICE: PulseAudio: Opened device Default in pcm mode with Buffersize 150 ms

May anyone please help me on this?

Thanks.
Reply
#2
Okay I have found inputstream.adaptive is not enabled yet...

This one seems helpful:
https://github.com/emilsvennesson/script...reamhelper
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Playing Facebook MPD live stream with livestream adaptive00