hardcoded settings?
#1
Hey
is there any way to disable debug logging and enable the splash screen in the Kodi 17 tvos build?
I'd love to use a custom splash screen, but Kodi only starts with a black screen even if I don't use a custom image.

Having the option to disable Kodi debug logging would be helpful for troubleshooting third party addons, as the maintainers of these addons don't have to deal with huge log files.

But it feels like one is not able to change these settings (even if you specifically enable/disable it in advancedsettings.xml).
Reply
#2
ok figured out the splash screen issue. Contrary to other OS (Kodi 17, Windows 10) it is case sensitive here. So you have to name the file
Splash.png
In addition you have to set
<splash>true</splash>
in advancedsettings.xml


But I can't figure out to disable debug logging.
This is what I entered in my advancedsettings.xml
<loglevel hide="false">0</loglevel>

Any idea?
Reply
#3
Have a look at Advancedsettings.xml (wiki) and see if that helps, if you've not already done so.

What are you trying to do in the logging, to turn it off completely or just have normal logging (errors only)? The former is -1, the latter is 0 as you have above.

You also have to make sure of the GUI setting, as that will override the advancedsetting file setting. Normally this entry would only be used to enable logging for situations where you can't get to the GUI (crashes on startup for example).
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#4
(2019-08-15, 21:28)DarrenHill Wrote: Have a look at Advancedsettings.xml (wiki) and see if that helps, if you've not already done so.

What are you trying to do in the logging, to turn it off completely or just have normal logging (errors only)? The former is -1, the latter is 0 as you have above.

You also have to make sure of the GUI setting, as that will override the advancedsetting file setting. Normally this entry would only be used to enable logging for situations where you can't get to the GUI (crashes on startup for example).

Thanks, but it doesn't seem to be true for the Kodi 17 tvos build.
I want normal logging, so the "0" is the way to go for me. In GUI settings debug logging is disabled, too. But there's still debug output in log file.

Worth to mention that you don't have access to the debug log settings in GUI at all if you don't write
<loglevel hide="false">
into the advancedsettings.
That's why I'm suspecting it to be hardcoded somehow.
Reply
#5
guess this is something only @Memphiz knows :-)
Reply
#6
Not sure but I guess that the tvOS test build was build in Debug mode and this is why you see a lot of debug informations on your log.
If this is the case you cannot disable it. But Memphiz will confirm this.
Co-developer of Catch-up TV & More video add-on: GitHub repoWebsite
Reply
#7
(2019-08-16, 12:39)sy6sy2 Wrote: Not sure but I guess that the tvOS test build was build in Debug mode and this is why you see a lot of debug informations on your log.
If this is the case you cannot disable it. But Memphiz will confirm this.

thanks
is anybody willing and able to build the same build without debug mode?
It's really a pita for troubleshooting addons like Emby.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
hardcoded settings?00