20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

Access denied ... "couldn't get settings for add-on" [SOLVED, kind of]
#1
Tvheadend has quit working after an upgrade to 18.3. Running osmc on a pi3.

Actually tvheadend seems to be working fine through the web gui. But the kodi frontend is wrecked. I can't even open the settings for it in kodi.

INFO: AddOnLog: Tvheadend HTSP Client: pvr.hts - starting PVR client
DEBUG: CAddonCallbacksAddon - GetAddonSetting - add-on 'Tvheadend HTSP Client' requests setting 'host'
ERROR: CAddonCallbacksAddon - GetAddonSetting - couldn't get settings for add-on 'Tvheadend HTSP Client'
DEBUG: CAddonCallbacksAddon - GetAddonSetting - add-on 'Tvheadend HTSP Client' requests setting 'htsp_port'
ERROR: CAddonCallbacksAddon - GetAddonSetting - couldn't get settings for add-on 'Tvheadend HTSP Client'
... and so it goes on for every PVR setting

Tried deleting ~/.kodi but no different. And debsums tells me no packages are corrupted.

I have no idea what it can be... Do you?

Trying to compile kodi from master branch right now to see if it gets any better.

I should sleep. ttyl interwebz
Reply
#2
(2019-08-20, 21:48)allejok96 Wrote: Running osmc on a pi3.
..but the kodi frontend is wrecked. I can't even open the settings for it in kodi.

Does this perhaps sound familiar, @Sam.Nazarko ?
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#3
Ok so I failed to compile Kodi for RPi, but that doesn't matter because I got PVR working again. Too bad I have no idea what the original fault was... But here's what I did:

DISCLAIMER commands not checked for typos. use your head.

Following
https://github.com/xbmc/xbmc/blob/master...ry-add-ons
and
https://github.com/kodi-pvr/pvr.hts

First download kodi-platform, as pvr is dependent on that

Code:
git clone https://github.com/xbmc/kodi-platform.git
cd kodi-platform
cmake -DCMAKE_INSTALL_PREFIX=/usr/local
make
make install

Then download source for pvr.hts (note: Kodi 18 must use Leia branch)

Code:
git clone https://github.com/kodi-pvr/pvr.hts.git --branch Leia
cd pvr-hts
mkdir build
cd build

Remove system pvr addon... A bit unorthodox but hey it works (until next update uh-oh)

Code:
rm /usr/share/kodi/addons/pvr.hts /usr/lib/kodi/addons/pvr.hts

Compile pvr addon.
I wanted it to install to /usr/local to not get confused with system files (seems those options had no effect)

Code:
cmake -DCMAKE_INSTALL_PREFIX=/usr/local -DOVERRIDE_PATHS=1 ..
make
make install

Restarted Kodi.

Went to All addons >TVHeadend > Settings and entered user and password again (because I had removed ~/.kodi/userdata/addon_data/pvr.hts earlier in a futile attempt to make things work)

And now it worked!!!!!11! yay

PS. Heads up for all ya osmc people with problems!
I thought osmc was a merely raspbian with kodi preinstalled... But it turns out they have their own build of kodi for rpi, packaged in a single deb called rbp2-mediacenter-osmc. It contains everything (including pvr), which in normal raspbian/debian is split up into several packages. So, since they got their own builds, perhaps it's best to go to osmc forum for help...
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Access denied ... "couldn't get settings for add-on" [SOLVED, kind of]00