Script.Module.Metadatautils incompatibility with Kodi Leia/18
#1
I figured it was finally time to migrate from Krypton to Leia but Titan was a base requirement for me. Unfortunately none of the current mods seemed to have fixed a problem with 'Skin Helper Widgets' for Music. Many of them don't work -- for me it was a desire for the 'Random Albums' widget that drove me to finally investigate.

The fix is pretty simple (for me at least).

Change this line in the script.module.metadatautils\lib\kodi-constants.py from

FIELDS_ALBUMS = ["title", "fanart", "thumbnail", "genre", "displayartist", "artist", "genreid",
    "musicbrainzalbumartistid", "year", "rating", "artistid", "musicbrainzalbumid", "theme", "description",
    "type", "style", "playcount", "albumlabel", "mood", "dateadded"]

to

FIELDS_ALBUMS = ["title", "fanart", "thumbnail", "genre", "displayartist", "artist",
    "musicbrainzalbumartistid", "year", "rating", "artistid", "musicbrainzalbumid", "theme", "description",
    "type", "style", "playcount", "albumlabel", "mood", "dateadded"]

Note: Kodi 18 JSON API no longer supports the parameter "genreid" for the GetAlbums method for the AudioLibrary (class).

I thought that I'd mention this (rudimentary) fix for the mod authors (or any one else interested) who might be able to include it in their repositories. (In retrospect, after I had tracked this down, I see that a user 'Angelinas1' has already noted this fix in github -- that would have saved me some time!)

cheers,
Lee
Reply
#2
Can you open a issue below thanks

https://github.com/kodi-community-addons...ils/issues
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Script.Module.Metadatautils incompatibility with Kodi Leia/1800