Thread Rating:
  • 0 Vote(s) - 0 Average
No Audio in XBMC
I was running Vista and everything was fine aside from the constant crashing and slow GUI. Now I'm running Ubuntu Hardy Heron and the GUI is faster than I've ever seen it on Xbox or PC, but I have no sound anywhere. I play videos and they play really really fast, and any audio-only files will make XBMC freeze for maybe five seconds.

I'm new to Linux, just been finding my way around for the past few days. I had some other problem with flash audio in Firefox but managed to fix that pretty quickly.

Laptop Model: HP dv6102od
Linux: Unbuntu Hardy Heron 8.04
Arch: i686
XBMC: 2.1a2svn13999-hardy1 from the SVN PPA repository

Select the proper audio device in XBMC setup I believe - this has been seen and mentioned by many and I believe that is the fix.
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
I went into the audio configuration and for audio device it has analog selected with the name "default". I tried changing it to: Conexant, CONEXANT, Conexant Audio, CONEXANT Audio, pulseaudio, alsa, and alsa_output.pci_8086_27d8_sound_card_0_alsa_playback_0.

None of those did anything. I even restarted XBMC after changing it every time, then I tried default again... still nothing.
I can't edit posts for some reason, but I left something out, sorry for the double post.

I can't find any place to select an audio device, just a place to manually type in an audio device. How do I see what I need to put in this box?
I just tried PulseAudio Sound Server, PulseAudio Sound, PulseAudio, Master, Volume, audio, mixer, snd, dsp, adsp, /dev/snd, /dev/mixer, /dev/audio, /dev/dsp, /dev/adsp, ALSA PCM, ALSA, alsa, HDA Intel, hda intel, hda_intel, etc.

Still nothing. There were a few, however, that it would freeze for a few seconds after I set it, but then still no sound and no sound after a restart of XBMC.
Are you just pulling stuff out of the air and typing it in?

There have been plenty of threads on this if you'd bothered looking. "iec958" works for some.
Tried IEC958 and it fixed the video speed but still no audio anywhere. AND NO, I wasn't just pulling things out of my ass, i was pulling ideas from other threads in other places, only I didn't know what they were talking about most of the time, being new to Linux. So I just pulled things out of applications that looked like they might work and tried them. I searched, sorry that I didn't want to go through 100s of threads to maybe find a solution.

Figured it out: I needed libalsa2-plugins (something like that). With the audio device set to "default" now I can play MP3 files but videos just make XBMC freeze solid.
FYI - IEC958 will pass audio through spdif.

Trying to play a video, it freezes solid. Before I had sound the video would play really fast.

Laptop Model: HP dv6102od
Linux: Unbuntu Hardy Heron 8.04 (kernel 2.6.24-19-generic)
Arch: i686
XBMC: build 14005 from the SVN PPA repository

Debug Log:
Backtrace: No core file, i have to killall -9 xbmc.bin to get it to close.
You can try to "killall -SEGV xbmc.bin" instead, the bt may or may not be useful at that point.
You may also want to try uninstalling portaudio et. al.
I know this is old but I just wanted to add that you can get a list of valid device names with the aplay -L command (yes, capital L)

also, if you create any aliases in your .asoundrc or /etc/asound.conf file you can use those as well. for instance, my hdmi port only accepts 48khz audio, so i made a hdmihq alias where i resample all audio to 48k before sending it out the hdmi. (fixed my mp3 playback issue, 44.1k audio was playing back at 48k so everything sounded like it was on low doses of helium)

default should work in most cases for analog
iec958 for digital audio (pcm/ac3/dts passthru)
hdmi for hdmi audio
you can also try dmix, which is alsa's internal mixer

No Audio in XBMC00