Actors/Posters image quality
#1
Dear Friends,
Firstly sorry about my poor language skills, I try to describe my problem as clear as possible:

1st config: Epson TW9400 projector (4k, 23.97 and 59.94Hz, 4:2:0 BT2020 colorspace, but tried others too) , nVidia Shield TV 2017 media player, Kodi 18.x, Kodi Matrix, Gigabit internet
2nd config: Asus gamer notebook, nvidia GTX 860M video, Kodi 18.x, Kodi Matrix, 20 Mbit internet

The problem: adding movies to the Kodi (through NFS on Android, WebDAV on Windows 10) I get strange images. Here are the samples:
Bad quality: https://imgur.com/ODhIcqN
After a while: https://imgur.com/TopByYJ
More samples: https://imgur.com/CQiMhUZ

The problem exists only if I use "The Movie Database" scraper. Depends on the scanned movies, some images improving, some are not. I have to open the movie info page and a lot of images will be OK after a while. But the posters on the main page are seldom improving, they are stay in the bad quality.

What I've tried? Reinstall, factory reset on the Shield, other color space, other refresh rate, other resolution. Scanned 1 movie only, scanned 500+. Downloaded SPMC (other kodi fork), everything was nice and colorful.

A sample, how to bring out surely:
I reinstalled Kodi (clean install v18.4 or v19 alpha), then scan John Wick 3 folder only. On Windows the casts pictures are good in most cases, but the poster is bad in almost every time. On Android both wrong. After 1-2 minutes, but just if I visit the movie info page, the actors thumbnails going to good quality. (almost every time, depends on movie count)
Now the trick: I have found the thumbnail picture of Ian McShane from the movie. (because he has a 2000x3000 res image on tmdb.org) The thumbnail pic is only 480x720, good quality. I deleted it. Back to the Kodi, reload the movie info page and Ian McShane profile picture is really bad quality again. It seems the Kodi have to reload and make thumbnail, but if the thumb is not exists before, Kodi displays the original (?) picture and the resize function makes the wrong quality.

Interesting: the image quality depends on skins too. Embuary skin causes the worst results, Estuary V2 sometimes good, sometimes bad, the best result was with the default Estuary skin. Other interesting thing: the problem occurs only if the original picture is big (1000x1500 and above). Under that resolution I can't see differences, or there are smalls only I can't notice. For example Robert Downey Jr., he has 750x1125 picture on tmdb. He is always good... Big Grin

Checked the log file of course, but there is nothing about it. Made a backup copy of the Kodi folder, but there are no diffrences between the bad and the qood quality pictures or the folder structure as well. It seems the problem comes out at first time, while there is no thumb created yet.

Sorry about my long post, I really would be happy if anyone can help me. I use Kodi for a long time, but this problem comes for a couple of months only.

Thank you!
Reply
#2
From the wiki Artwork/Cache (wiki)

Using the following code in your advancedsettings.xml will allow caching artwork at original size. [2]
<imageres>9999</imageres> <fanartres>9999</fanartres>
Reply
#3
(2019-09-19, 17:01)PatK Wrote: From the wiki Artwork/Cache (wiki)

Using the following code in your advancedsettings.xml will allow caching artwork at original size. [2]
<imageres>9999</imageres> <fanartres>9999</fanartres>

Not worked for me. Sad
Reply
#4
(2019-09-20, 13:33)Joco1114 Wrote: Not worked for me

Request a debug log turned on and uploaded to a public pastebin and that URL linked to this thread. What I'm looking for in the log is the advanced setting, and the attempt to bring posters or fanart into a scrape (pls indicate the title) in the thread.

The advanced settings only work on start-up and is not retroactive, subsequent artwork should be appreciated in it's org format. You may have to re-scan the collection for upgrade images.
Reply
#5
(2019-09-24, 02:33)PatK Wrote:
(2019-09-20, 13:33)Joco1114 Wrote: Not worked for me

Request a debug log turned on and uploaded to a public pastebin and that URL linked to this thread. What I'm looking for in the log is the advanced setting, and the attempt to bring posters or fanart into a scrape (pls indicate the title) in the thread.

The advanced settings only work on start-up and is not retroactive, subsequent artwork should be appreciated in it's org format. You may have to re-scan the collection for upgrade images.  

Thank you for checking it. Here is my log: efeculotov.kodi (paste)
I made a clean install, deleted all folders on Windows 10. Scraped "John Wick Episode 3 - Parabellum", here are the screenshots: https://imgur.com/a/ufme76I
On the 1st picture you can see the poster quality (I hope...) and on the 2nd the actor pictures. Check McShane and Fishburn or Reeves' beard.

P.S.: After a while the actor pictures improved if I opened the movie page.

Thank you!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Actors/Posters image quality00