Android Scraper not choosing the correct movie information
#1
Hey everyone, new here
Just a quick Q
I have been updating and organising my movies and noticed that two movies in particular are always showing the same movie info and poster.
The movie is the karate kid (1984), it always shows the poster and info for the karate kid (2010).
No matter how much a change the scraper settings or use a differnt scraper is still shows the remake poster.

Any ideas why or any thoughts how to change it
Cheers munk
Reply
#2
@Munkeyroot

Yes, I can see the problem. It is not the poster, but the whole scraping keeps defaulting to the 2010 version of the film, even though we select the (1984) version.

Even more interesting is that the log shows the correct movie being scraped, yet we end up with the wrong version.

There are other issues also being reported and I will move this post to the metadata scraper forum and hopefully the developer of the scraper @olympia can investigate the problem.

Here is my log. Scrape starts at line 1107... uzunomiyad.kodi (paste)

Seems that TheMovieDB are making changes, but not advertising them.

Until a fix is issued, you can use a Parsing NFO file to scrape the correct movie. See here... https://kodi.wiki/view/NFO_files#Parsing_nfo
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
Hi karellen
Thanks for your post, really appreciated your response and thanks for your time.

I dont feel as much of an idiot now i know there could be a dev issue, its very annoying lol

Thanks again for you're time
Munkey
Reply
#4
No problems @Munkeyroot

Keep an eye on this thread... 2885264 (post)
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
Thanks mate,
Ok so just done the parsing nfo
Make sure ive followed this right
Went to the movie db
Found the correct movie the karate kid (1984)
And copied the url
https://www.themoviedb.org/movie/1885-th...uage=en-US
Created a movie.nfo in the file folder the karate kid (1984) and pasted the url in
Updated the libary again
Still showing the reboot 2010 ver ...hum
Reply
#6
(2019-09-14, 10:34)Munkeyroot Wrote: Created a movie.nfo
What you have done in your post is correct.

The movie.nfo is not a default name and works only in specific situations. You need the setting "Movies are in separate folders that match the movie title" enabled. You may not have this enabled which is why it does not work.

It is safer to name your nfo files as <Moviefilename>.nfo. So name it exactly the same as the filename of the movie. See this image for example... https://kodi.wiki/view/NFO_files/Movies#...d_Location

The other reason it may not work is if the nfo file you created is not saved as UTF-8 type file as shown in the image...

Image
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#7
Hey chap, thanks for your fast response
Ok cool just checked what you said
Confirmed the separate folders is checked on
And renamed the nfo file to
The karate kid (1984).nfo
Still no update.... god its annoying lol

Ok ill get my laptop out in a bit and check if the nfo file is utf-8

Thanks again fella
Reply
#8
Yeah it gets annoying until you figure out what the problem is and then it suddenly becomes super easy.

If the UTF-8 check is ok, then provide a screenshot of your folder so I can see the files and the foldername. Also a Debug Log which captures you trying to scrape The Karate Kid nfo.

I just double checked here on my setup, and the parsing nfo file is definitely working for the Karate Kid movie.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Scraper not choosing the correct movie information00