Exploit for better quality audio found
#1
I'm running windows 10 insider build 18963 and have an AMD rx 580 8gb graphics card with an asrock x470 gaming k4 mother board (Realtek ALC1220 soundcard) and ryzen 2700x 32GB RAM. I've installed the latest AMD graphics drivers after resetting windows, I installed my mainboards realtek soundcard drivers through asrocks appstore utility program for updating drivers I don't know if this works with default Realtek drivers installed by windows. I've a pioneer VSX933 but this should work for most atmos or 7.1 receivers, in the receivers hardware speaker configuration I set it to the right speaker config and crossover then manually set the crossover for the speakers I'm using and set Levels all to max I then distance about 1.11m for all speakers.

If you have a distance from speakers to ceiling for atmos speakers mine sound best at maybe 1.53m this will change on your room. In windows 10 sound settings under the playback tab I find the Audio receiver connected by HDMI in the device listing and right click and configure speakers and check all speakers applicable and set to "Full range" I then go to the advanced tab and set the audio to 16bit 44100hz and ensure that the exclusive mode sound option checkboxes are both ticked enabled. Do not enable any spatial sound options like dolby atmos if you have them unless its for a game or app that specifically uses atmos like a handful of movies on Netflix or shadow of the tomb raider or gears of war or other games with atmos in the sound options leave your speaker configuration to be 5.1 or 7.1 at 16bit 44100hz. I then proceeded to install kodi 18.4 leia as an .EXE executable installer and configure it for 7.1 surround sound upmixing high quality best resampling and set default audio and passthrough to WASAPI and then adjust to specific WASAPI devices and try changing default sound device to directsound.


After cycling through all primary sound device comibinations with the passthrough set as WASAPI toggling on and off all the decoding options like AC3 to trueHD I disable kodi UI sounds and toggle the fullscreen mode display setting. I then uninstall kodi KEEPING the program settings then go to the windows 10 app store and install KODI from the windows 10 appstore. The previous settings are kept, I then open up the program and toggle through the audio output devices again default device and passthrough device to both be WASAPI.. then something amazing happens, the audio will sound far brighter and more life like almost like its clipping and distorting but still world changingly better to listen to. Something about having the previous settings from an executable installer from kodi and using the windows 10 app store app makes the sound better maybe somehow. I'm not sure whats going on, its almost like its got twice the audio output coming out at once. But everything sounds better though a little clippy which is why I thought kodi needed a normalizer. I thought that amazingly good audio quality was how it was supposed to sound till I did a reset/reinstall of my computer the other day and kodi sounded lame dull and flat and I fiddled till I got it working again.

Please look into and discover why the WASAPI upmixed surround sound can suddenly sound sooo damn amazingly good and make it the default sound output but without the clippy distortion? PLEASE thanks and even if you cant figure it out just please don't stop this exploit from working. However if you leave the audio playing for a long period of time with directsound default and WASAPI default passthrough the audio will distort more and more over time somehow? it still sounds great though.
Reply
#2
forgot to mention I'm outputting from my RX 580 8gb card into the receiver and then into my TV. my rx 580 8gb graphics card has two HDMI output ports on it, however if I use both at once the quality of audio and possibly slight degrade to image quality occurs, this could be limitations of hardware or more likely caused by interference. Recommend having your graphics card only connected directly to the AVR for best results otherwise you wont hear as much of the exploited audio quality.
Reply
#3
You may want to put in some paragraphs in your opening text. Not everyone is comfortable reading one giant wall of text.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#4
(2019-09-27, 07:53)Klojum Wrote: You may want to put in some paragraphs in your opening text. Not everyone is comfortable reading one giant wall of text.

OK I'll try.
I noticed some other sound settings and some more details.. I think I was previously running kodi 18.3 possibly like the august 31st or I believe a release sometime after September 4th in an x64 build.

Furthermore in the video settings under processing: render method is set to DXVA.
While playing back a video and opening its video settings there I set deinterlacing to : Off, I also set the  video scaling method to either DXVA or lancoz 3 optimised or AUTO.
I'd also disable Reinhardt stuff on the video settings but it always turns itself back on and never wants to save my setting of having it disabled for some reason, bug much?

I'm not sure why but all these settings seem to subtly ever ever so slightly alter sound?

Following that heres the important part in expert audio decoder settings I'd have it set to directsound with wasapi default passthrough and then toggle the maintain original volume on downmix and the upmix stereo sound and switch between default directsound and my AV receiver directsound.

Somewhere in there it will sound as if it was never really upmixing previously the volume will get somewhat louder and much more surround and have a far far far more lifelike feel to it while also feeling far more processed? I don't know how to describe it other than the feeling you get when you toggle the upmixing stereo on for a 5.1 or 7.1 surround system but sort of subtly enhancing the existing upmixing setting... sometimes when enabling upmixing you will for a split fraction of a second hear it go very clear and loud, this is just making it stay like that always.
then I toggle the passthrough supported options on and off for the default WASAPI as somehow disabling truehd passthrough and such everything except AC3 passthrough seems to make it sound subtly better too. but it depends on the build of kodi I think as for how good it sounds and how good it works.. on one random version of kodi I tried it sounded amazingly good and i'm forever trying to figure out what it was I did to get it to sound like that. After you've gotten it working in one of the few weeks old version of kodi 18 I think it will work with the windows 10 app store version of kodi too just mostly by using those settings and toggling the maintain volume button.
 
I don't really get why but if I open up a different media player and open a youtube URL with it and then go into the media players temp directory and copy out the temporary audio file from the youtube video and play it back in kodi it sounds almost disturbingly good like you could listen to anything and everything on it all day and never get tired of hearing it in my opinion.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Exploit for better quality audio found00