The TVDB scraper is currently broken due to upgrade works at TheTVDB site. We hope this issue will be resolved quickly.

delete custom artwork
#1
Good morning

By accident, I created a new set of artwork for a certain movie.
My intention was to upload a custom poster for a movie.
Now, everytime I want to change the artwork, the set I created is always showing up.
Is there a way to remove this?

I have searched the internet now for 3 days without luck.


Thanks in advance
Reply
#2
hmmm

It seems like nobody had this problem before Smile
Reply
#3
(2019-10-07, 23:16)Sjarel77 Wrote: It seems like nobody had this problem before
Don't know. I don't really understand the problem you are describing.

(2019-10-02, 11:57)Sjarel77 Wrote: My intention was to upload a custom poster for a movie.
Which website have you uploaded your movie posters to?

(2019-10-02, 11:57)Sjarel77 Wrote: Now, everytime I want to change the artwork, the set I created is always showing up.
How are you doing this? Are you rescraping? Do you have the correct scraper active for the site you uploaded the poster to?

(2019-10-02, 11:57)Sjarel77 Wrote: Is there a way to remove this?
Use the Choose Art option... https://kodi.wiki/view/Artwork#Choosing_Art_You_Want
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#4
Good afternoon Karellen

I try to explain again

So, when you want to change the poster from a movie, you select the information and then you can change the "poster" and the "fanart".
Image

Now, I did the mistake to click on the button "add art" on the right side.
At this moment, you can give your art a name.  
But in fact, you are creating a new "section" (link poster, fanart, banner, clearart, ...)

The poster of the movie I want to use, is as a jpg-file on my Synology.

So I first had to select the section "poster", and then add or select my own poster.


but now, at this moment, for every movie where I want to change my poster, there is always my own created "section".
This section I try to delete, but I can't find any way to do it.


I hope this is more clear
Reply
#5
Ok, I understand what you have done. You created a new art type by mistake instead of replacing the poster image.

The new art type you created won't affect anything. Are you experiencing any problems with it?

But if you want to remove it because it is annoying, then the art type is listed in the database. The only way to remove it is to edit the database and delete the record from the Art table. If you added it once, and there is no image attached to it in any movie, then there is only 1 line to delete.

Are you happy doing that?
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#6
(2019-10-08, 23:42)Karellen Wrote: Ok, I understand what you have done. You created a new art type by mistake instead of replacing the poster image.

The new art type you created won't affect anything. Are you experiencing any problems with it?

But if you want to remove it because it is annoying, then the art type is listed in the database. The only way to remove it is to edit the database and delete the record from the Art table. If you added it once, and there is no image attached to it in any movie, then there is only 1 line to delete.

Are you happy doing that?
Good morning.

Thank you for the reply.
So it's not possible doing in Kodi itself.

how to add the database?
I put the SDcard in my windows-computer.

There I have a lot of files, saying nothing to me Smile and a folder called "overlay's... full with .DTBO files


Nothing makes sense to me. Smile Smile
Reply
#7
It is not possible in Kodi to delete. It was never meant to be a common editable list.

A little bit of playing around and the easy way to remove that artwork type is to delete the movie where you created it and run a Clean Library. That will delete the entry in the database. Once that is done, scan the movie back into the library.

Just make sure it is the same movie where you created the wrong artwork type. It won't work if you delete any other movie.

Let me know if that works. If not I will tell you how to edit the database.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#8
ok, I will try this weekend.  thanks for the clear answer
Reply
#9
So..... I tried to  delete the database.... that didn't work out  Sad

I didn't find a way how, so finally in the file explorer, there was a folder 'databases', and a file "mydatabase..."
After deleting this file, Kodi started to act weird, half of the menu-items were not working anymore. 

So, I tried to reset LibreElec.  It took a every long time to do, and after a while it finally started again.
Now, for some reason, the remote control of my tv was not working anymore, and the 'yatse'-app I have, also stopped working.

The Pi4 now almost takes 5 minutes to start, before I can finally use the remote control of my tv. Even then, some commands are still not working.
I added the locations again for the movies, which are on my NAS.  But now, for an unknown reason, it will not read/create a new database again.
It always says there is no location present, although I set it up again myself.

the moral of the story: put it aside.. befor throwing with it....
Reply
#10
(2019-10-12, 15:19)Sjarel77 Wrote: So..... I tried to  delete the database.... that didn't work out 
Ummm, I did not ask you to delete any database. All you had to do was delete a movie from the library.

Your other problems I cannot help with as I do not use LibreELEC. Others will need to advise.

Should have taken my advice and just left the unwanted artwork entry alone as it was doing no harm.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#11
Yeah, it was my mistake.

I formatted the SDcard and re-installed everything from scratch.
When doing setup again, I found the menu-option to clear the database (which I should have done in the first place)

sorry. my bad!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
delete custom artwork00