20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

Do not remote key events using CEC (libCEC) on RPI4 (RaspberryPi4)
#1
We have been using libcec, cec-client on RPI 3B to turn ON/OFF TV and to receive remote control events. Recently we moved to RPI4. For RPI 4 we moved to latest libCEC (4.0.4)  from https://github.com/Pulse-Eight/libcec.
We are able to Turn ON/OFF the TV, make TV Active Source etc using the cec-client. However we not receive any key press events from the remote.  It seems like the hardware change to Micro HDMI or 2 HDMI ports is causing this issue. Same buster load works on RPI 3 and 3B+ i.e. we can turn OFF/ON TV and we do receive key presses.

Setup: RPI 4/Buster (Linux 4.19.66) with HDMI cable connected to LG TV and HDMI1 (port close to USB). We are using latest cec-client 4.0.4

> cec-client -i
libCEC version: 4.0.4, compiled on Linux-4.15.0-48-generic … 

All these command WORK:
echo "on 0" | cec-client RPI -s  // Turned LG TV ON
echo 'standby 0' | cec-client -s  // Turned LG TV OFF
echo 'as' | cec-client -s // Made LG as Active source
echo 'scan' | cec-client -s 

We have changed several HDMI cables to make sure that HDMI cable is not an issue. We tried HDMI0 (port close to USB-C). That port does not display anything on TV and does work for us.

Thank your for pointing us in the right direction!
Reply
#2
ok, I testet:


pi4:~ # cec-client -l
libCEC version: 4.0.4,  compiled on Tue Sep  3 02:44:00 UTC 2019 by [email protected] on Linux 4.9.0-9-amd64 (x86_64), features: P8_USB, DRM, P8_detect, RPi
Found devices: 1

device:              1
com port:            RPI
vendor id:           2708
product id:          1001
firmware version:    1
type:                Raspberry Pi

WARNING: [            1657] unhandled response received: opcode=0 initiator=1 destination=0 response=1

this is clearly something for the devs of CEC
Reply
#3
New Cable still no luck,
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Do not remote key events using CEC (libCEC) on RPI4 (RaspberryPi4)00