Library dependencies to Update to Python 3
#16
Any chance script.common.plugin.cache be updated to Py3 please!
Kodi 19.1 x64 Windows | CoreELEC 19.2RC2 S905X | Kodi 19.1 Linux Mint Ulyssa XFCE
Reply
#17
script.common.plugin.cache doesn't have an active maintainer. If you want to use it, you have to make it Python 3 compatible yourself.
Reply
#18
(2019-10-31, 10:15)Rechi Wrote: script.common.plugin.cache doesn't have an active maintainer. If you want to use it, you have to make it Python 3 compatible yourself.

Looks like someone has popped up and saved the day Smile

https://github.com/anxdpanic/script.comm.../issues/14

Updated the first post in the thread.
Image Image
Reply
#19
script.module.routing is not yet in the matrix repository. I've imported by zip in my v19 test environment and it seems to work as is, but it would be nice for it to be automatic.
Reply
#20
script.module.parsedom
script.module.elementtree
script.module.inputstreamhelper
script.extendedinfo
Reply
#21
Thanks added to the 2nd post
Image Image
Reply
#22
elementree is included in python (and has been since 2.5)
there's no need anymore for a separate module.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#23
https://github.com/ruuk/script.module.addon.signals/
https://github.com/romanvm/script.module.pyxbmct

Both supports python 3 but need to be added to the matrix repo.
Reply
#24
script.module.youtube.dl
Reply
#25
@docwra 
script.extendedinfo -> discontinued. Skinners should use https://forum.kodi.tv/showthread.php?tid=345847 (plugin approach) or https://forum.kodi.tv/showthread.php?tid=346034 (similar to script.extendedinfo; works without skin integration)
script.module.routing -> now available in the matrix repo (@zachmorris  fyi)
Main: Lancool II Mesh  - Ryzen 9 5900x - MSI x570 Unify - Zotac RTX 3080 AMP HOLO - 32GB Trident Z Neo 3600 CL16 -  EVO 960 M.2 250GB / EVO 940 250GB / MX100 512GB /  Crucial P1 2TB / WD Blue 3D Nand 2TB 
Sound: Saxx AS30 DSP - Beyer Dynamic Custom One Pro 
TV: Nvidia Shield 2019 Pro- Adalight 114x LEDs - Sony 65XG9505 - Kodi / Emby - Yamaha RX-V683 - Heco Victa 700/101/251a + Dynavoice Magic FX-4
Server: i3 Skylake - 8GB - OMV4 - 22TB Storage
Reply
#26
I have extendedinfo working along with dependency module.kodi65.  Unfortunately, the upstream repo on github has preliminary changes made for py2/py3 compatibility while my fixes are based on the released version in the Kodi repo.  Making a python3-only version for Matrix is much simpler (for me, anyway). 

The only shortfall now is the youtube / youtube-dl dependency as I'm not sure the py3 status of those addons.  The addon runs without youtube to provide the other enhanced info.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix see: Aeon MQ5 Mod Martix release thread
Leia see: Aeon MQ5 Mod Leia release thread
Reply
#27
I think this script.module.parsedom should be working in matrix can we add them to repo?
https://drive.google.com/drive/u/0/folde...RxeNvmLgrS
Reply
#28
Please update:
script.module.t0mm0.common
script.module.addon.common
Get Best of NHK, NRATV, DigitalRev TV and XiveTv add-ons via my repository. Enjoy!
Reply
#29
(2020-05-29, 15:29)misty01 Wrote: Please update:
script.module.t0mm0.common
script.module.addon.common

those were written in 2011, you should consider using something else written with modern python in mind.
Reply
#30
Is there any chance we can get Script.module.pil upgraded to py3 for Android please if it is at all possible

That would be absolutely amazing. I have an addon that works great on windows but wont on android as it needs pil.
Reply



Logout Mark Read Team Forum Stats Members Help
Library dependencies to Update to Python 30
This forum uses Lukasz Tkacz MyBB addons.