20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

Solved [Solved] TVDB scraper not working not finding data.
#1
I was trying to sort out a movie file in another thread. However in my attempts at renaming the file and adding multiple times I cleaned / updated my video db a few times. During this process I'm guessing that it tried to update my tv show library with whatever it couldn't find, then cleaning finished it off for my tv shows. The files are all still here however I cannot scan them regardless of doing each folder separately or globally my tv shows folder. I'm at a loss and the wife is a bit upset she can't get to her criminal minds.

All other local media seems to be working fine. SQL server is fine. I just can't get this stuff re-scanned in. If I do a recursive scan with the movies setting it works through all the files, takes several minutes. If I do it for tv shows it finishes near instant. Scanning the individual tv show folders gets me nowhere as well.
Reply
#2
Which scraper are you using for the TV shows, TVDB or TMDB?

In any case you should always be able to view the files and access them via the videos > files view, to keep the boss happy. But via that way you can do a similar trick to the one I talked you through for the movies also on the TV shows. Go into the information entry in the context menu and refresh and you should be able to pick again.

If not then enable debug loggin, reboot, gather a debug log (wiki) of a failed scrape, upload it to paste.kodi.tv and supply the url it will give you here and we can see what's going on.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#3
(2019-11-03, 21:11)DarrenHill Wrote: Which scraper are you using for the TV shows, TVDB or TMDB?

In any case you should always be able to view the files and access them via the videos > files view, to keep the boss happy. But via that way you can do a similar trick to the one I talked you through for the movies also on the TV shows. Go into the information entry in the context menu and refresh and you should be able to pick again.

If not then enable debug loggin, reboot, gather a debug log (wiki) of a failed scrape, upload it to paste.kodi.tv and supply the url it will give you here and we can see what's going on.
Ok this log is just now. I disabled music scanning as it seems to be working correctly. I changed to autoscan on boot for video files. I am currently using TVDB I believe. I can post another log with TMDB if necessary.

https://paste.ubuntu.com/p/Gt2Xs4RFJQ/

I see a bunch of dir skipping due to no change, yet the files are present and not loading into the database. Going to tv shows on the menu tells me to add a source. I know it isn't permissions as I can play the files just fine by finding them in the files menu and playing the mkv directly. Used a find command to unify directory and file permissions and ownerships on the filesystem. All music and movies play and load fine, just no tv shows seem to be available.

Thank you for the shortcut irectly to the files. Kept the wife happy earlier and she is about to start watching through that again in the next hour or so.
Reply
#4
There are some errors in the log related to the playlist Path Substitution you have setup. Lines 71-80 approx.

The log is not revealing due to "skipping due to no change". This happens with MySQL where once a folder is scanned for content, the next scan the folder will be ignored if there is no change to the folder. So you need to force a change.

Easiest would be to delete the movie Source out of Kodi, then run a Clean Library then enable Debug Mode.

Restart Kodi, and run the Library Update, then exit. <-- That is the log we need. It will show what the problem is.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
(2019-11-04, 02:06)Karellen Wrote: There are some errors in the log related to the playlist Path Substitution you have setup. Lines 71-80 approx.

The log is not revealing due to "skipping due to no change". This happens with MySQL where once a folder is scanned for content, the next scan the folder will be ignored if there is no change to the folder. So you need to force a change.

Easiest would be to delete the movie Source out of Kodi, then run a Clean Library then enable Debug Mode.

Restart Kodi, and run the Library Update, then exit. <-- That is the log we need. It will show what the problem is.
Marking as solved. I removed source and changed main folder name. Re-added and it scanned perfectly. Just for testing purposes I removed the new source, changed folder name back to tvshows again and it's scanning in now.
Reply
#6
Great!! Thread marked solved.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[Solved] TVDB scraper not working not finding data.00