Solved Extracted EDID for two video outputs?
#1
Hi,

I am trying to force the EDID on my setup but I can only seem to get one working. I followed fritchs' vaapi guide (with some modifications) but it doesnt seem to work for both outputs. Note, my setup is 2 video outs: 1 hdmi directly to tv and a 1 dp++>passive adapter>hdmi>avr>tv. The hdmi directly to the tv is for the video and the avr is just used to audio.

Code:
dmesg |pastebinit
https://paste.ubuntu.com/p/YYDH778GhG/

for p in /sys/class/drm/*/status; do con=${p%/status}; echo -n "${con#*/card?-}: "; cat $p; done
DP-1: disconnected
HDMI-A-1: connected
HDMI-A-2: connected

cat /var/log/Xorg.0.log |pastebinit
https://paste.ubuntu.com/p/RM6Fh83Xq9/

cat /etc/initramfs-tools/hooks/include-edid-data|pastebinit
https://paste.ubuntu.com/p/53NRfndyrJ/

cat /etc/default/grub |pastebinit
https://paste.ubuntu.com/p/fW3hdDXDMY/

edid-decode /usr/lib/firmware/edid/edid-mu7000.bin |pastebinit
https://paste.ubuntu.com/p/7HyttcVV9M/

edid-decode /usr/lib/firmware/edid/edid-rxv473.bin |pastebinit
https://paste.ubuntu.com/p/ybdw3fSvSm/

md5sum /lib/firmware/edid/*
d461e6278b7a78e3e21d9d2679c9230d  /lib/firmware/edid/edid-mu7000.bin
ed089f1d630c359d4b0bf0f2c4d2b1a0  /lib/firmware/edid/edid-rxv473.bin
 

Not sure what else I can provide, but if somthing is missing please let me know.
Any ideas?
Reply
#2
Got it! The boot options syntax was wrong. I should have RTFM Confused 
Need a comma between the two values (with no space!) and no second drm.edid_firmware tag:

Code:
dmesg |grep -i edid
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.3.0-23-generic root=UUID=0d6be0de-27a0-429d-84b3-978a7349e3da ro net.ifnames=0 biosdevname=0 video=HDMI-A-1:[email protected],HDMI-A-2:[email protected] drm.edid_firmware=HDMI-A-1:edid/edid-rxv473.bin,HDMI-A-2:edid/edid-mu7000.bin
[    0.082824] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.3.0-23-generic root=UUID=0d6be0de-27a0-429d-84b3-978a7349e3da ro net.ifnames=0 biosdevname=0 video=HDMI-A-1:[email protected],HDMI-A-2:[email protected] drm.edid_firmware=HDMI-A-1:edid/edid-rxv473.bin,HDMI-A-2:edid/edid-mu7000.bin
[    1.846073] [drm] Got external EDID base block and 1 extension from "edid/edid-rxv473.bin" for connector "HDMI-A-1"
[    1.850229] [drm] Got external EDID base block and 1 extension from "edid/edid-mu7000.bin" for connector "HDMI-A-2"
[    2.285876] [drm] Got external EDID base block and 1 extension from "edid/edid-rxv473.bin" for connector "HDMI-A-1"
[    2.290068] [drm] Got external EDID base block and 1 extension from "edid/edid-mu7000.bin" for connector "HDMI-A-2"
[    2.329121] [drm] Got external EDID base block and 1 extension from "edid/edid-rxv473.bin" for connector "HDMI-A-1"
[    2.333640] [drm] Got external EDID base block and 1 extension from "edid/edid-mu7000.bin" for connector "HDMI-A-2"
[    8.786959] [drm] Got external EDID base block and 1 extension from "edid/edid-rxv473.bin" for connector "HDMI-A-1"
[    8.792362] [drm] Got external EDID base block and 1 extension from "edid/edid-mu7000.bin" for connector "HDMI-A-2"

video= needs two tags though.

Great, audio switching is working perfectly now Blush
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Extracted EDID for two video outputs?00
This forum uses Lukasz Tkacz MyBB addons.