Pi4 subtitles video juddering
#1
Hi there,

My Raspi4 doesn't like subtitles with Libreelec and Kodi. Reportedly other Linux distros are affected too.
Playback seems just fine until any kind of subtitles are involved, which results immediately in video judder or frame skipping.
Is this a Linux/Raspi and or driver problem or does it have anything to do with Kodi?

Analog threads for LE e.g. are here:
https://forum.libreelec.tv/thread/20769-...rame-or-2/
https://forum.libreelec.tv/thread/20345-...tuttering/

Thanks
Reply
#2
Hi,
Some developer can see this report?
This happens too under  Raspberry OS on Kodi.
Thanks...
Reply
#3
I also have this issue with a pi4 4gb. I have buster lite installed with Kodi. I get stutter with any subtitle.
Reply
#4
I just had another look at my RPi4 Buster / Kodi setup. I can't see any 'juddering'.
Perhaps because I'm watching it on a PC monitor at 60Hz, and not a TV at 23Hz?
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
Yes, it's not too visible with monitor/tv at 60 hz, perhaps actually filming the playback in some kind of high fps mode will show the issue? Kodi itself doesn't detect any frame drops/skips when they are quite visible in reality.
Reply
#6
Just connected the RPi4 setup to my 2012 fullhd TV. I only enabled the "Adjust display refresh rate" option, as I did see some tiny hiccups with "Sync playback to display" so I disabled that.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#7
Frame drops happen with and without refresh rate sync. 60hz, 50hz, 23hz, makes no difference.
Reply



Logout Mark Read Team Forum Stats Members Help
Pi4 subtitles video juddering0
This forum uses Lukasz Tkacz MyBB addons.