Intel 8th gen NUC without frame stutters - how?
#1
OK. I'm a long time kodi user. I work in broadcast a/v so understand (and am very susceptible) to incorrect frame rates. I have 2 (actually 4 in total) kodi boxes. An old shuttle 35GTv2 Nvidia based box and an i3 8th Gen Intel NUC box. They drive an old (but capable) Pioneer PDP. Both run Ubuntu 18.04 plus the standard install of kodi from the ppa. Both are set "identically" in terms of switching frame rates etc... The Shuttle box works flawlessly. The i3 box has problems with frames that are either skipped or played out of order (I'm not sure which just yet). The frame drop/skip/reversal happens once every 5-10 seconds, I can't watch the i3 box, evern though it should be the "better" box.  Most of the stuff I play is 23.98 but xrandr/kodi.log says the box is playing at the correct frame rate.

Anyone have any ideas what is going on here? Settings are to change freq. on start/stop, 23.98 is enabled. Hardware VAAPI decode (although I have tried s/w decode). Using Obiaf's drivers (and the standard 18.04) and still the same. Any ideas?
Reply
#2
Might be a GPU Hz issue lke this - https://forum.libreelec.tv/thread/14614-...eelec-9-0/ - I know you say Ubuntu.  Just in case it has a similar issue...
Sorry, no help w/out a *full debug log*
Reply
#3
(2019-12-03, 07:59)bossanova808 Wrote: Might be a GPU Hz issue lke this - https://forum.libreelec.tv/thread/14614-...eelec-9-0/ - I know you say Ubuntu.  Just in case it has a similar issue...

Thanks for the pointer, but that doesn't seem to solve it Sad

Having said that, it looks like LibreELEC 9.2 does (although I need an audio offset of , however I'd like to be able to install other stuff (I run desktop apps as well like Brave).  Now I know the hardware "works" I can start tracking the issue down... Will start by trying 19.10...
Reply
#4
(as another BTW - Libreelec sets a default audio offest in the advanced_settings.xml IIRC correctly - I think because in the past a lot of TVs had mroe significant latency.  I remove it personally as I have not found it helpful...)

Good luck with your issue!
Sorry, no help w/out a *full debug log*
Reply
#5
Thanks. 19.10 didn't solve the problem.... Not sure where to go from here - whether to just do everything I want via plugins (don't like that idea as the computer is pretty powerful but it may well work...) or to persevere and try and find what is causing the micro-jumps.
Reply
#6
LibreElec releases often contain quite a lot of optimisation in terms of GPU drivers and the way these are driven.  @fritsch used to be incredibly helpful with Intel Kodi installations, though he may well now spend more time on other platforms. There used to be a guide he contributed to that covered optimised Ubuntu installs.  I see that guide is no longer a sticky in the Linux forum, but he may still be able to advise.

The reality is that LibreElec is always a much neater solution for most platforms that it is offered on - as boring stuff like video drivers, audio passthrough config etc. 'just works' in LE - whereas you can end up with a lot of additional work in a stock Ubuntu or similar distro.  You may find a dual boot solution is an option?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Intel 8th gen NUC without frame stutters - how?00