Movie Disc Playback
#1
Just want to start by saying that I love this skin, the home screen design is amazing and the customization is fairly easy as well. I am however having an issue with this skin when I try to watch an actual movie. it spins up the drive and Kodi recognizes that its a playable disc. I get the eject and play buttons showing up right above the menu also, but the movies just will not play. I have it set so that they will autoplay when I put them in the drive and Kodi attempts to play the movie, I get a glimpse of the movie menu and then it flashes back to the home screen. No matter how many times I click the play button the movie just will not play. Now what is weird is that if I switch to a different skin the movie plays with no issues, and it plays outside Kodi with no issues as well. Any thoughts as to why this is happening? I would really hate to have to switch to a different skin but I have a sizable collection of physical discs that  I would like to be able to use.
Reply
#2
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.
4.Upload the log to Kodi Paste Site manually or use the Kodi Logfile Uploader. (wiki) With either method post the link to the log back here.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file (wiki)

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Use the Kodi Paste Site. Post the link to your pasted log in the forum
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
@Eldersilverdragon 

Thanks! I have been able to reproduce the bug that you mention, but only when home melodies option is enabled (I suppose that's your case). I have already fixed the bug, from now on when a disc is loaded the home melodies will stop. The new version is available in github, but if that's too much hassle for you, for the time being you can disable the home melodies option in settings when you are going to play a dvd and you won't have any problem.
If I have helped you or increased your knowledge, please click the 'thumbs up' button to give thanks :) 
Reply
#4
(2019-12-11, 21:04)manfeed Wrote: @Eldersilverdragon 

Thanks! I have been able to reproduce the bug that you mention, but only when home melodies option is enabled (I suppose that's your case). I have already fixed the bug, from now on when a disc is loaded the home melodies will stop. The new version is available in github, but if that's too much hassle for you, for the time being you can disable the home melodies option in settings when you are going to play a dvd and you won't have any problem.

Yes, Thank you that did fix the problem. Sorry it took me a bit to get back to you I have been pretty busy. thank you for the quick response time. I will update the skin soon but until then I just turned off the home melodies option.
Reply



Logout Mark Read Team Forum Stats Members Help
Movie Disc Playback0
This forum uses Lukasz Tkacz MyBB addons.