Kodi and booting Manjaro
#1
Good Day,

yesterday i installed kodi in manjaro 18.1.4 rc2 kde 64 bit testing build, this was after i installed several other pieces of software from manjaro's software center. after i installed kodi i launched it and set it for windowed., and then closed kodi and rebooted the system. once it rebooted i was presented with the kodi home screen and no apparent way to boot to my desktop. try as i might to get kodi to shut down as normal with kodi it didn't want to exit. i finally did a hard reboot and once again was presented with kodi. this time when i clicked kodi's power button i waited remembering that it can take kodi awhile to close. finally kodi close and i was presented with my manjaro login screen, gut when i entered my password i was taken right back to kodi.  i did this routine 3 or 4 more times before i noticed in EXTREMELY tiny text in the bottom left corner that i had a menu to select either kodi or manjaro., so i selected manjaro, entered my password and FINALLY ended up on my desktop. once there for the time being i uninstalled kodi. i want to reinstall it, but i need to make sure it's not going to do that again. i also want to make sure kodi is not running in the background when i don't have it open. thanks
Reply
#2
Sounds like we need to inspect their (manjaro) PKGBUILD+files for kodi...
Need help programming a Streamzap remote?
Reply
#3
(2019-12-16, 23:16)graysky Wrote: Sounds like we need to inspect their (manjaro) PKGBUILD+files for kodi...

looks to me you have a setting in kodi to have it run as a server, which is fine as long as there is a easy way to switch between kodi and the os during boot.
Reply
#4
Kodi is not meant as a server and there is no such settings
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#5
kodi does add the option to start kodi from the login screen (/usr/share/xsessions/kodi.desktop).
i have no clue why it was set to default at your end... afaik it should always use the option from the last session.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#6
(2019-12-17, 13:46)ronie Wrote: kodi does add the option to start kodi from the login screen (/usr/share/xsessions/kodi.desktop).
i have no clue why it was set to default at your end... afaik it should always use the option from the last session.



thanks for the info. how is it disabled from within settings? needless to say i just about had a stroke when i saw that and had to cheat it to get to my desktop. one thing kodi has had a problem with since the first time i ran it under windows is it not wanting to exit when you press it's power settings button. i know this bug affects a lot of people cause when kodi was taking it's sweet time closing in windows i went hunting for a solution and found a lot of people who mentioned the same issue regardless of os platform. the devs have had years to get to the bottom of the slow shut down for kodi. from what i see i really don't think they put much if any time into figuring out why kodi takes so long to exit.
Reply
#7
https://forum.manjaro.org/t/kodi-and-boo...aro/115485
Reply
#8
(2019-12-16, 17:14)GraveDigger1 Wrote: Good Day,

yesterday i installed kodi in manjaro 18.1.4 rc2 kde 64 bit testing build, this was after i installed several other pieces of software from manjaro's software center. after i installed kodi i launched it and set it for windowed., and then closed kodi and rebooted the system. once it rebooted i was presented with the kodi home screen and no apparent way to boot to my desktop. try as i might to get kodi to shut down as normal with kodi it didn't want to exit. i finally did a hard reboot and once again was presented with kodi. this time when i clicked kodi's power button i waited remembering that it can take kodi awhile to close. finally kodi close and i was presented with my manjaro login screen, gut when i entered my password i was taken right back to kodi.  i did this routine 3 or 4 more times before i noticed in EXTREMELY tiny text in the bottom left corner that i had a menu to select either kodi or manjaro., so i selected manjaro, entered my password and FINALLY ended up on my desktop. once there for the time being i uninstalled kodi. i want to reinstall it, but i need to make sure it's not going to do that again. i also want to make sure kodi is not running in the background when i don't have it open. thanks
You seem to have Kodi set as your default desktop. Shut down Kodi and when presented with your login screen choose the desktop that you require from one of the dropdown menu's on the login screen.
Reply
#9
(2019-12-18, 13:19)happyaslarry Wrote:
(2019-12-16, 17:14)GraveDigger1 Wrote: Good Day,

yesterday i installed kodi in manjaro 18.1.4 rc2 kde 64 bit testing build, this was after i installed several other pieces of software from manjaro's software center. after i installed kodi i launched it and set it for windowed., and then closed kodi and rebooted the system. once it rebooted i was presented with the kodi home screen and no apparent way to boot to my desktop. try as i might to get kodi to shut down as normal with kodi it didn't want to exit. i finally did a hard reboot and once again was presented with kodi. this time when i clicked kodi's power button i waited remembering that it can take kodi awhile to close. finally kodi close and i was presented with my manjaro login screen, gut when i entered my password i was taken right back to kodi.  i did this routine 3 or 4 more times before i noticed in EXTREMELY tiny text in the bottom left corner that i had a menu to select either kodi or manjaro., so i selected manjaro, entered my password and FINALLY ended up on my desktop. once there for the time being i uninstalled kodi. i want to reinstall it, but i need to make sure it's not going to do that again. i also want to make sure kodi is not running in the background when i don't have it open. thanks
You seem to have Kodi set as your default desktop. Shut down Kodi and when presented with your login screen choose the desktop that you require from one of the dropdown menu's on the login screen. 
how about not telling me what i already know. how about letting me how to stop this behavior. the default for kodi should be to just run on the desktop unless the ENDUSER decides to expressly go into settings and enable run on startup / run as desktop or whatever it's called.
Reply
#10
(2019-12-18, 15:57)GraveDigger1 Wrote:
(2019-12-18, 13:19)happyaslarry Wrote:
(2019-12-16, 17:14)GraveDigger1 Wrote: Good Day,

yesterday i installed kodi in manjaro 18.1.4 rc2 kde 64 bit testing build, this was after i installed several other pieces of software from manjaro's software center. after i installed kodi i launched it and set it for windowed., and then closed kodi and rebooted the system. once it rebooted i was presented with the kodi home screen and no apparent way to boot to my desktop. try as i might to get kodi to shut down as normal with kodi it didn't want to exit. i finally did a hard reboot and once again was presented with kodi. this time when i clicked kodi's power button i waited remembering that it can take kodi awhile to close. finally kodi close and i was presented with my manjaro login screen, gut when i entered my password i was taken right back to kodi.  i did this routine 3 or 4 more times before i noticed in EXTREMELY tiny text in the bottom left corner that i had a menu to select either kodi or manjaro., so i selected manjaro, entered my password and FINALLY ended up on my desktop. once there for the time being i uninstalled kodi. i want to reinstall it, but i need to make sure it's not going to do that again. i also want to make sure kodi is not running in the background when i don't have it open. thanks
You seem to have Kodi set as your default desktop. Shut down Kodi and when presented with your login screen choose the desktop that you require from one of the dropdown menu's on the login screen.   
how about not telling me what i already know. how about letting me how to stop this behavior. the default for kodi should be to just run on the desktop unless the ENDUSER decides to expressly go into settings and enable run on startup / run as desktop or whatever it's called.  

Why are you intentionally antagonizing people who are trying to help you?  Further, why are you bitching about something that has nothing to do with upstream?  Your problem is not related to Kodi, it's related to your settings and/or your distro.
Need help programming a Streamzap remote?
Reply
#11
(2019-12-18, 15:57)GraveDigger1 Wrote: how about not telling me what i already know. how about letting me how to stop this behavior. the default for kodi should be to just run on the desktop unless the ENDUSER decides to expressly go into settings and enable run on startup / run as desktop or whatever it's called.

How about you take it down a notch?

I don't know Manjaro, but I know Windows, Android and Ubuntu. Kodi is not set to automatically start as a home screen on any of them. Perhaps in all your enthusiasm you've made certain changes to the boot loader or login menu section in Manjaro, causing your current predicament. I know it's possible in Ubuntu, but it's certainly not the default setting. It's not a setting inside of Kodi itself. It's not that OS aware.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#12
Can we please keep this civil, please?
This is a forum for the benefit of end-users. There is no need to get belligerent.
Got a Kodi problem? Provide us with a full Debug log (wiki)  || Useful pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || forum rules (wiki) || VPN policy (wiki)
Reply
#13
(2019-12-18, 16:45)Klojum Wrote:
(2019-12-18, 15:57)GraveDigger1 Wrote: how about not telling me what i already know. how about letting me how to stop this behavior. the default for kodi should be to just run on the desktop unless the ENDUSER decides to expressly go into settings and enable run on startup / run as desktop or whatever it's called.

How about you take it down a notch?

I don't know Manjaro, but I know Windows, Android and Ubuntu. Kodi is not set to automatically start as a home screen on any of them. Perhaps in all your enthusiasm you've made certain changes to the boot loader or login menu section in Manjaro, causing your current predicament. I know it's possible in Ubuntu, but it's certainly not the default setting. It's not a setting inside of Kodi itself. It's not that OS aware. 
 all i did was open manjaro's sofware center, search for kodi, and install it. as for grub i have not made any changes to it. so if it's not a setting in kodi and i'm sure it's not something in manjaro it has to be something in the community build. i just emailed the packager and gave him / her both the link to this thread and the one i created on the manjaro forums.  since i know uninstalling kodi stops the behavior and manjaro boots normally maybe i'll reinstall it and see if the person who packaged it for manjaro made any changes in settings.
Reply
#14
We have our PPA for Ubuntu. Arch Linux usually does its own packaging of Kodi, so .. anything is possible I guess.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#15
(2019-12-18, 19:23)Klojum Wrote: We have our PPA for Ubuntu. Arch Linux usually does its own packaging of Kodi, so .. anything is possible I guess.

it's most likely some tiny bit of code that wasn't or shouldn't of made it in to their build, but you did give me one idea. that is to reinstall kodi and take a look at grub before and after the reinstall.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi and booting Manjaro00
This forum uses Lukasz Tkacz MyBB addons.