High CPU in 18.5 on Ubuntu 18.04
#16
Update: I have good news and bad news. 

The good news is that Kodi is running well again, with "idle" cpu around 25% and cpu under load (watching tv at 1920x1080) around 40%.  

The bad news is that I don't know exactly what the cause of the problem was.  Here is what happened:
- As part of troubleshooting, I renamed the userdata and addons folders and ran Kodi - without any addons or media libraries, it ran fine, no CPU problems.
- At one point, I mistakenly restored the userdata folder but not the addons folder.  When I restarted Kodi, I realized the mistake because the skin & addons weren't restored as I had expected. 
- So I stopped Kodi and restored the addons folder, but now the addons and userdata were out of sync.  Kodi continued to appear without any of the addons etc enabled, but I was able to go in to Settings/Addons & see all my installed addons, which were now all disabled. 
- I enabled the "important" ones that I can't live without, and kodi continued to work properly.  It's now fully usable again.

There are still a slew of addons that are disabled.  Most of these I am not familiar with, and didn't specifically install.  And I don't know what they do - I seem to have full functionality without them.

Conclusion: the problem is with an addon, but I can't pinpoint which one.  

@jackh maybe this could help you, good luck!
Reply
#17
(2019-12-21, 16:18)jrmcfly Wrote: @jackh maybe this could help you, good luck!

Yeah, dark addons... the usual suspects... I'll give that a try and report back for posterity.
If anyone is waiting on my news please bear with me as today I may not be able to find the time. I recognize that I arrived at this thread searching for my symptoms so I may not be the only one out there Smile

@jrmcfly Which skin are you using? I'm with Aeon Nox Silvo
Reply
#18
OK, good news, got it!

After following @jrmcfly 's instructions for getting all the addons disabled I started enabling them in small batches. The trick (learned the hard way...) is to enable an addon, then exit Kodi and restart it. The issue kicks-in ONLY after restarting the entire app, not immediately after enabling the addon.

With a bit of patience eventually I arrived at the culprit: it's "Artist Slideshow". I will report this case on the addon thread here, which actually contains a similar recent case but on a RaspPI.

For the time being, I can live without it.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
High CPU in 18.5 on Ubuntu 18.0400
This forum uses Lukasz Tkacz MyBB addons.