Issues with arrow

So, I tried the 0.15.6 from the link you provided and got close to the same error result. This time, bytes was returned rather than the usual datetime. Also remember, this is on Ubuntu 20.04 and not Windows. 
Quote:2021-04-01 17:32:47.017 T:3831     INFO <general>: CAddonMgr::FindAddons: script.module.arrow v0.15.6+matrix.1 installed

2021-04-01 17:32:58.015 T:3943    ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'AttributeError'>
                                                   Error Contents: 'bytes' object has no attribute 'timestamp'
                                                   Traceback (most recent call last):
                                                     File "/home/mediapc/.kodi/addons/", line 10, in <module>
                                                       from resources.lib.plugin_content import PluginContent
                                                     File "/home/mediapc/.kodi/addons/", line 22, in <module>
                                                       from metadatautils import MetadataUtils
                                                     File "/home/mediapc/.kodi/addons/script.module.metadatautils/lib/", line 10, in <module>
                                                       import helpers.kodi_constants as kodi_constants
                                                     File "/home/mediapc/.kodi/addons/script.module.metadatautils/lib/helpers/", line 11, in <module>
                                                       from .utils import KODI_VERSION
                                                     File "/home/mediapc/.kodi/addons/script.module.metadatautils/lib/helpers/", line 13, in <module>
                                                       import arrow
                                                     File "/home/mediapc/.kodi/addons/script.module.arrow/lib/arrow/", line 2, in <module>
                                                       from .api import get, now, utcnow
                                                     File "/home/mediapc/.kodi/addons/script.module.arrow/lib/arrow/", line 12, in <module>
                                                       from arrow.arrow import TZ_EXPR, Arrow
                                                     File "/home/mediapc/.kodi/addons/script.module.arrow/lib/arrow/", line 34, in <module>
                                                       from arrow import formatter, locales, parser, util
                                                     File "/home/mediapc/.kodi/addons/script.module.arrow/lib/arrow/", line 26, in <module>
                                                       from arrow.util import next_weekday, normalize_timestamp
                                                     File "/home/mediapc/.kodi/addons/script.module.arrow/lib/arrow/", line 6, in <module>
                                                       from arrow.constants import (
                                                     File "/home/mediapc/.kodi/addons/script.module.arrow/lib/arrow/", line 16, in <module>
                                                       _MAX_TIMESTAMP = datetime.max.timestamp()
                                                   AttributeError: 'bytes' object has no attribute 'timestamp'
                                                   -->End of Python script error report<--

Logout Mark Read Team Forum Stats Members Help
Issues with arrow0
This forum uses Lukasz Tkacz MyBB addons.