v18 IP Camera RTSP Stream doesnt start in Kodi
#1
I give up. I have tried 2 days to get the stream from my IP Camera working in Kodi, but it simply doesn't work. The Stream starts loading and stops immediately.

With VLC and iSpy it is working like a charm.

Here is the the media information from VLC:

Here is the log:
Hey folks,
I give up. I have tried 2 days to get the stream from my IP Camera working in Kodi, but it simply doesn't work. The Stream starts loading and stops immediately.

With VLC and iSpy it is working like a charm.

Here is the the media information from VLC:
Image

Here is the log:
wajasufaza.kodi (paste)

Thanks in advance
Reply
#2
Hi All

Knowing it's an old Thread, I really want to revive the topic.
I face exactly the same behaviour that Idok_ describes.

As described in many tutorials, I saved the rtsp-URL in a .strm file and then start the stream in kodi. It starts to open the stream and immediately stops (before first frames come in).
The URL plays smoothly in VLC, mplayer, etc.

I uploaded the log here: Logfile

The first Error in the log (regarding Framerate) is overriden by the default (25 fps). The second Error to me seems rather a consequence that a cause of the problem.

Really appreciating any help!
(Since its a private CCTV stream, I don't want to publicly provide the URL. If you want to test on your system, just ping me a message!)

Thank you very much in advance and best regards
bb
Reply
#3
Hi, I had a somewhat similar issue when using the IPTV simple client addon.
I solved it by adding a kodiprop. Maybe that will work with your strm file as well.

#KODIPROP:inputstream=inputstream.ffmpeg
#EXTINF:-1 group-title="CCTV" ,CAM1
rtsp://192.168.20.20:554/live0.264
Reply
#4
Thanks Luguber,

I tried your suggestion and also studied (and experimented with) the context around inputstream adaptive further.

Unfurtunately, this did not resolve the issue.

Any other thoughts?

Thanks and best regards
bb
Reply
#5
Provide a full uncut Debug Log not a snippet that you think is relevant.
Make sure that you have the right rtsp url for your camera, make sure that  you pass correct auth data to your camera in the way that it expects.
Make sure that your camera video feed is properly setup, some camera vendors like to use codecs with proprietary extensions eg h264+ h265+ which won't work in any player except vendors own software.
The best way to check it is vlc - when you get the url working in vlc - write it down to strm file and try with kodi.
Eg/ rtsp://username:[email protected]:554/whatever.sdp
If you have problems accessing rtsp stream with vlc - try vendor's support or a dedicated CCTV forum, Kodi is a mediaplayer and not a cctv software after all.
Reply
#6
Hi asavah

appreciate the warm welcome! :-)

As requested, here a full Debug Log
(The RTSP stream is being triggered at time stamp 2021-05-10 12:46:16.131 T:2394985328)

As stated in my above message, the stream-URL plays perfectly well in VLC, mplayer, etc.

Looking forward to your support.

Thank you very much and best regards
bb
Reply
#7
@biberbb this is raspberry pi ... which you should have stated from the beginning.
This looks to me that it might be a rpi hardware acceleration issue or a crap stream coming from your camera or both.
Software decoders can deal with crap coming from crap cameras, but hardware decoders are more picky.
It might be a good idea to move your question to the pi support forum where it has higher probability to be seen by the right person.

"Report" your own thread - "Wrong forum" to request a moderator to move this thread.
Reply
#8
No need to report, already seen and moved to the Pi section.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply



Logout Mark Read Team Forum Stats Members Help
IP Camera RTSP Stream doesnt start in Kodi0
This forum uses Lukasz Tkacz MyBB addons.