v18 problem following mysql update
#1
Hello
I have a problem with kodi 18.5.
I have a Mysql MariaDB base for kodi, it has been updated and since kodi can no longer find the base ...
The given database is well started and I find it in mariaDB, the port is also correct.
How do I get kodi to find her? Have you ever had this problem?
Reply
#2
You need to supply a debug log that shows Kodi starting up and trying to connect to the database.  The instructions are --> Log_file/Easy (wiki) <-- in that link.  Please make sure you enable debug logging and then restart Kodi, otherwise the log will not contain the relevant information.  As soon as you get to Kodi's home screen, there should be enough information in the log to help diagnose your issue so you can quit kodi and upload the log, or use the log uploader addon to do so.
Learning Linux the hard way !!
Reply
#3
Ok i just found the line
2020-01-11 13:30:45.273 T:14272   ERROR: Unable to open database: MyVideos116 [2002](Can't connect to MySQL server on '192.168.0.21' (10061))
He cannot connect to the base but the advancesetting file has not changed however


2020-01-11 13:29:18.328 T:6596  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <videodatabase>
                                                <type>mysql</type>
                                                <host>192.168.0.21</host>
                                                <port>3308</port>
                                                <user>kodi</user>
                                                <pass>*****</pass>
                                              </videodatabase>
                                              <musicdatabase>
                                                <type>mysql</type>
                                                <host>192.168.0.21</host>
                                                <port>3308</port>
                                                <user>kodi</user>
                                                <pass>*****</pass>
                                              </musicdatabase>
                                              <videolibrary>
                                                <importwatchedstate>true</importwatchedstate>
                                                <importresumepoint>true</importresumepoint>
                                              </videolibrary>
                                            </advancedsettings>


How can I give you the full log file?
Reply
#4
To upload the full log file, open it in whatever text editor you are using and select all, then copy.  go to https://paste.kodi.tv/ in your broswer.  Right click in the window and paste the logfile into the window.  Then click the little disk icon on the right to save the log.  When the page refreshes, copy the full url in your browsers address bar and paste that into a post here.
Learning Linux the hard way !!
Reply
#5
ERROR: Unable to open database: MyVideos116 [2002](Can't connect to MySQL server on '192.168.0.21' (10061))

This line should tell you enough. See https://mariadb.com/kb/en/troubleshootin...on-issues/
Or perhaps totally reinstall MariaDb ?
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#6
Ha yes, permissions issue or mariadb is not running.
Learning Linux the hard way !!
Reply
#7
The link of the complete log file : itezigepur.kodi (paste)

I will look at the side of mariadb but it seemed to me that everything was correct
Reply
#8
I don't understand, the base is well started, I access it from PHPMyAdmin, I am good on MariaDB 10.4.7 and I find MyVideos116.
I connect well on the base with the user kodi.
I really don't understand what's blocking ...
Reply
#9
Error 2002 means "can't connect through local socket", 10061 means "connection refused".  So, if the server is up and running, make sure that there is no firewall blocking the port and that MariaDB is configured to use the port you specified in your advancedsettings.xml (3308) because the default port is 3306.

Note that if you change the port in my.cnf you must restart mariadb for it to be applied.
Learning Linux the hard way !!
Reply
#10
Is your MariaDB allowed to do remote connections?
Better re-check your database user credentials of the user 'kodi'.
Hosting allowed should be from '%', not just the localhost.
Also re-check as well the "GRANT ALL" privileges.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#11
I checked, the port is set to 3308.
the Kodi user is correct, I recreated it in case but without change.
I must check the firewall of my NAS (where mariadb is installed).
For the remote access parameter on mariadb, where can I check this?
Reply
#12
(2020-01-13, 17:08)zeze31 Wrote: For the remote access parameter on mariadb, where can I check this?
In the system database table 'mysql'.
SELECT User,Host from user;
where Host should be % for the user 'kodi' .
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#13
The result of the SQL query :
Code:
  User Host
kodi %
read %
root 127.0.0.1
root ::1
localhost
kodi localhost
read localhost
root localhost
nas-ts-451
root nas-ts-451

I checked, there is no firewall on my server
Reply
#14
You seem to have 2 users named 'kodi', with different Host values. Heck, there are multiple entries of several database users, even. Why? (Or did your paste go wrong?)

I'd remove the localhost one for 'kodi' for starters.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#15
I deleted all unnecessary users, I left only kodi% and root but no change.
Question: on my QNAP NAS, I therefore have QPHPMyAdmin and QMariaDB to install. Everything must be started or only QMariaDB?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
problem following mysql update00