All Addons in V19 not working?
#1
Hi

I'm working with a developmental build on Android. V 19.

None of my addins are working and I'm confused why. Is there a new settings I need to have. Any advice is greatly appreciated.

Thank you.

Bobo
Reply
#2
V19 needs python 3 compatible addons whereas v18.x used python 2.  If your addons are not working, you should contact the authors of them and ask them to update them to python 3.
Learning Linux the hard way !!
Reply
#3
Might there be a list of addons that are currently v 19 compatable?

Thank you,

Bobo
Reply
#4
Just check what's available to install from the repo.
Reply
#5
(2020-01-13, 00:02)Hitcher Wrote: Just check what's available to install from the repo.

Unfortunately the addons for v18 and below are not specified.....
Reply
#6
sadly there's no such list atm.
the repo in v19 also lists py2 addons that have not been updated.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#7
Don't you think there should be a backward compatibility? Why we are facing such problem?
Reply
#8
the main issue is there is no indicator in the addon.xml file that tells whether an addon is py2-only or py2/py3 compatible.
without such an indicator it is not possible to exclude the py2-only ones in the repo for v19.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#9
The closest to the list for the Official repo would be to look at the relevant repo branches on Github

Everything in the Leia branch should be compatible with both Python 2 & 3 so therefore should work on both v18 and v19.

https://github.com/xbmc/repo-plugins/tree/leia

Everything in Matrix branch will be Python 3 compatible only so will only work on v19

https://github.com/xbmc/repo-plugins/tree/matrix

As you can see there's only 1 addon in Matrix branch that's Python 3 only, so it seems most addons that are updating are targeting dual Python 2 & 3 compatibility.

However that won't show you everything as I think update submissions with dual Python 2 & 3 compatibility have been allowed in the branches for earlier releases, however it hasn't been a requirement for branches earlier than Leia to have Python 3 compatibility so it's difficult to tell which might be v19 compatible. As Python 3 compatibility is only enforced for submissions to Leia branch onwards, only those that show in Leia/Matrix branches are guaranteed to be v19 compatible.
Reply
#10
(2020-01-14, 14:40)jjd-uk Wrote: Everything in the Leia branch should be compatible with both Python 2 & 3 so therefore should work on both v18 and v19.

sadly that is not even the case, we've been accepting submissions to the leia branch months before we started to require py3 compatibility.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#11
Damn I thought we agreed prior to Leia branch being open that all submissions would have to include Python 3 compatibility.
Reply
#12
And Dailymotion addon is in Jarvis repo and yet py2/py3 compatible Smile
Kodi 18.5 x64 Windows | CoreElec 9.2.1 S905X
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
All Addons in V19 not working?00