•   
  • 1
  • 30
  • 31
  • 32
  • 33
  • 34(current)
Beta Sling
I just started having difficulties viewing Recordings and "Continue Watching".    This started maybe two days ago.   I have four RPi4's all running LibreElec v10.0.3 and all of them are having the same issue. 

I turned on the Sling debug log and Kodi debugging.  Here is the log

Kodi Sling errors 

Thanks you

Daryl
Reply
(2022-11-27, 17:11)rosede Wrote: I just started having difficulties viewing Recordings and "Continue Watching".    This started maybe two days ago.   I have four RPi4's all running LibreElec v10.0.3 and all of them are having the same issue. 

I turned on the Sling debug log and Kodi debugging.  Here is the log

Kodi Sling errors 

Thanks you

Daryl
Looking through the log file, I see these entries:
Quote:2022-11-27 08:53:57.882 T:949     ERROR <general>: GetDirectory - Error getting plugin://plugin.video.sling/?mode=my_tv&name=Recordings&url=https%3a%2f%2fp-cmwnext.movetv.com%2fpg%2fv1%2fmy_tv_tvod%2frecordings%3fdma%3d652%26timezone%3d-0600

2022-11-27 08:54:06.054 T:957     ERROR <general>: GetDirectory - Error getting plugin://plugin.video.sling/?mode=my_tv&name=Continue%20Watching&url=https%3a%2f%2fp-cmwnext.movetv.com%2fpg%2fv1%2fmy_tv_tvod%2frecents%3fdma%3d652%26timezone%3d-0600

2022-11-27 08:54:08.750 T:959     ERROR <general>: GetDirectory - Error getting plugin://plugin.video.sling/?mode=my_tv&name=My%20TV

Anyone have any idea what the error's mean?  

Thanks

Daryl
Reply
The same happened to me about a month ago. But it is working now. After a week or so, it clean it self up. I figured it was something at Sling.
Reply
(2022-11-28, 14:50)rosede Wrote:
(2022-11-27, 17:11)rosede Wrote: I just started having difficulties viewing Recordings and "Continue Watching".    This started maybe two days ago.   I have four RPi4's all running LibreElec v10.0.3 and all of them are having the same issue. 

I turned on the Sling debug log and Kodi debugging.  Here is the log

Kodi Sling errors 

Thanks you

Daryl
Looking through the log file, I see these entries:
Quote:2022-11-27 08:53:57.882 T:949     ERROR <general>: GetDirectory - Error getting plugin://plugin.video.sling/?mode=my_tv&name=Recordings&url=https%3a%2f%2fp-cmwnext.movetv.com%2fpg%2fv1%2fmy_tv_tvod%2frecordings%3fdma%3d652%26timezone%3d-0600

2022-11-27 08:54:06.054 T:957     ERROR <general>: GetDirectory - Error getting plugin://plugin.video.sling/?mode=my_tv&name=Continue%20Watching&url=https%3a%2f%2fp-cmwnext.movetv.com%2fpg%2fv1%2fmy_tv_tvod%2frecents%3fdma%3d652%26timezone%3d-0600

2022-11-27 08:54:08.750 T:959     ERROR <general>: GetDirectory - Error getting plugin://plugin.video.sling/?mode=my_tv&name=My%20TV

Anyone have any idea what the error's mean?  

Thanks

Daryl

I find that if I delete the Sling database and reboot, that will sometimes fix an issue like that. If you go into the settings for Sling >> Expert >> Delete Database, that should do it.
Reply
@Doctor Eggs @hagertyoh 

Thanks for the replies. I deleted the database and rebooted as suggested, a couple of times, but this did not work.  I feel there a path or something has changed on Slings side, because this is happening on all four of my RPi4 devices.  If it was one or even two devices, I could see a corrupted database and deleting and recreating it could solve this issue, but it's all four.  

Is this add-on dead?   Its been a year since it was last updated or even touched in Git and the developers have not posted in nearly a year.   My fear is if they stopped work on the add-on and if Sling did make a change, then this will never get fixed.  I'm not a developer and have no idea how to go about fixing this myself. 

Thanks

Daryl
Reply
When I was trying to fix. I remember installing the optional PySocks dependency. At the time I did not think it did anything but maybe that had something to do with the fix. I also feel it may have been part of a wider communication issue within the raspberry so I disabled other communication dependent addons like next up, Amazon prime, Netflix.
Reply
(2022-12-01, 20:58)hagertyoh Wrote: When I was trying to fix. I remember installing the optional PySocks dependency. At the time I did not think it did anything but maybe that had something to do with the fix. I also feel it may have been part of a wider communication issue within the raspberry so I disabled other communication dependent addons like next up, Amazon prime, Netflix.

I just tried it, and the Recordings and Continue Watching is back. So, I think your original assessment of Sling doing something on their end was the issue.  Which honestly surprises me.  I would think that if they were making aa change it would effect all users at the same time, but perhaps they're doing it region by region. 

Anyway, I'm happy that the functionality is back.  Thanks for your replies.

Daryl
Reply
I've noticed the same thing and found that some of the recordings are causing the issue. More specifically recordings that just finished recording. I usually just delete the last couple of recordings from the app (if I've already watched them on the app or live) then try again and it starts working.
Reply
I started experiencing this issue again; this time with "Continue Watching" only.  I could access the Recordings, but I just couldn't continue watching via the continue watching function.  After a week or so, I thought that I'd check the forum to see if anyone else is experiencing this and I see this comment.  
(2022-12-03, 08:00)snoopyjoe Wrote: I've noticed the same thing and found that some of the recordings are causing the issue. More specifically recordings that just finished recording. I usually just delete the last couple of recordings from the app (if I've already watched them on the app or live) then try again and it starts working.
Well this sounds promising.  Perhaps its an a corrupt recording causing this issue, I've experienced corrupted recordings before, so would not be surprised.  I deleted all of the recordings that I've watched and now, I can't get to recordings.  

This is getting really frustrating.  

I use Matt Huisman's Stremium and IPTV Merge add-ons primarily, and really don't need this app, other than to access all of the On-Demand features as well as the the recordings etc....

Daryl
Reply
Windows 10, using iptv simple along sling. A couple of weeks ago I started having trouble with not getting a video feed, only audio on sling.

I uninstalled sling and iptv simple and reinstalled but continue to have the same problem. (sometimes the video will play on the first channel i choose but in trying to change the channel i get the same problem)

I also use nexrpvr along with the iptv simple and I o not have any trouble with video

https://paste.kodi.tv/zitehodefi
Reply
I went ahead and spent the $5 for stremium as suggested in an earlier post because this addon had become such a headache. Stremium (Matt Huisman addon) makes the guide work right for IPTV since it obvs works with IPTV Merge. It'd be nice to not have to spend that extra $5.
Reply
(2022-12-23, 18:53)clones Wrote: Windows 10, using iptv simple along sling. A couple of weeks ago I started having trouble with not getting a video feed, only audio on sling.

I uninstalled sling and iptv simple and reinstalled but continue to have the same problem. (sometimes the video will play on the first channel i choose but in trying to change the channel i get the same problem)

I also use nexrpvr along with the iptv simple and I o not have any trouble with video

https://paste.kodi.tv/zitehodefi


I think this has to do with Kodi 20. My XBox updated to Kodi 20 RC1 automatically and I started having the same issues. Hopefully it will be fixed at some point. I updated a raspberry rpi4 with Kodi 20 and had similar issues. So it seems to not be isolated to windows.
Reply
(2022-12-23, 18:53)clones Wrote: Windows 10, using iptv simple along sling. A couple of weeks ago I started having trouble with not getting a video feed, only audio on sling.

I uninstalled sling and iptv simple and reinstalled but continue to have the same problem. (sometimes the video will play on the first channel i choose but in trying to change the channel i get the same problem)

I also use nexrpvr along with the iptv simple and I o not have any trouble with video

https://paste.kodi.tv/zitehodefi
Well I thought my windows 10 system, which did not have a stand alone graphics card, might have been the problem. Added a new graphics card, unfortunately no change, still no video only audio.
Reply
Incredible stupid question, I'm trying a fresh install of Kodi (19.5, am waiting on 20 right now), Windows 10, I am downloading the sling add zip from D21spike's github page (plugin.video.sling-Matrix.zip) and am getting an error message, and http://iofault.com/repo-zip page is giving an error message. What simple thing am I missing?

Never mind: I got it to download
Reply
  •   
  • 1
  • 30
  • 31
  • 32
  • 33
  • 34(current)



Logout Mark Read Team Forum Stats Members Help
Sling0
This forum uses Lukasz Tkacz MyBB addons.