•   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  •   
Beta Sling
(2020-07-12, 23:55)feerlessleadr Wrote:
(2020-07-12, 23:08)lasers Wrote: I was able to work around the above issue by disabling the VOD service in settings.xml.

I'm also noticing every time I reboot, IPTV simple loses the EPG/channel information. It still is present in the sqlite database though...
I would have expected that it would fallback to cache if the slinger service fails. For whatever reason when IPTV-simple requests the m3u or xml file, it's blank.

Glad I'm not the only one. Mind sharing what you modified in the settings.xml to disable?

Thanks
It turns out this didn't work right. Oddly a users fork seems to be working just fine... https://github.com/snoopyjoe/plugin.video.sling
Reply
(2020-05-05, 20:57)markeymark Wrote:
(2020-05-05, 18:57)rifken Wrote:
(2020-05-05, 14:43)markeymark Wrote: you can make an m3u of sling channels to play in any m3u program, you just need to code it correctly, the add on is what autenticates the stream, not simple iptv player, I can help if you need  
That would be amazing!  I wasn't sure if there was something with Widevine that prevented that...  I swear I got tv mosaic to play a single stream the other day when I tested and then after that initial test it stopped working.

What I did was use the web server this addon spins up as the URL for the remote M3U and XMLTV guide URLs in TV Mosaic.  There's really not much more to it than that (at least from passing in a M3U and XMLTV guide)...  It does find the channels as well as the guide info using that but the playback appears to time out...  

If we need to take this out of the scope of this thread please let me know, I don't want to derail the thread.  I figure this would be the same setup to use for any of the other PVR backends though...  so it *might* be releventHuh 
drop me a dm if needed, keep post clean
I am unable to DM, I'd be very, very interested. I've lost almost a week trying to figure it out.
Reply
Is there a way to stop vod being updated?
Reply
I know this might be a pipe dream but any chance we could get AirTV support added?
If someone's post helps you out, click the thank user button.
Reply
(2020-07-13, 23:34)lasers Wrote:
(2020-07-12, 23:55)feerlessleadr Wrote:
(2020-07-12, 23:08)lasers Wrote: I was able to work around the above issue by disabling the VOD service in settings.xml.

I'm also noticing every time I reboot, IPTV simple loses the EPG/channel information. It still is present in the sqlite database though...
I would have expected that it would fallback to cache if the slinger service fails. For whatever reason when IPTV-simple requests the m3u or xml file, it's blank.

Glad I'm not the only one. Mind sharing what you modified in the settings.xml to disable?

Thanks
It turns out this didn't work right. Oddly a users fork seems to be working just fine... https://github.com/snoopyjoe/plugin.video.sling
The issue with the shows update hanging is usually because the shows has invalid timestamps or characters in them. @d21spike has resolved this issue before but every time a new show with invalid data is added to Sling, the issue reappears. I just set the VOD and Show update service intervals to 30 days, then manually update any show just before I click to watch it.

Also, I'm not sure how my fork resolves this as the only changes in it is when and where the PVR manager is restarted after the slinger service updates the guide. I abandoned the idea and turned the function into a service addon. That way if you're running two or more PVR clients, the PVR switch can restart the guide after the slinger service has started. This usually isn't a problem if you're only running IPTV PVR client. The service addon can be found here... PVR Switch
Reply
(2020-07-12, 23:55)feerlessleadr Wrote:
(2020-07-12, 23:08)lasers Wrote: I was able to work around the above issue by disabling the VOD service in settings.xml.

I'm also noticing every time I reboot, IPTV simple loses the EPG/channel information. It still is present in the sqlite database though...
I would have expected that it would fallback to cache if the slinger service fails. For whatever reason when IPTV-simple requests the m3u or xml file, it's blank.

Glad I'm not the only one. Mind sharing what you modified in the settings.xml to disable?

Thanks
I was able to figure this out. The error happens with the Amazing Mysteries show because the JSON blob is using a key that the show.py script isn't expecting within 'thumbnail'.

Here is an Amazing Mysteries episode that is being parsed: 
{
    "airings": [{
        "ratings": [
            "US_MPAA_UR"
        ],
        "_href": "http://cbd46b77.cdn.cms.movetv.com/cms/publish3/asset/info/e57c565f7ebe44849e323ba6dd23deb8.json",
        "title": "Amazing Mysteries",
        "program_id": 2168738,
        "source_id": 1442,
        "vendor_content_id": "LLVAL014MAG_Bonus",
        "has_blackouts": false,
        "duration": 2909.01,
        "external_id": "e57c565f7ebe44849e323ba6dd23deb8",
        "availability": [{
                "channel_id": 1885,
                "channel_guid": "246b3ad254b34b0498682688d8fab675",
                "stop": "2030-07-11T03:59:00Z",
                "start": "2020-03-16T04:01:00Z",
                "availability_type": "svod",
                "qvt": "http://cbd46b77.cdn.cms.movetv.com/cms/publish3/entitlement/asset/efc89fb7371e4bfe9968495e6a684d50/e57c565f7ebe44849e323ba6dd23deb8.qvt"
            },
            {
                "channel_id": 1885,
                "channel_guid": "246b3ad254b34b0498682688d8fab675",
                "stop": "2030-07-11T03:59:00Z",
                "start": "2020-03-16T04:01:00Z",
                "availability_type": "svod",
                "qvt": "http://cbd46b77.cdn.cms.movetv.com/cms/publish3/entitlement/asset/2b51540c9ed84863804a037e73d940c6/e57c565f7ebe44849e323ba6dd23deb8.qvt"
            }
        ],
        "airing_id": 43933715
    }],
    "ratings": [
        "US_MPAA_UR"
    ],
    "background_image": {
        "url": "http://p-img.movetv.com/cms/images/bbe93e4711deffaf18e69997eb76f73c76fcf05a.jpg",
        "h": 1080,
        "credit_short": null,
        "w": 1920,
        "credit_full": null
    },
    "guid": "dbb2bfd7ff784a72aa901be16bfa8585",
    "description": "Dinosaurs became extinct 65 million years ago. Was it triggered by an asteroid impact? Global volcanic activity?  A worldwide flood? The fossil records show something different. What really happened?      ",
    "name": "Dinosaur Extinction: What Killed the Dinosaurs?",
    "thumbnail": {
        "url": "http://p-img.movetv.com/cms/images/bbe93e4711deffaf18e69997eb76f73c76fcf05a.jpg",
        "h": 1080,
        "credit_short": null,
        "w": 1920,
        "credit_full": null
    },
    "episode_number": 3,
    "type": "episode",
    "id": 2168738,
    "_href": "http://cbd46b77.cdn.cms.movetv.com/cms/api/programs/dbb2bfd7ff784a72aa901be16bfa8585"
}

Here is a normal JSON blob of a different show/episode: 
{
    "airings": [{
        "ratings": [
            "US_UPR_TV-G"
        ],
        "_href": "http://cbd46b77.cdn.cms.movetv.com/cms/publish3/asset/info/1a41eb1d985641a782a17fe16b9d1756.json",
        "title": "Adopt",
        "program_id": 2505612,
        "source_id": 1603,
        "vendor_content_id": "DOGP0000000000009163",
        "has_blackouts": false,
        "duration": 294.53,
        "external_id": "1a41eb1d985641a782a17fe16b9d1756",
        "availability": [{
                "channel_id": 1467,
                "channel_guid": "de24cb792ce14252860ef3a7e1ab6fad",
                "stop": "2024-05-06T03:59:59Z",
                "start": "2020-05-05T04:01:00Z",
                "availability_type": "svod",
                "qvt": "http://cbd46b77.cdn.cms.movetv.com/cms/publish3/entitlement/asset/6fb84893343d4ee89ebadb45d0c5d605/1a41eb1d985641a782a17fe16b9d1756.qvt"
            },
            {
                "channel_id": 2056,
                "channel_guid": "354260716fd4486d9dd4cd979fb02cac",
                "stop": "2024-05-06T03:59:59Z",
                "start": "2020-05-05T04:01:00Z",
                "availability_type": "svod",
                "qvt": "http://cbd46b77.cdn.cms.movetv.com/cms/publish3/entitlement/asset/d9184b7fece64017b1cb25cf4d246979/1a41eb1d985641a782a17fe16b9d1756.qvt"
            }
        ],
        "airing_id": 49518559
    }],
    "ratings": [
        "US_UPR_TV-G"
    ],
    "background_image": {
        "h": 1440,
        "href": "http://p-img.movetv.com/cms/images/31c326b6eed9d77597dac322221fee7c6035671b.jpg",
        "credit_short": null,
        "w": 2560,
        "credit_full": null
    },
    "guid": "d0e557969fb84b1599a0757cb9ac04d4",
    "description": "DOGTV is working with rescues across the US to get dogs adopted. Adopt a dog now and get a great adoption kit. Season 2 episode 23",
    "name": "Adopt S02E23",
    "thumbnail": {
        "h": 1440,
        "href": "http://p-img.movetv.com/cms/images/31c326b6eed9d77597dac322221fee7c6035671b.jpg",
        "credit_short": null,
        "w": 2560,
        "credit_full": null
    },
    "episode_number": 23,
    "type": "episode",
    "id": 2505612,
    "_href": "http://cbd46b77.cdn.cms.movetv.com/cms/api/programs/d0e557969fb84b1599a0757cb9ac04d4"
}

The show.py script expects that the thumbnail section contain the key 'href'. In the broken episode it's 'url'.
I fixed mine by editing the show.py script directly like so:
204     def processEpisode(self, episode, new_season, new_show, episode_query):
205         timestamp = int(time.time())
206         log(json.dumps(episode, indent=4))
207         new_episode = {
208             'GUID': episode['guid'],
209             'ID': int(episode['id']),
210             'Show_GUID': new_show['GUID'],
211             'Season_GUID': new_season['GUID'],
212             'Name': episode['name'],
213             'Number': int(episode['episode_number']) if 'episode_number' in episode else episode['guid'],
214             'Description': '',
215             'Thumbnail': new_season['Thumbnail'],
216             'Poster': new_show['Poster'],
217             'Rating': '',
218             'Start': 0,
219             'Stop': 0,
220             'Duration': 0,
221             'Playlist_URL': '',
222             'infoLabels': {},
223             'infoArt': {}
224         }
225 
226         if 'description' in episode:
227             if episode['description'] is not None:
228                 new_episode['Description'] = episode['description']
229         if 'thumbnail' in episode:
230             if 'url' in episode['thumbnail']:
231                 new_episode['Thumbnail'] = episode['thumbnail']['url']
232             elif episode['thumbnail'] is not None:
233                 new_episode['Thumbnail'] = episode['thumbnail']['href']
234         if 'background_image' in episode:
235             if 'url' in episode['thumbnail']:
236                 new_episode['Poster'] = episode['background_image']['url']
237             elif episode['background_image'] is not None:
238                 new_episode['Poster'] = episode['background_image']['href']
239 
240         for airing in episode['airings']:

I could open a bug report or create a PR but I'm sure there is a better way to fix this...
Reply
(2020-07-16, 21:33)lasers Wrote: grumpy mod edit - What I said above...
You can also easily test the fix by navigating in the application to: Shows --> Shows A-G --> Right click Amazing mysteries --> Update Show
Reply
If you're going to include long items of code, please consider using our pastebin site for them instead of filling up the forum database.

And if you're doing to just add a single line, please don't quote the whole thing again. Edit your post and add it at the end.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
(2020-07-16, 21:33)lasers Wrote:
(2020-07-12, 23:55)feerlessleadr Wrote:
(2020-07-12, 23:08)lasers Wrote: I was able to work around the above issue by disabling the VOD service in settings.xml.

I'm also noticing every time I reboot, IPTV simple loses the EPG/channel information. It still is present in the sqlite database though...
I would have expected that it would fallback to cache if the slinger service fails. For whatever reason when IPTV-simple requests the m3u or xml file, it's blank.

Glad I'm not the only one. Mind sharing what you modified in the settings.xml to disable?

Thanks
I was able to figure this out. The error happens with the Amazing Mysteries show because the JSON blob is using a key that the show.py script isn't expecting within 'thumbnail'.

Here is an Amazing Mysteries episode that is being parsed: 

Here is a normal JSON blob of a different show/episode: 


The show.py script expects that the thumbnail section contain the key 'href'. In the broken episode it's 'url'.
I fixed mine by editing the show.py script directly like so:


I could open a bug report or create a PR but I'm sure there is a better way to fix this...

Do you think you could post your entire show.py to pastebin or something similar? I have a feeling the numbers on the rows are messing up my copy/paste, as I get a sling error when I start up kodi w/ the changes to the file.
Reply
(2020-07-16, 23:30)feerlessleadr Wrote:
(2020-07-16, 21:33)lasers Wrote:
(2020-07-12, 23:55)feerlessleadr Wrote: Glad I'm not the only one. Mind sharing what you modified in the settings.xml to disable?

Thanks
I was able to figure this out. The error happens with the Amazing Mysteries show because the JSON blob is using a key that the show.py script isn't expecting within 'thumbnail'.

Here is an Amazing Mysteries episode that is being parsed: 

Here is a normal JSON blob of a different show/episode: 


The show.py script expects that the thumbnail section contain the key 'href'. In the broken episode it's 'url'.
I fixed mine by editing the show.py script directly like so:


I could open a bug report or create a PR but I'm sure there is a better way to fix this...

Do you think you could post your entire show.py to pastebin or something similar? I have a feeling the numbers on the rows are messing up my copy/paste, as I get a sling error when I start up kodi w/ the changes to the file.

Here you go: https://paste.kodi.tv/equbucuyew
Reply
(2020-07-17, 14:40)lasers Wrote:
(2020-07-16, 23:30)feerlessleadr Wrote:
(2020-07-16, 21:33)lasers Wrote: I was able to figure this out. The error happens with the Amazing Mysteries show because the JSON blob is using a key that the show.py script isn't expecting within 'thumbnail'.

Here is an Amazing Mysteries episode that is being parsed: 

Here is a normal JSON blob of a different show/episode: 


The show.py script expects that the thumbnail section contain the key 'href'. In the broken episode it's 'url'.
I fixed mine by editing the show.py script directly like so:


I could open a bug report or create a PR but I'm sure there is a better way to fix this...

Do you think you could post your entire show.py to pastebin or something similar? I have a feeling the numbers on the rows are messing up my copy/paste, as I get a sling error when I start up kodi w/ the changes to the file.

Here you go: https://paste.kodi.tv/equbucuyew
Thanks! looks like it worked perfectly
Reply
Has anyone figured out a real workaround for no audio on some channels (usually starz/showtime/epix)? I've found that 90% of the time the channel has no sound when first selecting it but I can switch to a non-premium channel and then switch back and it will work--most of the time. Happens on all 5 of my (varying) devices.

Is this an inputstream.adaptive issue or is there any possibility of it being a bug in the addon?
Reply
Having an issue with sling. Nothing will play. For some reason, the plugin is getting a 404 error. Is anyone else getting a similar issue? Here is a snippet of my log:
Quote:2020-07-31 12:01:06.128 T:18910  NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.sling/?url=http%3A%2F%2Fcbd46b77.cdn.cms.movetv.com%2Fcms%2Fapi%2Fchannels%2F2a915617329d4e87b5a83b68c39b9229%2Fschedule%2Fnow%2Fplayback_info.qvt&mode=play&name=BBC+America
2020-07-31 12:01:06.129 T:19202  NOTICE: Creating InputStream
2020-07-31 12:01:06.220 T:19202   ERROR: AddOnLog: InputStream Adaptive: Key system request: com.widevine.alpha
2020-07-31 12:01:08.703 T:19202  NOTICE: Creating Demuxer
2020-07-31 12:01:08.717 T:19202  NOTICE: Opening stream: 1001 source: 256
2020-07-31 12:01:09.062 T:19202  NOTICE: Creating video codec with codec id: 27
2020-07-31 12:01:09.087 T:19202  NOTICE: CDVDVideoCodecAndroidMediaCodec::Open: Secure decoder requested: false (stream flags: 0)
2020-07-31 12:01:09.087 T:19202  NOTICE: CDVDVideoCodecAndroidMediaCodec::Open Testing codec:OMX.Nvidia.mp2.decoder
2020-07-31 12:01:09.088 T:19202  NOTICE: CDVDVideoCodecAndroidMediaCodec::Open Testing codec:OMX.Nvidia.wma.decoder
2020-07-31 12:01:09.088 T:19202  NOTICE: CDVDVideoCodecAndroidMediaCodec::Open Testing codec:OMX.Nvidia.h264.decode
2020-07-31 12:01:09.203 T:19202  NOTICE: Creating video thread
2020-07-31 12:01:09.205 T:19225  NOTICE: running thread: video_thread
2020-07-31 12:01:09.218 T:19202  NOTICE: Opening stream: 1002 source: 256
2020-07-31 12:01:09.328 T:19202  NOTICE: Finding audio codec for: 86018
2020-07-31 12:01:09.421 T:19202  NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder aac
2020-07-31 12:01:09.430 T:19202  NOTICE: Creating audio thread
2020-07-31 12:01:09.430 T:19232  NOTICE: running thread: CVideoPlayerAudio:Tonguerocess()
2020-07-31 12:01:09.631 T:19211   ERROR: AddOnLog: InputStream Adaptive: Download http://p-cdn1-803-cg14-linear-cbd46b77.m...fffffa.m4s failed with error: 404
2020-07-31 12:01:20.973 T:19228   ERROR: Previous line repeats 10 times.
2020-07-31 12:01:20.973 T:19228   ERROR: AddOnLog: InputStream Adaptive: Download http://p-cdn1-803-cg14-linear-cbd46b77.m...fffffa.m4s failed with error: 404
2020-07-31 12:01:32.168 T:19202   ERROR: Previous line repeats 10 times.
2020-07-31 12:01:32.168 T:19202  NOTICE: CVideoPlayer::OnExit()
2020-07-31 12:01:32.168 T:19202  NOTICE: VideoPlayer: eof, waiting for queues to empty
2020-07-31 12:01:32.168 T:19202  NOTICE: Closing stream player 1
2020-07-31 12:01:32.169 T:19202  NOTICE: Waiting for audio thread to exit
2020-07-31 12:01:32.170 T:19232  NOTICE: thread end: CVideoPlayerAudio::OnExit()
2020-07-31 12:01:32.170 T:19202  NOTICE: Closing audio device
2020-07-31 12:01:32.170 T:19202  NOTICE: Deleting audio codec
2020-07-31 12:01:32.186 T:19202  NOTICE: Closing stream player 2
2020-07-31 12:01:32.186 T:19202  NOTICE: waiting for video thread to exit
2020-07-31 12:01:32.188 T:19225  NOTICE: thread end: video_thread
2020-07-31 12:01:32.188 T:19202  NOTICE: deleting video codec
2020-07-31 12:01:32.264 T:18910  NOTICE: CVideoPlayer::CloseFile()
2020-07-31 12:01:32.266 T:18910  NOTICE: VideoPlayer: waiting for threads to exit
2020-07-31 12:01:32.266 T:18910  NOTICE: VideoPlayer: finished waiting
2020-07-31 12:01:32.266 T:18910  NOTICE: CVideoPlayer::CloseFile()
2020-07-31 12:01:32.266 T:18910  NOTICE: VideoPlayer: waiting for threads to exit
2020-07-31 12:01:32.266 T:18910  NOTICE: VideoPlayer: finished waiting
2020-07-31 12:01:33.303 T:19195 WARNING: Attempt to use invalid handle 9
I tried clicking on the stream url, and this came up:
Quote:{ "status": 404, "status_string": "Not Found", "message": "Request for stream 91735abcd31011ea8d120025b547220f segment 0xfffffffa is beyond the stream end (0x351b; limit 0x351c)" }
Reply
Went ahead and pulled a fresh log to speed things up:

https://paste.kodi.tv/ayawudupuw.kodi
Reply
(2020-07-31, 19:23)lhassell Wrote: Went ahead and pulled a fresh log to speed things up:

https://paste.kodi.tv/ayawudupuw.kodi

Just wondering if anyone has seen this. Anyone here?
Reply
  •   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  •   



Logout Mark Read Team Forum Stats Members Help
Sling0
This forum uses Lukasz Tkacz MyBB addons.