How to run pocketcdg?
#1
This is a parallel problem to my inability to get pocketcdg to install on linux (see 351092 (thread) ).

On my MacOS computer, I was able to install pocketcdg.

Unfortunately, I can't seem to find out how to run it from within Kodi.  Pocketcdg doesn't show up under Games or Add-ons.  How to I run it within Kodi?
Reply
#2
same problem
Reply
#3
(2020-01-19, 20:48)mmcmonster Wrote: This is a parallel problem to my inability to get pocketcdg to install on linux (see 351092 (thread) ).

On my MacOS computer, I was able to install pocketcdg.

Unfortunately, I can't seem to find out how to run it from within Kodi.  Pocketcdg doesn't show up under Games or Add-ons.  How to I run it within Kodi?

You can install it with this unofficial repository.
Image

After it's installed, it should show up in Addons>Game Addons>Emulators
Image

You do need the game.libretro addon installed, which should be available in the official repository. From your linux command line:

sudo add-apt-repository ppa:team-xbmc/xbmc-nightly
sudo apt-get update
sudo apt-get install kodi-game-libretro

Edit: I see your other post did these steps. What version of game.libretro does kodi show is installed?
Reply
#4
(2020-01-19, 23:25)zachmorris Wrote: [...]
After it's installed, it should show up in Addons>Game Addons>Emulators
Image

[...]

Thanks for the reply.  As mentioned in the other thread, I was able to get pocketcdg installed.  Problem was that I had to install kodi from the same repository as libretro.

But, once it's installed, I cannot find it (either on MacOS or Linux) in Addons>Game Addons>Emulators.  I do see it in Sprocket->Add ons->My add-ons->Game add-ons->Emulators.

Unfortunately, from that location, the image looks identical to the image you posted above.  ie: the Run icon is greyed out.  Does it require something in addition to be active?
Reply
#5
While I still can't get PocketCDG to show up in the Game add-ons menu, I did find a workaround:

1. Sprocket>File Manager> <select the directory with your .cdg/.mp3 files>
2. Instead of entering the karaoke file directory, use the contect menu to "Add to favourites".
3. Favourites>Karaoke directory> Select file with .cdg extension.  This will load PocketCDG and (after a warning regarding how to get to the game menu) play the mp3 and cdg correctly.

Anyone know how to get rid of that warning splash screen?
Reply
#6
(2020-01-20, 13:18)mmcmonster Wrote:
(2020-01-19, 23:25)zachmorris Wrote: [...]
After it's installed, it should show up in Addons>Game Addons>Emulators
Image

[...]

Thanks for the reply.  As mentioned in the other thread, I was able to get pocketcdg installed.  Problem was that I had to install kodi from the same repository as libretro.

But, once it's installed, I cannot find it (either on MacOS or Linux) in Addons>Game Addons>Emulators.  I do see it in Sprocket->Add ons->My add-ons->Game add-ons->Emulators.

Unfortunately, from that location, the image looks identical to the image you posted above.  ie: the Run icon is greyed out.  Does it require something in addition to be active?

Maybe the confusion is that there is no standalone emulator / addon to run (which is why it's greyed out). It's just another 'player' added to your Kodi installation. This particular one will play cdg files, so you just need to browse to a CDG file and try to play it:
1) Have some MPG and CDG files to play (two separate files with the same exact name, one mp3 one cdg)
2) Under the Games tab in Kodi, add a source pointing to the directory your MP3+CDG files are located - Note it's under Games because PocketCDG is a 'games' addon
3) Select the Games tab, browse to your added source. You should see the CDG files displayed. Select the one you want and it should automatically start
Image
Image


(2020-01-20, 14:48)mmcmonster Wrote: Anyone know how to get rid of that warning splash screen?

The splash screen I think you're referring to is for game playback controls (if you were using a controller). It should only show the first time you play the game/song. There's currently no way to prevent that from popping up the first time (although that is a good idea to add to Kodi).
Reply
#7
Going to reply to myself so that others that are trying to get Karaoke on Kodi to work can get some direction here. :-)

So I got PocketCDG to install correctly on my desktop Linux using the above method (using the nightly repository and then install both kodi and kodi-game-libretro).

Then I was able to get it to run by using the Kodi file manager (Sprocket->File manager), and saving the parent folder as a Favourite.

Then I noticed that it worked for local .mp3/.cdg files, but gave an error when the files are elsewhere on the network.  I haven't figured out how to solve this problem, except to copy all my karaoke files to the local drive.  Works for me. (*shrug*)

Then I tried to reproduce my install on Intel 64bit LibreELEC, as that's what I've got installed on my computer next to the TV.  I downloaded PocketCDG from the LibreELEC x86-64 repository: https://github.com/zach-morris/kodi_libr...s-for-kodi

Was able to find and install PocketCDG from this repo easily enough.

Running into a problem trying to run it on LibreELEC, however.
   When I use the File Manager to load a remote .cdg, it throws up an error: 'The emulator "PocketCDG" had an internal error.'
   When I use the File Manager to load a local .cdg, the screen becomes black and nothing happens.  System is effectively hung, except I can remote in and reboot or kill the kodi process.
Reply
#8
(2020-01-21, 21:37)mmcmonster Wrote: Going to reply to myself so that others that are trying to get Karaoke on Kodi to work can get some direction here. :-)

I think there's likely not much that can be done to fix the issue until the addon is built by Kodi officially. A debug log would help though.
Reply
#9
(2020-01-20, 17:18)zachmorris Wrote: The splash screen I think you're referring to is for game playback controls (if you were using a controller).

It should only show the first time you play the game/song. There's currently no way to prevent that from popping up the first time (although that is a good idea to add to Kodi). 

When the splash is shown, it sets a hidden "show splash" setting to False. Simply ship an advanced setting that defaults this to False, and the splash won't be shown unless no controllers are attached in a non-keyboard emulator.

Do you want me to track down the exact advancedsettings.xml line you need?
Reply
#10
(2020-02-05, 19:59)garbear Wrote:
(2020-01-20, 17:18)zachmorris Wrote: The splash screen I think you're referring to is for game playback controls (if you were using a controller).

It should only show the first time you play the game/song. There's currently no way to prevent that from popping up the first time (although that is a good idea to add to Kodi). 

When the splash is shown, it sets a hidden "show splash" setting to False. Simply ship an advanced setting that defaults this to False, and the splash won't be shown unless no controllers are attached in a non-keyboard emulator.

Do you want me to track down the exact advancedsettings.xml line you need?

Thanks, I was able to 'fix' this for pocketcdg by adding the keyboard as a possible controller (in actuality there's no control at all since it's just playback).
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
How to run pocketcdg?00