Aeon NOX Silvo - GameFlix views for AML plugin
#46
Rychem, it looks like I'm having a very strange issue and Im not sure if it is skin related or what.  When I launch any rom that is set to kodi retroplayer, the game appears to start ( Or at least kodi creates a savestate aftewards) but the game doesn't render to the window.  Switching skins back to Aeon Nox silvo seems to fix the issue.  I can't be certain it is a skin issue but I was wondering if you might have some insight into the issue.  
Here is a link to my log paste https://pastebin.com/AdPaDBw3  and below is a log entry snippet that appears to show something having trouble rendering the picture.  
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() romfile      "F:\Game Files\Sega_Genesis\3 Ninjas Kick Back (USA).md"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() rompath      "F:\Game Files\Sega_Genesis"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() rombase      "3 Ninjas Kick Back (USA).md"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() rombasenoext "3 Ninjas Kick Back (USA)"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() romtitle     "3 Ninjas Kick Back (USA)"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() application  "retroplayer_launcher_app"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() apppath      ""
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() romext       "md"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : Launching app found "retroplayer_launcher_app"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : ROM found "F:\Game Files\Sega_Genesis\3 Ninjas Kick Back (USA).md"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() raw arguments   "%rom%"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL INFO : _command_run_rom() final arguments "F:\Game Files\Sega_Genesis\3 Ninjas Kick Back (USA).md"
2020-06-28 21:53:22.707 T:14212   ERROR: AEL VERB : fs_load_Collection_ROMs_JSON() special://profile/addon_data\plugin.program.advanced.emulator.launcher\history.json
2020-06-28 21:53:22.713 T:14212   ERROR: AEL VERB : fs_write_Collection_ROMs_JSON() File special://profile/addon_data\plugin.program.advanced.emulator.launcher\history.json
2020-06-28 21:53:22.744 T:14212   ERROR: AEL VERB : fs_load_Favourites_JSON() File special://profile/addon_data\plugin.program.advanced.emulator.launcher\most_played.json
2020-06-28 21:53:22.755 T:14212   ERROR: AEL INFO : fs_write_Favourites_JSON() File special://profile/addon_data\plugin.program.advanced.emulator.launcher\most_played.json
2020-06-28 21:53:22.815 T:14212   ERROR: AEL INFO : _command_run_rom() Executing ROM with Kodi Retroplayer ...
2020-06-28 21:53:22.828 T:14212   ERROR: AEL INFO : _command_run_rom() application.getOriginalPath() "retroplayer_launcher_app"
2020-06-28 21:53:22.828 T:14212   ERROR: AEL INFO : _command_run_rom() ROMFileName.getPath()         "F:\Game Files\Sega_Genesis\3 Ninjas Kick Back (USA).md"
2020-06-28 21:53:22.828 T:14212   ERROR: AEL INFO : _command_run_rom() label_str                     "3 Ninjas Kick Back (USA).md"
2020-06-28 21:53:22.828 T:14212   ERROR: AEL VERB : _command_run_rom() Calling xbmc.Player().play() ...
2020-06-28 21:53:22.828 T:14212   ERROR: AEL VERB : _command_run_rom() Calling xbmc.Player().play() returned. Leaving function.
2020-06-28 21:53:22.831 T:14212   ERROR: AEL DEBUG: Advanced Emulator Launcher run_protected() END
2020-06-28 21:53:22.831 T:14212   ERROR: AEL DEBUG: SingleInstance::__exit__() Releasing lock
2020-06-28 21:53:22.832 T:14212   ERROR: AEL DEBUG: Advanced Emulator Launcher run_plugin() exit
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_input1
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): invalid picodrive_input: ''
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_input2
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): invalid picodrive_input: ''
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_sprlim
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_ramcart
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_region
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_aspect
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_overscan
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_overclk68k
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_drc
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_audio_filter
2020-06-28 21:53:25.289 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): Unknown setting ID: picodrive_lowpass_range
2020-06-28 21:53:25.294 T:13536   ERROR: AddOnLog: Sega - MS/MD/CD/32X (PicoDrive): warning: wanted to map @02000000, got 0000024617350000
2020-06-28 21:53:29.485 T:13536   ERROR: RetroPlayer[SAVE]: Failed to load savestate
2020-06-28 21:53:29.629 T:13536   ERROR: Control 805 in window 10001 has been asked to focus, but it can't
2020-06-28 21:53:34.629 T:11396  NOTICE: EMBY.objects.monitor -> [ xbmc/Player.OnAVStart ]
2020-06-28 21:53:34.693 T:11396  NOTICE: EMBY.objects.monitor -> [ xbmc/Player.OnStop ]
2020-06-28 21:53:34.809 T:11396  NOTICE: Previous line repeats 1 times.
Reply
#47
Let me have a look at this, I don't see anything in the log that stands out as an issue, So not sure at the moment how to proceed.

Cheers.
Reply
#48
I'll turn on some extra debugging and post new ulogs after I ttry uninstalling and reinstalling the skin
Reply
#49
So i do see an item in the log that says the view tried to focus but couldn't. I think this may be the issue, but I need to see if I can figure out why this is happening. I think it may have to do with the imagery being displayed, found a couple of forum posts describing the same issue. Stay tuned.
Reply
#50
Jachin, can you try the latest version on the git. I have made a change to the Portrait mode view to see if I can rectify the skin not coming back into focus. One question I did have is are the trailers playing when launching a game and you are using the Kodi built-in retroplayer when the issue occurs. Any issues with AEL? I think the problem may be interfacing with the Kodi built-in RetroPlayer (skin issue).

Cheers.
Reply
#51
Rychem, im away from my machine for a while but I'll try your changes either this weekend or early next week. Thanks
Reply
#52
I had a chance to try your change but things still aren't working correctly.  The good news is that games WILL launch from widgets, the list view, and the icon view.  The bad news is that they will not launch from any of the gameflix views.  In the log below, I first launched a game from a widget, and it was successful.  I then launched a few games from gameflix views and was not successful.  The last game launch was from the icon view, and that was successful.  Thanks. 
Logs can be found here https://pastebin.com/gT0rYc3X
Reply
#53
Thanks for the feedback. This might take me a bit to figure out, I am not sure why the skin wouldn't be allowing the execution of the plugin. I will need to install AEL and see if I can replicate the issue. As I don't see anything in the log that points to the potential issue. I will keep you posted.

Cheers.
Reply
#54
Jachin, I am not sure I am anycloser to figuring out what is going on. Can you do me a favour and disable the trailers being shown on the main page and let me know if that makes any difference. That was the last change that I made to the skin and I think it coincides with the issues you are seeing. Simply disabling the trailers should be enough. I am interested to see what you experience.

Cheers,
Reply
#55
(2020-07-28, 19:51)Rychem28 Wrote: @Jachin99, I am not sure I am anycloser to figuring out what is going on. Can you do me a favour and disable the trailers being shown on the main page and let me know if that makes any difference. That was the last change that I made to the skin and I think it coincides with the issues you are seeing. Simply disabling the trailers should be enough. I am interested to see what you experience.

Cheers,
Reply
#56
Rychem I have tried disabling trailers, and uninstalling and reinstalling the skin but nothing has made a difference
Reply
#57
@Jachin99
Can you try the latest revision on the git for the skin? I have rolled back a couple of changes I made prior to you starting to see issues. I am interested to see if this resolves what you are seeing. Using the skin with AML, I don't see any issue with focusing.

Thanks.
Reply



Logout Mark Read Team Forum Stats Members Help
Aeon NOX Silvo - GameFlix views for AML plugin0
This forum uses Lukasz Tkacz MyBB addons.