Music Scraping by cue
#1
Using Kodi 18.5 on Corelect 9.2.1.
I've read on the Wiki the section for musicextension and it should be possible, at least for the begin (need a month and a spare HDD to change the tag way on the actual library), to exclude .flac files from library indexing and force only a .cue reading for tags .

So i added on the advancedsettings.xml the lines

<musicextensions>
<add>.cue</add>
<remove>.flac|.wav</remove>
</musicextensions>

placed the file in the userdata folder, cancelled the old library, reboot, rescan... and no effect. Files are indexed not looking at the cue but only at the audio file tags.

I'm using as a test drive a thumbdrive with three album:
one that has the correct tags ONLY in the cue, so if it loads the tags from the separate tracks it's very clear that the cue isn't parsed
one that is a cue+single big file (that doesn't show the folder.jpg cover too)
one that is a compilation album in which the cue has the correct album infos and the single tracks have their original-album-sourced infos.

I have read on the forum that the music scraping has been changed a lot from v17 to v18, but the wiki is basically v17. Better to wait for updates in the wiki, or some suggestion?
Reply
#2
(2020-01-22, 11:09)Winopener Wrote: some suggestion?

Yeah, don't use cue files.  Cue file support is very limited and it won't be improved or worked on.  Much better to use your flac files and tag them properly. 

From the Wiki
Quote: However the information provided by the cue sheet standard is much more limited than that of standard tagging, hence to enjoy the full music library features it is recommended that tracks are ripped into separate files and fully tagged.
Learning Linux the hard way !!
Reply
#3
(2020-01-22, 11:20)black_eagle Wrote:
(2020-01-22, 11:09)Winopener Wrote: some suggestion?

Yeah, don't use cue files.  Cue file support is very limited and it won't be improved or worked on.  Much better to use your flac files and tag them properly. 
That's for sure, the .cue question was a way to use the library meanwhile, since it is a very large one and it would need a lot of time to re-parse it in a kodi-friendly way.
Reply
#4
OK, that sounds reasonable.  Can you get a debug log (wiki) of you scanning those three albums into the library then ?  Maybe that will provide some clues as to what is or isn't happening.  Make sure those albums are removed from your library first.  Put kodi into debugging mode and then restart it and do the scan.  By restarting first, it'll show if there are any issues with the advancedsettings file.  There probably aren't but it's wise to check everything.

Full instructions for producing the debug log are here -> https://kodi.wiki/view/Log_file/Easy
Learning Linux the hard way !!
Reply
#5
(2020-01-22, 11:09)Winopener Wrote: So i added on the advancedsettings.xml the lines

<musicextensions>
<add>.cue</add>
<remove>.flac|.wav</remove>
</musicextensions>

placed the file in the userdata folder, cancelled the old library, reboot, rescan... and no effect. Files are indexed not looking at the cue but only at the audio file tags.

This will never work to achieve what you want. That advanced setting purely controls what Kodi sees as a valid music file in the music section, so removing the flac extension will mean those files will never appear in the music section.
Reply
#6
Looking at the wiki what could work is excludefromscan see https://kodi.wiki/view/Advancedsettings.xml#audio

<advancedsettings>
<audio>
<!-- Regular expressions that if evaluated to true won't be added to library. -->
<excludefromscan>
<regexp>\.flac$</regexp>
</excludefromscan>
</audio>
</advancedsettings>

Not exactly sure that's the correct regex as I'm no regex expert, just used an example at https://forum.kodi.tv/showthread.php?tid...pid1488213
Reply
#7
(2020-01-27, 01:17)zzsszz Wrote: Yeah, don't use cue files

So you are reporting your own post for "Breaking forum rules"... It's not the best reason, but it does have a point: your reply totally makes no sense.

We are not waiting for useless replies or trolls on this forum. However, we will act whenever action is deemed necessary in such cases.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#8
(2020-01-22, 16:01)jjd-uk Wrote: Looking at the wiki what could work is excludefromscan see https://kodi.wiki/view/Advancedsettings.xml#audio
...
Not exactly sure that's the correct regex as I'm no regex expert, just used an example at https://forum.kodi.tv/showthread.php?tid...pid1488213

Works halfway, in this sense:
applying the excludefromscan to flac now it display correctly the test files on the Add file dialog, but these cannot be imported in the library.
(sorry for the delay... sick in bed)
Reply
#9
(2020-01-28, 23:56)Winopener Wrote:
(2020-01-22, 16:01)jjd-uk Wrote: Looking at the wiki what could work is excludefromscan see https://kodi.wiki/view/Advancedsettings.xml#audio
...
Not exactly sure that's the correct regex as I'm no regex expert, just used an example at https://forum.kodi.tv/showthread.php?tid...pid1488213

Works halfway, in this sense:
applying the excludefromscan to flac now it display correctly the test files on the Add file dialog, but these cannot be imported in the library.
(sorry for the delay... sick in bed) 
I think you're going to have to provide a debug log (wiki) if you want to see if this can be solved.
Learning Linux the hard way !!
Reply



Logout Mark Read Team Forum Stats Members Help
Music Scraping by cue0
This forum uses Lukasz Tkacz MyBB addons.