•   
  • 1
  • 36
  • 37
  • 38(current)
  • 39
  • 40
  • 48
  •   
[LINUX] XBMC for Linux port to ARM architecture CPU and SoC chips?
@christian667

We don't use the hw decoder on panda yet, which is why its not a supported platform..

Patches for that is welcomed

And it ran better than that for me purely on CPU, I could play SD content quite well, granted divx and not 1080p output resolution.
So you definatly need to use my omap overlay patches to get presentation speed up most likely, something I hope to have as a pull req before eden.
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
@topfs2:
Execuse me if I misunderstand you, but are there any patches yet?
You are the one who worked the google summer of code project for the beagleboard, aren't you? Smile
Are the omap overlay patches for the beagleboard working with the omap4?
Reply
yeah I worked on beagle gsoc, the omap patches for beagle should work, havent tested them yet though. omap4 supports a few more modes which would be very useful on panda to further optimize the omap patches
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
Great, where to find the patches and where to apply them? Smile
Reply
christian667 Wrote:Do you have any video playing in the regular "ubuntu classic" session?

Are you asking if I had other video player runing at the same time when I started XBMC? No. I ran XBMC only. So far I have pictures on XBMC now, just have to wait for about 10 seconds. The video has no improvement. When I play a video file, I still see nothing but hearing the sound only.
Reply
joyhsieh Wrote:Are you asking if I had other video player runing at the same time when I started XBMC? No. I ran XBMC only. So far I have pictures on XBMC now, just have to wait for about 10 seconds. The video has no improvement. When I play a video file, I still see nothing but hearing the sound only.

I found the information in my xbmc.log after running ./xbmc.bin:
Code:
15:36:15 T:1337508880 M:588460032   DEBUG: Open - av_find_stream_info finished
15:36:15 T:1337508880 M:588460032    INFO: ffmpeg[4FB8C410]: Input #0, mpeg, from '/home/ubuntu/Videos/test.MPG':
15:36:15 T:1337508880 M:588460032    INFO: ffmpeg[4FB8C410]:   Duration: 00:04:59.66, start: 0.000000, bitrate: 1393 kb/s
15:36:15 T:1337508880 M:588435456    INFO: ffmpeg[4FB8C410]:     Stream #0.0[0x1e0]: Video: mpeg1video, yuv420p, 352x240 [PAR 200:219 DAR 880:657], 1150 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 29.97 tbc
15:36:15 T:1337508880 M:588435456    INFO: ffmpeg[4FB8C410]:     Stream #0.1[0x1c0]: Audio: mp2, 44100 Hz, 2 channels, s16, 224 kb/s
15:36:15 T:1337508880 M:588435456  NOTICE: Opening video stream: 0 source: 256
15:36:15 T:1337508880 M:588435456  NOTICE: Creating video codec with codec id: 1
15:36:15 T:1337508880 M:588435456   DEBUG: CDVDFactoryCodec: compiled in hardware support: CrystalHD:no OpenMax:no VDPAU:no VAAPI:no
15:36:15 T:1337508880 M:588435456   DEBUG: FactoryCodec - Video:  - Opening
15:36:15 T:1337508880 M:588435456   DEBUG: SECTION:LoadDLL(special://xbmcbin/system/players/dvdplayer/swscale-0-arm.so)
15:36:15 T:1337508880 M:588435456   DEBUG: Loading: /home/ubuntu/xbmc/system/players/dvdplayer/swscale-0-arm.so
15:36:15 T:1337508880 M:588361728   DEBUG: SECTION:LoadDLL(special://xbmcbin/system/players/dvdplayer/avfilter-1-arm.so)
15:36:15 T:1337508880 M:588361728   DEBUG: Loading: /home/ubuntu/xbmc/system/players/dvdplayer/avfilter-1-arm.so
[color=Red][b]15:36:15 T:1337508880 M:588337152   ERROR: Unable to load /home/ubuntu/xbmc/system/players/dvdplayer/avfilter-1-arm.so, reason: swscale-0-arm.so: cannot open shared object file: No such file or directory[/b][/color]
15:36:15 T:1337508880 M:588337152   DEBUG: FactoryCodec - Video:  - Failed
15:36:15 T:1337508880 M:588337152   ERROR: Unsupported video codec
15:36:15 T:1337508880 M:588337152 WARNING: OpenVideoStream - Unsupported stream 0. Stream disabled.

But I do have /home/ubuntu/xbmc/system/players/dvdplayer/avfilter-1-arm.so
Code:
[email protected]:~/xbmc/system/players/dvdplayer$ ls -lah
total 23M
drwxr-xr-x 3 ubuntu ubuntu 4.0K 2011-06-29 14:36 .
drwxr-xr-x 4 ubuntu ubuntu 4.0K 2011-06-29 10:20 ..
-rwxr-xr-x 1 ubuntu ubuntu  17M 2011-06-29 14:36 avcodec-52-arm.so
-rwxr-xr-x 1 ubuntu ubuntu  51K 2011-06-29 14:36 avcore-0-arm.so
[color=Red][b]-rwxr-xr-x 1 ubuntu ubuntu 417K 2011-06-29 14:36 avfilter-1-arm.so[/b][/color]
-rwxr-xr-x 1 ubuntu ubuntu 4.5M 2011-06-29 14:36 avformat-52-arm.so
-rwxr-xr-x 1 ubuntu ubuntu 260K 2011-06-29 14:36 avutil-50-arm.so
drwxr-xr-x 3 ubuntu ubuntu 4.0K 2011-06-28 18:14 etc
-rwxr-xr-x 1 ubuntu ubuntu 110K 2011-06-29 10:20 libdvdcss-arm.so
-rwxr-xr-x 1 ubuntu ubuntu 655K 2011-06-29 10:20 libdvdnav-arm.so
-rwxr-xr-x 1 ubuntu ubuntu 137K 2011-06-29 14:36 postproc-51-arm.so
-rwxr-xr-x 1 ubuntu ubuntu 392K 2011-06-29 14:36 swscale-0-arm.so
[email protected]:~/xbmc/system/players/dvdplayer$

How to solve this problem?

Thanks.
Reply
joyhsieh Wrote:Are you asking if I had other video player runing at the same time when I started XBMC? No. I ran XBMC only. So far I have pictures on XBMC now, just have to wait for about 10 seconds. The video has no improvement. When I play a video file, I still see nothing but hearing the sound only.

You run the netbook-preinstalled do you? So you should select after booting the board "ubuntu classic" in GDM and try to play a file with the help of totem or mplayer..

EDIT:
@joyhsieh:
how did you compile the xbmc? ./configure..? Smile
Reply
christian667 Wrote:Great, where to find the patches and where to apply them? Smile

https://xbmc.svn.sourceforge.net/svnroot...agleboard/

Somewhere in the hundreds of patches I made Smile Its not a single patch and the fixes are spread out. If you aren't comfortable to find them in there its better to wait until I get to it, which I plan to have done in time for eden.
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
wuaaai - don't you have a collection of patches?
To figure out the diff's between the git and the gsoc release is nearly impossible for someone who didn't write that code ^^
Isn't there one or two "monsterpatches" that improve playback a "little"?
For me it would be enough to play sd content smooth for the first steps... Wink
Reply
christian667 Wrote:You run the netbook-preinstalled do you? So you should select after booting the board "ubuntu classic" in GDM and try to play a file with the help of totem or mplayer..

EDIT:
@joyhsieh:
how did you compile the xbmc? ./configure..? Smile

I have tried
./configure --enable-gles
./configure --enable-gles --disable-optical-drive
Both of them result in the same problem.
Reply
christian667 Wrote:wuaaai - don't you have a collection of patches?
To figure out the diff's between the git and the gsoc release is nearly impossible for someone who didn't write that code ^^
Isn't there one or two "monsterpatches" that improve playback a "little"?
For me it would be enough to play sd content smooth for the first steps... Wink

Thats why I haven't done it yet, I haven't had time to yank out the interesting parts and produce a patch. Its development, if you aren't comfortable with finding the patch in the code (or know how to code Smile ) you should probably wait until I get a chance to do it.

If it was easy and I had a specific patch I could have just as easily pushed it to master now couldn't I Wink
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
Oh yeah this is obvious...
Mh I know how to code but I'm not familiar with the xbmc one.
Is there a direction to look at? Any folder somehow? Wink
If I find the time (and skill..) to figure out the impovements you did,
i promiss to push back patches... Smile

@joyhsieh:
For me compiling as described in my post on the last pages worked quite well without any problems, but i use the opdenkamp source.

You all may have a look at this:

http://www.youtube.com/watch?v=ICfaBEv5plU
Reply
ps2chiper Wrote:They have a one on amazon for 169. But since I live in china, i got one from alibaba. From alibaba if you pose as an importer, you can get a sample from 70 to 100 dollars. Just search android tv cortex a9 in alibaba and you will see a few manufactures selling various versions all with the amlogic soc. I need to solder a max3232 chip to my board now.

Hi ps2chiper,

Would you be able to get hold of tablet based on Amlogic AML-8726M like Ramos W10 or its clones to see if you can boot linux provided by amlogic straight from them?

Apparently retail version of what you got like A3 from Mygica or A100 from geniatech are just too hard to find even in China. The Amlogic AML-8726M tablet has similar specs in terms of CPU, GPU, DSP and Memory but its very popular in China and this means you can get it easily with dirty cheap price ($100 for a Ramos W10 clone).

If someone can get xmbc running on devices based on Amlogic AML-8726 with reasonable speed and performance I may well tempted to replace my ageing ATV1 with that.
Reply
christian667 Wrote:Oh yeah this is obvious...
Mh I know how to code but I'm not familiar with the xbmc one.
Is there a direction to look at? Any folder somehow? Wink
If I find the time (and skill..) to figure out the impovements you did,
i promiss to push back patches... Smile

@joyhsieh:
For me compiling as described in my post on the last pages worked quite well without any problems, but i use the opdenkamp source.

You all may have a look at this:

http://www.youtube.com/watch?v=ICfaBEv5plU

I have no idea that why the program told me it can't find avfilter-1-arm.so, which is just at the position it wants.

Maybe the source is really an issue. I am going to try the opdenkamp source.
Reply
s7mx1 Wrote:Hi ps2chiper,

Would you be able to get hold of tablet based on Amlogic AML-8726M like Ramos W10 or its clones to see if you can boot linux provided by amlogic straight from them?

Apparently retail version of what you got like A3 from Mygica or A100 from geniatech are just too hard to find even in China. The Amlogic AML-8726M tablet has similar specs in terms of CPU, GPU, DSP and Memory but its very popular in China and this means you can get it easily with dirty cheap price ($100 for a Ramos W10 clone).

If someone can get XBMC running on devices based on Amlogic AML-8726 with reasonable speed and performance I may well tempted to replace my ageing ATV1 with that.

I don't want to turn this into a sales channel, but I think this is what you want. Its a shame that the bom cost of the amlogic is about 30 dollars and they raise the price to 169 on amazon. But thats life.

http://www.dealextreme.com/p/7-touch-scr...-4gb-72290
Reply
  •   
  • 1
  • 36
  • 37
  • 38(current)
  • 39
  • 40
  • 48
  •   



Logout Mark Read Team Forum Stats Members Help
[LINUX] XBMC for Linux port to ARM architecture CPU and SoC chips?7
This forum uses Lukasz Tkacz MyBB addons.