VRC-1100 remote Numpad keys map to Nvidia Shield
#1
I previously had an HTPC and I was using the VRC-1100 remote control that PC and never had any problems.

VRC-1100 (wiki)


I recently swapped out the HTPC for an Nvidia Shield, plugged in the USB IR receiver from the VRC1100, and copied over my keyboard.xml that I was using with the HTPC.  Some keys work fine others do not..

All of the items in the xml below that start with numpad do not work...  I suspect it's because the Android TV OS does not recognize the numpad keys on a keyboard..  When I press any of the number keys on the remote I can see the IR Receiver light up so it's definitely receiving the signal... but I guess  the Shield does not know what to do with it.

Is there any way to remap those keys to something that the Shield will understand? 
(I also tried it without mapping those keys in the keyboard.xml but same result it doesn't recognize the number keys on the remote as numbers)

<keymap>
  <global>
    <keyboard>
      <F5>AudioNextLanguage</F5>
      <e mod="ctrl">XBMC.ActivateWindow(Videos,TvShowTitles,return)</e>
      <r mod="ctrl">info</r>
      <t mod="ctrl,shift">XBMC.ActivateWindow(Videos,MovieTitles,return)</t>
      <o mod="ctrl">togglewatched</o>
      <i mod="ctrl">XBMC.ActivateWindow(Pictures)</i>
      <g mod="ctrl">XBMC.ActivateWindow(Videos,Addons,return)</g>
      <t mod="ctrl">contextmenu</t>
      <m mod="ctrl">XBMC.ActivateWindow(Music)</m>
      <m mod="ctrl,shift">Fullscreen</m>
      <prev_track>bigstepback</prev_track>
      <next_track>bigstepforward</next_track>
      <numpadtimes>nextsubtitle</numpadtimes>  
      <numpadone>Number1</numpadone>
      <numpadtwo>Number2</numpadtwo>
      <numpadthree>Number3</numpadthree>
      <numpadfour>Number4</numpadfour>
      <numpadfive>Number5</numpadfive>
      <numpadsix>Number6</numpadsix>
      <numpadseven>Number7</numpadseven>
      <numpadeight>Number8</numpadeight>
      <numpadnine>Number9</numpadnine>
      <numpadzero>Number0</numpadzero>

    </keyboard>
  </global>
  <mymusicplaylist>
    <keyboard>
      <play_pause>Pause</play_pause>
    </keyboard>
  </mymusicplaylist>
  <mymusicfiles>
    <keyboard>
      <play_pause>Pause</play_pause>
    </keyboard>
  </mymusicfiles>
  <mymusiclibrary>
    <keyboard>
      <play_pause>pause</play_pause>
    </keyboard>
  </mymusiclibrary>
</keymap>
Reply
#2
I haven't made any progress on this, but it is definitely a Kodi problem, not a Shield problem.  If I bring up the on screen keyboard on the shield the Numeric Buttons on the remote input numbers on the screen.

But if I press on the numeric keys on the remote with Kodi running there is no input.

I checked the Debug log, and the numeric key presses are not even recorded in the log...   First I pressed some keys on the bluetooth keyboard and I can see that those are getting recorded in the log... then I pressed the number keys on the remote and those are not being registered in the log at all...


I found a post with a similar problem on the Raspberry Pi, from many years ago... but I don't understand what this person did to fix it....

223937 (thread)


If anyone has some insight I would appreciate it....
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
VRC-1100 remote Numpad keys map to Nvidia Shield00