Important Attn: Addon Devs - Python 3 compatible addons
#21
(2020-03-03, 18:30)mediaminister Wrote: How hard can it be to make sure that addon.xml is also Py2/Py3 compatible so that add-on developers can submit a Py2/Py3 compatible add-on just once?

we've been trying to find someone who could implement that for over two years now... so my answer would be it is very hard.

(2020-03-03, 18:30)mediaminister Wrote: In my opinion the release of Kodi 19 should be postponed until Py2/Py3 compatibility in addon.xml is implemented the right way!

i beg to differ. frankly my opinion is that team kodi should have made sure kodi 19 was released before python 2 went end-of-life.
when a user installs kodi today, we install an unmaintained version of python with it... and that potentially opens up the users system to exploits.
it's not a situation i'm particularly proud of, and imo we should get v19 out of the door as quickly as possible.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply


Messages In This Thread
RE: Attn: Addon Devs - Python 3 compatible addons - by ronie - 2020-03-03, 23:19


Logout Mark Read Team Forum Stats Members Help
Attn: Addon Devs - Python 3 compatible addons0
This forum uses Lukasz Tkacz MyBB addons.