Important Attn: Addon Devs - Python 3 compatible addons
#22
It would have made sense to announce such a hard break at the Kodi 18 release rather than having devs waste a lot of time making the code py2&3 compatible (as was requested and required) and then flagging all these compatible addons as incompatible anyway.

On my Kodi19 installation, 41 addons are now deemed incompatible and have been forcefully disabled, even though almost all of them were working absolutely fine. Kodi doesn't let me enable them either. Rather than forcefully blocking them, there should be a way to at least manually reactivate them while displaying a warning that they may not work as expected. Or as suggested above, add an addon.xml attribute to mark compatible addons as py2&3 compatible and only disable addons that require py2 and do not have this flag. Addons requiring py3 don't need that flag and are fine anyway. This avoids having to maintain multiple versions of exactly the same codebase, submitted to multiple branches and avoids the mess.

I've picked up and worked on quite a few unmaintained addons and made them py3 compatible, then spent more time re-adding py2 support for the current Kodi18 users and now all of them stopped working again.
Reply


Messages In This Thread
RE: Attn: Addon Devs - Python 3 compatible addons - by AnonTester - 2020-03-05, 00:49


Logout Mark Read Team Forum Stats Members Help
Attn: Addon Devs - Python 3 compatible addons0
This forum uses Lukasz Tkacz MyBB addons.