Important Attn: Addon Devs - Python 3 compatible addons
#35
I need advice, how to organize a repository to automatically update all my add-ons when update Kodi from 18 to 19 without reinstalling all add-ons and dependencies?
I made two separate repositories: Kodi 14-18 and Kodi 19.
When I update from Kodi 18 to Kodi 19, all add-ons are disabled. When I try to update the main add-on, appears error "The dependency on xbmc.python version 2.19.0 could not be satisfied". It's because that the all dependencies are disabled, they are from Kodi 18 and they don't updates when I'm update main addon. So I have to manually update all the dependencies, then the main add-on.

Here is repository descriptions and repository structure.
My addons: Gismeteo
Reply


Messages In This Thread
RE: Attn: Addon Devs - Python 3 compatible addons - by vl_maksime - 2020-03-31, 20:39


Logout Mark Read Team Forum Stats Members Help
Attn: Addon Devs - Python 3 compatible addons0
This forum uses Lukasz Tkacz MyBB addons.